Announcement

Collapse
No announcement yet.

UE4 installs to a folder titled UE_4.xx....why is that?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • UE4 installs to a folder titled UE_4.xx....why is that?

    Everytime I have installed UE4 on my computer it has always installed to a folder titled the engine version (ie. 4.xx) and that is all. When I went to install 4.15, UE4 would only install it to a folder titled UE_4.15. Why is this? I have noticed that this has sometimes happened on other computers that I have installed UE4 on but not mine. Can someone please tell me if there is a fix for this so that I can install UE4 in just the version number folder?

    Oh and if I rename the folder to just 4.15 then the UE4 launcher won't see that I installed it and show that I would need to download it again.

    Thanks!
    Attached Files

  • #2
    The intention, I believed, is to not break existing game builds. If the engine itself is updated, there is a very high likelihood that your game builds will break on the newer engines, potentially even completely rendering the source code useless in worst case scenarios. Thus, if the engine versions were installed separately, such as UE_4.XX, or even UE_5.YY, then everything will be intact. Your game works, and there won't be any issues with engine version migrations.

    However, the downside is it takes up a lot of hard drive space. Especially with SSDs on (almost common) portable computers / 2-in-1 laplets (laptop/tablet) / Surface Pros.

    Comment


    • #3
      Is your question "how can I install 4.15 in a subfolder called "4.15" instead of "UE_4.15"" ?
      If so, what dependency do you have on the folder naming convention where this matters?
      Whatever that dependency is, I would initially think that there's probably a better way to do things where the exact folder name doesn't matter. (But, I could be wrong!)

      Comment


      • #4
        I'm having the same issue. I have an automated build environment that needs multiple UE versions at the same time (we're making a plugin, not a game), and my build scripts just stopped working with 4.15. The launcher allows us to install to any folder, but doesn't allow us to choose the name of the last folder in the directory structure...
        Benoit Santerre - Software developer, Audiokinetic Inc.

        Comment


        • #5
          I have an automated build environment that needs multiple UE versions at the same time
          If you have a list of version numbers, can't you just create that list with the correct names?

          make:
          UE_VERSIONS := 4.12 4.13 4.14 UE_4.15

          scons:
          UE_VERSION = [ "4.12", "4.13", "4.14", "UE_4.15" ]

          and so on ...

          Comment

          Working...
          X