Announcement

Collapse
No announcement yet.

Dynamic shadows artifacts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [RENDERING] Dynamic shadows artifacts

    I just realized that a default sphere renders different in 4.14 compared to 4.13. It does not seem to happen with imported objects, so far. But as I´m about to start a bigger project I want to make sure I don´t run into trouble because of this, later. See attached screenshot. The 4.14 sphere looks faceted. I tried different lighting and shadow options but I can´t seem to fix it. Maybe it´s just the sphere that is broken ?
    Attached Files

    #2
    I've been getting this for a while now, not just 4.14
    curious for a solution
    Follow me on Twitter!
    Developer of Elium - Prison Escape
    Local Image-Based Lighting for UE4

    Comment


      #3
      Try turning off SSAO and see if the problem disappears.
      Artstation
      Join the support channel
      Gumroad Store

      Comment


        #4
        I have the exact same problem:
        https://forums.unrealengine.com/show...ing-not-smooth

        Comment


          #5
          It´s a shadow bias problem with 4.14.(3). I know that low poly objects in some cases may look a little bit faceted.Usually the bias is there to fix this in exchange of accuracy. But this is not the problem here. It´s the way shadow Bias works in 4.14. SSAO makes no difference btw. To reproduce the problem. Create a new project in 4.14.3, place a sphere over the floor object and switch the directional light to moveable. You will notice the facetes in the object. When you now increase the shadow bias to the slider max value of 1 it will get a bit better. If you now set the value even higher by hand to a value of 2 it will get a lot better. When you set it to 5 the problem is gone and the shadows are still there wich is not how it should be with such high bias values. A wild guess, the shadow bias value is getting multiplied in a wrong way in 4.14. or something like that. In 4.13 much smaller values that are still in range of the default slider max value will produce the same result as a value of 5 in 4.14, while a value of 5 in 4.13 will produce no shadows at all with an object of that size.
          Last edited by netfrag-sam; 01-13-2017, 08:22 AM.

          Comment


            #6
            Originally posted by netfrag-sam View Post
            I just realized that a default sphere renders different in 4.14 compared to 4.13. It does not seem to happen with imported objects, so far. But as I´m about to start a bigger project I want to make sure I don´t run into trouble because of this, later. See attached screenshot. The 4.14 sphere looks faceted. I tried different lighting and shadow options but I can´t seem to fix it. Maybe it´s just the sphere that is broken ?
            This is a shadow problem. from directional light sources plus other such lights. The problem is still present in your second picture and in previous unreal versions, the reason why you don't see it is because in the other scenes you have a skylight by default , the problem visually diminishes with a skylight or indirect lighting but it is still there. It will really pop out when you want to have detailed shadows in your scenes or when you have slightly high contrast in your lights. Bias will not help you, neither would anything else, it will always appear if you want to have detailed shadows. In addition to the link above here's my thread about this if you are interested. (check bottom of the thread). No solution to this from what i know so far, you just adjust settings according to angle and shot basis and live with it. I hope in the future Epic will come up with a workflow to make this work seamlessly.

            https://forums.unrealengine.com/show...ing-very-wrong!

            Comment


              #7
              I´m sorry, but it´s not. It also happens with skylight. I have both engine versions installed and 4.14 behaves completely different than 4.13. It even looks wrong in the material editor unlike in 4.13. There maybe other issues with the way unreal handles shadows, normals or bias compared to other engines but that´s not what I´m talking about here. Carefully read my last post and you will be able to reproduce my problem, there is something wrong or maybe just different with the Bias in 4.14.

              Comment


                #8
                Originally posted by netfrag-sam View Post
                I´m sorry, but it´s not. It also happens with skylight. I have both engine versions installed and 4.14 behaves completely different than 4.13. It even looks wrong in the material editor unlike in 4.13. There maybe other issues with the way unreal handles shadows, normals or bias compared to other engines but that´s not what I´m talking about here. Carefully read my last post and you will be able to reproduce my problem, there is something wrong or maybe just different with the Bias in 4.14.
                If you are speaking of some difference in Bias settings only, then you can try this (I tested it in 4.12 and 4.14 and there is a difference) because by default the r.shadow.maxresolution appears to be set lower in 4.14. When I increased this to 4096 it appeared to match correctly with previous version of unreal.

                So to recap, try this in 4.14.
                Type in the console:
                r.Shadow.MaxResolution 4096

                But like I said regardless of these minor differences, the problem of facets are still there by default (less visible) and especially when you have higher settings on shadow its not 4.14 only related issue.

                Comment


                  #9
                  Version 4.15 here. The problem started to occure on 4.12 for me.
                  Click image for larger version

Name:	ScreenShot00012.png
Views:	1
Size:	624.3 KB
ID:	1124177
                  This is a screenshot from within the Material Editor.

                  Pls fix this already.

                  Comment


                    #10
                    I'm surprised this isn't getting any more attention. So far I haven't seen this acknowledged from anyone from Epic except for a couple of posts suggesting to play with the shadow settings. And never any reference to the comparisons with older UE4 revisions

                    I also get this bug and it makes my characters faceted on closeups, and my landscape looks faceted as well (in areas where the shadows have their "boundaries")

                    A few threads with the same issue:
                    https://forums.unrealengine.com/show...ing-very-wrong
                    https://answers.unrealengine.com/que...ml?sort=oldest
                    https://forums.unrealengine.com/show...less-polygonal
                    https://forums.unrealengine.com/show...le-shadows-bug
                    https://forums.unrealengine.com/show...ows-on-terrain
                    https://forums.unrealengine.com/show...ing-not-smooth

                    I'm gonna quote this eye opener picture from William K
                    Originally posted by William K View Post
                    Update 3 on this issue:

                    Received a confirmation about this issue from another user in answerhub, I wouldn't be bumping this if i didn't feel it needs that kind of attention.

                    Meanwhile wanted to provide another example with normals going wrong, and here's a comparison with Untiy this time.

                    Edit: to better spot the Facets Directional light must have detailed shadows, in this case the Num of dynamic shadow cascades are bumped up from the default 3 to 6.

                    [ATTACH=CONFIG]123257[/ATTACH]

                    File FBX and Max:

                    https://answers.unrealengine.com/sto...20-%20copy.zip

                    here's the same issue (but much less evident) in UDK (then again the UDK sphere is lower poly)

                    Click image for larger version

Name:	udksphere.png
Views:	1
Size:	79.2 KB
ID:	1124182


                    quite sad to not see this issue looked into
                    Follow me on Twitter!
                    Developer of Elium - Prison Escape
                    Local Image-Based Lighting for UE4

                    Comment


                      #11
                      With 3 shadow cascades I get smooth results. With 4 cascades I have the same problem. Really annoying.
                      Artstation
                      Join the support channel
                      Gumroad Store

                      Comment


                        #12
                        Originally posted by Maximum-Dev View Post
                        With 3 shadow cascades I get smooth results. With 4 cascades I have the same problem. Really annoying.
                        This is a known issue and from our tests it is not just dependent on shadow cascade count but rather on the shadow distance which adjusts the quality of the shadow detail (not just bias) regardless of the cascades. You can have 1 cascade and still have the issue pop up once you adjust the shadow distance for that shadow detail quality. And once you get to the sweet spot when you think the shadow distance/quality is just right you will have the issue visible as a consequence (note by quality I don't mean "shadow resolution" but rather the amount of detail in the geometry that the shadow map catches). From all our discussions and posts the problem hasn't gone away unfortunately.

                        Comment


                          #13
                          hi,

                          any news about this?
                          Follow me on Twitter!
                          Developer of Elium - Prison Escape
                          Local Image-Based Lighting for UE4

                          Comment


                            #14
                            I am getting same issue since 4.14, this is supper annoying when using procedural meshes. I though my tangents were bad... nope, shadows make everything look like potato.
                            www.dawidniemiec.com

                            Comment


                              #15
                              I think it's about time someone from Epic look into this problem.
                              The blocky shading is too problematic.



                              Artstation
                              Join the support channel
                              Gumroad Store

                              Comment

                              Working...
                              X