Announcement

Collapse
No announcement yet.

Out of video memory trying to allocate a texture

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [EDITOR] Out of video memory trying to allocate a texture

    Hey Guys,
    I have added the grass tool into my landscape material in UE4.14.1 and wanted to edit some areas, then this happened:
    Click image for larger version

Name:	Unbenannt.png
Views:	1
Size:	6.9 KB
ID:	1205049
    I had this problem never before, it must be a problem with the grass tool or what do you think?

    My gpu is a "NVIDIA GeForce GTX 980 Ti" with 6gb memory size:
    Click image for larger version

Name:	Unbenannt2.png
Views:	1
Size:	32.1 KB
ID:	1205050
    others: intel i7-5820K, 64gb Ram

    I have changed the quality of the editor from epic to low but it happens too...
    Same result if only the landscape is loaded with a directional light...

    Memory used in persistent level:
    Epic settings: 1838mb
    Low settings: 1484mb
    Memory used with only landscape opened and directional light added:
    Epic settings: 1345mb
    Low Settings: 1013mb


    I have Win7 installed, would it be better to install Win10 because of Dx12?
    Last edited by Killerzwerg; 01-07-2017, 04:37 AM.

    #2
    I have tested this problem a little more out:

    In the first minute I´m painting on the landscape, the video memory increases to about 6gb, after this point, it increases only slow, after 3-5minutes the editor crashes with the message above...
    If I save the changes before it crashes, the complete video memory gets emptied.

    Maybe there´s no problem with the grasstool, but with the video memory management?

    Edit: It happens with a new Landscape too!
    Last edited by Killerzwerg; 01-08-2017, 05:33 AM.

    Comment


      #3
      I had the same problem with a R9 390 (8gb memory). It went away on its own

      Comment


        #4
        Yeah I think so, after I´m finished with Landscape painting^^

        Comment


          #5
          Originally posted by Killerzwerg View Post
          I have Win7 installed, would it be better to install Win10 because of Dx12?
          Win10 and DX12 changes nothing. PLus DX12 is not complete supported here I think.
          Hevedy - Instance Tools: https://hevedy.itch.io/hevedyinstances
          Hevedy - Image Tools: https://hevedy.itch.io/imagetools

          Comment


            #6
            Originally posted by Hevedy View Post
            Win10 and DX12 changes nothing. PLus DX12 is not complete supported here I think.
            I thought so^^
            I had it installed win10 1 year ago, but got no connection to steam...

            Comment


              #7
              I just started getting this error also. I have an i7 6700k + 1080 video card + 16gb ram. Is there a fix for this?

              Comment


                #8
                This happens for both ram and vram. The best thing to do is to change the editor settings to show the stats and pay attention to the memory usage. Go to editor settings>type "show frame rate and memory">click the checkbox. Now you'll see the stats in the top right of the main editor window. If the memory get's beyond a certain amount, then save>close editor>reopen editor.

                The editor is absolutely horrible about respecting physical ram and will leave all sorts of memory tied up for no reason (probably undo history, if I had to take a guess). Doing anything with large landscapes, like a change to a material that is used across all components, is one way to blow out your ram because it has to recompute all the shaders and the editor thinks it's a good idea to just allocate 200000000000gb of ram all at once to do it, rather than sequentially chunk it out into small pieces of ram at a time. One reliable way to explode your ram is to make a large landscape and then import layer data from a png or something(world machine splat maps are an example). Do that for 5 or 6 layers and you'll see the ram start climbing up to ridiculous levels.

                Comment


                  #9
                  Report this on Answerhub. It's quite possibly a memory leak.

                  Comment


                    #10
                    It isn't a memory leak, it's just poor memory management. I'd rather it take 3x as long to shader compile a landscape, if it meant that I didn't run out of vram or didn't spill over from ram into the pagefile.

                    Comment


                      #11
                      If y'all report this stuff on Answerhub rather than here, there's a chance of it being changed or looked into.

                      Provide a good repro case and let Epic know.

                      Comment


                        #12
                        I'm flabbergasted by how this has been happening the last couple of engine versions without a fix. I made an answerhub post a while back but it went nowhere. Its odd.
                        Current Project: Shadow Over Isolation

                        Comment


                          #13
                          Link to the AH post?

                          Comment


                            #14
                            https://answers.unrealengine.com/que...ram-cause.html

                            As referenced in the post and in this thread, it occurs when the ram is maxed out. It doesn't seem to be a problem with the page file either as it doesn't max out the system controlled page files created.
                            Current Project: Shadow Over Isolation

                            Comment


                              #15
                              I stumbled upon this thread, and then found a fix that worked for me on a reddit thread:
                              https://www.reddit.com/r/unrealengin...to_allocate_a/

                              changing the paging file size as described in this link to a size the same as my graphics card's video memory fixed this issue for me:
                              https://www.thewindowsclub.com/incre...memory-windows

                              Thought I'd post back here in case it helps someone else sincce it looks like i've been unecessarily living with this issue for the last year.
                              Mine was set to 3g. Setting it to 8 to match my 1080's texture memory fixed me up.

                              It appears in my case at least unreal was mis-reported as out of video memory when it's actually running out of paging memory or something to that effect.


                              Comment

                              Working...
                              X