Announcement

Collapse
No announcement yet.

to developers, ue 4.14 crashes! - Error: 0x887A0006 - 'HUNG'

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • to developers, ue 4.14 crashes! - Error: 0x887A0006 - 'HUNG'

    heres what im doing. i import my fdx model with animation.
    there is no animation for my model in the content browser.
    i double click my model and this is where ue 4.14 crashes!

    im hoping you guys can fix this,but until then im going back to 4.13 ( i hope i can still dl it on the website!)

    here i copied the crash log:


    MachineId:1778D6324E7F266C02D5D7830E65AB4D
    EpicAccountId:363d3e75c9c5423db2bae3870b02f04f

    Fatal error: [File:\Build\++UE4+Release-4.14+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 176]
    Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')


    UE4Editor_Core!FDebug::AssertFailed() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:332]
    UE4Editor_D3D11RHI!TerminateOnDeviceRemoved() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:176]
    UE4Editor_D3D11RHI!VerifyD3D11Result() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:225]
    UE4Editor_D3D11RHI!FD3D11DynamicRHI::GetQueryData() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11query.cpp:135]
    UE4Editor_D3D11RHI!FD3D11DynamicRHI::RHIEndDrawingViewport() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:562]
    UE4Editor_RHI!FRHICommandList::EndDrawingViewport() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\rhi\private\rhicommandlist.cpp:1347]
    UE4Editor_SlateRHIRenderer!FSlateRHIRenderer:rawWindow_RenderThread() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:486]
    UE4Editor_SlateRHIRenderer!TGraphTask<`FSlateRHIRenderer:rawWindows_Private'::`35'::EURCMacro_SlateDrawWindowsCommand>::ExecuteTask() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\async\taskgraphinterfaces.h:868]
    UE4Editor_Core!FNamedTaskThread::ProcessTasksNamedThread() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\async\taskgraph.cpp:932]
    UE4Editor_Core!FNamedTaskThread::ProcessTasksUntilQuit() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\async\taskgraph.cpp:679]
    UE4Editor_RenderCore!RenderingThreadMain() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:320]
    UE4Editor_RenderCore!FRenderingThread::Run() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:454]
    UE4Editor_Core!FRunnableThreadWin::Run() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]
    Last edited by Stephen Ellis; 12-21-2016, 01:26 PM.

  • replied
    Yeah, this has been the most annoying issue of my life. Every day I use the engine for one or two hours and get nothing done. 20 crashes per day is quite common, and I'm afraid to use play in editor anymore.

    I'm running an NVIDIA GTX 960. Drivers are up to date. I keep sending my callstacks to the team, but IDK. This is the worst bug in the history of bugs. Nothing can be done to fix it.

    Leave a comment:


  • replied
    Originally posted by Dr. Whoop DSc View Post
    The most painful thing is that this issue always has the 'target fix' set for the next version of UE4, then 2 days before it releases they push it back to the next next one without a word.
    oh look it's 4.23 now

    Leave a comment:


  • replied
    Originally posted by lucastakejame View Post
    I'm having a similar problem on my laptop
    There is one additional tip added to the newer version of the bug report: "If on laptop, open the Nvidia GeForce Experience, and set "Battery Boost" to OFF"

    Leave a comment:


  • replied
    I'm having a similar problem on my laptop (which due recent circumstances I'm being forced to use) since UE4.18. Now on 4.21 its impossible even to open the editor. What happens is my driver drops, and crach reporter show me something like:

    Code:
    Fatal error: [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 200] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0005 - 'REMOVED')
    
    UE4Editor_Core!FDebug::AssertFailed() [d:\build\++ue4\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:417]
    UE4Editor_D3D11RHI!TerminateOnDeviceRemoved() [d:\build\++ue4\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:210]
    UE4Editor_D3D11RHI!VerifyD3D11Result() [d:\build\++ue4\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:249]
    UE4Editor_D3D11RHI!FD3D11DynamicRHI::GetQueryData() [d:\build\++ue4\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11query.cpp:141]
    UE4Editor_D3D11RHI!FD3D11DynamicRHI::RHIEndDrawingViewport() [d:\build\++ue4\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:673]
    UE4Editor_RHI!FRHICommandListExecutor::ExecuteInner_DoExecute() [d:\build\++ue4\sync\engine\source\runtime\rhi\private\rhicommandlist.cpp:325]
    UE4Editor_RHI!FRHICommandListExecutor::ExecuteInner() [d:\build\++ue4\sync\engine\source\runtime\rhi\private\rhicommandlist.cpp:578]
    UE4Editor_RHI!FRHICommandListExecutor::ExecuteList() [d:\build\++ue4\sync\engine\source\runtime\rhi\private\rhicommandlist.cpp:628]
    UE4Editor_RHI!FRHICommandList::EndDrawingViewport() [d:\build\++ue4\sync\engine\source\runtime\rhi\private\rhicommandlist.cpp:1509]
    UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::DrawWindow_RenderThread() [d:\build\++ue4\sync\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:935]
    UE4Editor_SlateRHIRenderer!TGraphTask<TEnqueueUniqueRenderCommandType<`FSlateRHIRenderer::DrawWindows_Private'::`29'::SlateDrawWindowsCommandName,<lambda_43e86ee7c51f39979e9a39d40b280024> > >::ExecuteTask() [d:\build\++ue4\sync\engine\source\runtime\core\public\async\taskgraphinterfaces.h:829]
    UE4Editor_Core!FNamedTaskThread::ProcessTasksNamedThread() [d:\build\++ue4\sync\engine\source\runtime\core\private\async\taskgraph.cpp:679]
    UE4Editor_Core!FNamedTaskThread::ProcessTasksUntilQuit() [d:\build\++ue4\sync\engine\source\runtime\core\private\async\taskgraph.cpp:575]
    UE4Editor_RenderCore!RenderingThreadMain() [d:\build\++ue4\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:333]
    UE4Editor_RenderCore!FRenderingThread::Run() [d:\build\++ue4\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:467]
    UE4Editor_Core!FRunnableThreadWin::Run() [d:\build\++ue4\sync\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:76]
    Nothing I tried worked (all tips here https://issues.unrealengine.com/issue/UE-42280 and also increasing TDR delay). My graphics card is a NVidia NVS 5400m, my driver is up to date and by now I don't know what to try ...

    Leave a comment:


  • replied
    The most painful thing is that this issue always has the 'target fix' set for the next version of UE4, then 2 days before it releases they push it back to the next next one without a word.

    It has just been slowly climbing up the rankings to now be the third highest voted issue in the engine.

    Leave a comment:


  • replied
    even if laptops are "more unstable" this problem is not a thing of laptops, it's either a UE4 or an Nvidia problem but UE4 is doing something that the driver doesn't like. apparently this issue is more common on GTX 970's - which I have both at home and at work. At work I swapped it for a different GTX 970 and the issue kept appearing, then I swapped for a GTX 1060 and I stopped having it, then I had to go back to the GTX 970 and the issue came back.

    the crash always seems to appear then the GPU's memory is full. I actually have a fairly reliable way to make it crash in the editor - I open a series of editor windows, I alt-tab and work in 3dsmax and leave UE4 in the background, and within 15-30 minutes I'll get the crash

    Using older or newer drivers doesn't help, disabling Ansel doesn't help, disabling Nvidia experience doesn't help, running UE4 in DX12 doesn't help (because UE4 on DX12 crashes on startup). buying a different graphics card that may or may not have the issue isn't acceptable (since no other game or software has the issue).

    But most of all: any of these solutions that might be acceptable for me as a developer is not acceptable for the users that are experiencing these crashes with our game
    Last edited by Chosker; 11-22-2018, 03:46 AM.

    Leave a comment:


  • replied
    Laptops can have trouble being stable. Make sure though that you're using the Nvidia GPU, since by default Windows will try to choose between that and the Intel GPU for different tasks and it doesn't do a good job, I've gotten better performance by just forcing it to use the Nvidia GPU always.
    Also, you may need to try to use an older Nvidia driver.

    Leave a comment:


  • replied
    Sounds like there has still not been found the ultimate solution to this.
    I am running constantly into this problem and tried many of the suggested work arounds that sound like a suitable workaround.

    e.g. ContentBrowser -> realTime, PowerManagement are things I have tried.

    Cleaning Ram and graphic card contacts is one of the tings I did not and will not try. My laptop is brand new, don't see the need for it.

    It is really mind blowing that things are so unstable with a pretty beefy machine like the Aero 15x or the MSI GS67.


    Leave a comment:


  • replied
    Hi,

    I've recently encountered this crash and other such D3D/GPU crashes recently running the 4.19 editor.
    Graphics Card is a GTX 1080 with the latest NVidia Drivers installed.

    Tried a lot of the suggestions to fix the problem all of which either didn't work or caused other issues.

    We decided to swap out the Graphics Card for a different one that has an identical spec, so like-for-like swap for a different 1080 but also change the PCIe port that the card was plugged into.

    Amazingly this looks to have fixed my issues with the D3D errors about the GPU crashing or loosing the GPU or at least I haven't had any of the errors or crashes relating to this since swapping out the card.

    Maybe something for others to potentially try to see if this works for them, not sure if it was the card or the port at fault though.

    Thanks.

    Leave a comment:


  • replied
    I'm running UE 4.19.2 on my new MSI GS67 laptop with an NVIDIA GTX 1070 and driver version 398.36 on Windows 10 x64 build 1803 17134.112 and have been encountering this issue regularly for several weeks. Switching to DX12 seems to help. I also dropped in the registry key for TdrDelay=10 just in case. Note that GRHINeedsExtraDeletionLatency is set to true in both the dx11 and dx12 rendering paths in 4.19.2. I also reduced the engine scalability from Epic to Medium while working.

    Leave a comment:


  • replied
    I see there is a jira bug ticket on this issue: UE-42280 & UE-51650, I have two EVGA Nvidia 760 in SLI configuration. Looks like UE team is trying to figure out how to reproduce, maybe this will help?: I crash maybe every 3 minutes in ARK on the Island map, sometimes I can make it a few hours without a crash but that's pretty rare. Sometimes I'll crash when opening any inventory, sometimes when it's dark on the screen I crash. During hard rendering of scenes you would think it would crash but it seems to do fine.

    Something that has seems to help maybe a little was, opening the properties of the executables for the game and going to compatibility and checking boath run as administrator and disable full screen optimizations, crashing doesn't happen as frequently but it still happens, when I remove these checkbox selection I crash a lot more frequently.

    I am interested in this disabling rendering and thumbnails in real time but I am guessing that is something the game developer would need to do?

    System specs:
    GPU: 2x EVGA Nvidia 760
    RAM: 16GB DDR3
    CPU: Intel Core i7-3960X Extreme Edition Sandy Bridge-E 6-Core 3.3GHz
    OS: Windows 10 Pro 64-bit
    Motherboard: ASUS Rampage IV Extreme LGA 2011

    Leave a comment:


  • replied
    disable rendering in real-time, then disable thumbnails in real-time, was the quickest solution

    Leave a comment:


  • replied
    I'm getting reports of this for my game.
    Packaged with 4.18.2, based on a small sample it seems confined to older Intel integrated graphics systems at the moment.
    Issue didn't occur before upgrading the project from 4.15.3.

    Leave a comment:


  • replied
    I have the same problem in UE 4.18.3, i'm trying the solutions added above and not working...

    Graphic Card: NVIDIA GeForce GT 730 2GB
    Memory RAM: 12GB DDR3
    CPU: AMD FX-8350
    OS: Windows 7 Professional 64-bit

    Leave a comment:

Working...
X