Announcement

Collapse
No announcement yet.

Training Livestream - Blender to UE4 - May 30 - Live from Epic HQ

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by motorsep View Post
    What if I don't use Rigify to Unreal script?

    My rigs are usually go as Armature > root > pelvis > and so on. So are you saying that now when FBX with such hierarchy is imported into 4.16+, UE4 will automatically remove Armature "bone" and I will end up with the following hierarchy: root > pelvis > and so on ?
    Yes, exactly. It doesn't matter how you export your rig. If it has "Armature" at the top, UE4 will now delete that bone/null automatically for you.

    Comment


      Originally posted by cyaoeu View Post
      Seems to work for me.


      You can share the .blend file you've got.
      Thanks for reproducing. I still can't seem to get your result. Here's my .blend file:

      https://drive.google.com/open?id=0B1...WhPbDBEYmlFR00

      That's with Blender 2.78c. I've tried with UE4.15 and just now I tried with 4.16 as well.

      But then this .blend file, created with 2.76 works fine and has half as many verts as triangles when I export it FBX from 2.76 with edge or face smoothing and import with "import normals and tangents" or "compute normals":

      https://drive.google.com/open?id=0B1...nhaWnN3MjA3REU

      Comment


        Hello Community,

        i have a problem importing the Blendman.fbx file to Unreal (4.14.3). When i run the script in Blender (2.78c) and import Blendman it will not work, but if i didn´t run the script it works, but without the Rig ....
        I attached some screenshots for better understanding whats the problem. When i open the .blend - file Mr. Blendman looks way to short. Anybody have similar issues and know what to do ?

        Thank u

        Edit: I already reinstalled Python to 3.6.1.

        After opening in Blender
        https://drive.google.com/open?id=0Bz...m95UWk2RHRORW8

        In Scripting-Section
        https://drive.google.com/open?id=0Bz...FhOV3RkdnB2SkE

        Import to Unreal failed
        https://drive.google.com/open?id=0Bz...TVjaERvUVBWM0E
        Last edited by Seim2k; 06-09-2017, 06:07 AM.

        Comment


          Originally posted by Simon Nguyen View Post
          Hello Community,

          i have a problem importing the Blendman.fbx file to Unreal (4.14.3). When i run the script in Blender (2.78c) and import Blendman it will not work, but if i didn´t run the script it works, but without the Rig ....
          I attached some screenshots for better understanding whats the problem. When i open the .blend - file Mr. Blendman looks way to short. Anybody have similar issues and know what to do ?

          Thank u

          Edit: I already reinstalled Python to 3.6.1.

          After opening in Blender
          https://drive.google.com/open?id=0Bz...m95UWk2RHRORW8

          In Scripting-Section
          https://drive.google.com/open?id=0Bz...FhOV3RkdnB2SkE

          Import to Unreal failed
          https://drive.google.com/open?id=0Bz...TVjaERvUVBWM0E
          Yes - I am seeing this exact same thing in Blender 2.78c as shown in Simon's first link - just download the BlendMann.blend and open in Blender 2.78c on Windows 10... anyone else seeing this or know how to fix it? Maybe an older version of blender was used for this (relatively recent) video tutorial?

          Comment


            Originally posted by Simon Nguyen View Post
            i have a problem importing the Blendman.fbx file to Unreal (4.14.3). When i run the script in Blender (2.78c) and import Blendman it will not work, but if i didn´t run the script it works, but without the Rig ....
            I attached some screenshots for better understanding whats the problem. When i open the .blend - file Mr. Blendman looks way to short. Anybody have similar issues and know what to do ?

            You see the little button at the top of the screen? The one that says "Reload Trusted"? You must be loading the file from an untrusted directory, so it won't run the Python scripts needed for Rigify to work properly. It's a security feature to prevent somebody from doing bad things to you through a Blender file.

            Hit that button and it will work fine. You can go into preferences to add directories that Blender will run scripts from.

            Comment


              Has anybody had much luck with the retargeting from the Epic skeleton to the Unrigify? There's something really odd about the retargeting. When I retarget to Lui's version, it works perfectly. When I retarget to a UE4 skeleton exported to Blender and then re-imported with a new skeleton, it retargets perfectly. But this guy, not so much.

              I modified the stream asset, if anybody's interested. My version makes the following changes:

              - Creates a duplicate asset on a separate layer with bone names matching Unreal's expected names so that you don't have to manually map bones
              - Sets default name to "Armature", which causes 4.16 to remove the extra root bone
              - Sets correct scale in the Blender document and removes the scale change from the script

              It's essentially the same as the original Unrigify, I just tweaked it to avoid manual work. That being said, I'm probably going back to Lui tools, as I can't get the retargeting to work quite right on this rig for some reason. It would be nice to have a generic Rigify to Unreal solution, but there still seems to be a missing link in that chain.

              Comment


                Thank you Kneebiter. It worked !

                Comment


                  Originally posted by Kneebiter View Post
                  Has anybody had much luck with the retargeting from the Epic skeleton to the Unrigify? There's something really odd about the retargeting. When I retarget to Lui's version, it works perfectly. When I retarget to a UE4 skeleton exported to Blender and then re-imported with a new skeleton, it retargets perfectly. But this guy, not so much.

                  I modified the stream asset, if anybody's interested. My version makes the following changes:

                  - Creates a duplicate asset on a separate layer with bone names matching Unreal's expected names so that you don't have to manually map bones
                  - Sets default name to "Armature", which causes 4.16 to remove the extra root bone
                  - Sets correct scale in the Blender document and removes the scale change from the script

                  It's essentially the same as the original Unrigify, I just tweaked it to avoid manual work. That being said, I'm probably going back to Lui tools, as I can't get the retargeting to work quite right on this rig for some reason. It would be nice to have a generic Rigify to Unreal solution, but there still seems to be a missing link in that chain.
                  Hi Kneebiter, the file you made seems to be working fine, except ue still cant identify all the bones correctly. other than that the retargeting works fine if everything set up corretly. What problem did you find?

                  Comment


                    Originally posted by mzprox View Post
                    Hi Kneebiter, the file you made seems to be working fine, except ue still cant identify all the bones correctly. other than that the retargeting works fine if everything set up corretly. What problem did you find?
                    The retargeted animations aren't quite the same as the original. Hard to describe exactly what went wrong, but the retargeted animations look like someone not fully in control of their muscles.

                    I'm curious which bones didn't map correctly? That could explain the problem. The only bones I noticed not mapping was spine3, plus the custom and IK bones. There simply wasn't enough bones in the rigify deform spin to have a hip, pelvis, three spines, and a neck.

                    Comment


                      Originally posted by Kneebiter View Post
                      The retargeted animations aren't quite the same as the original. Hard to describe exactly what went wrong, but the retargeted animations look like someone not fully in control of their muscles.

                      I'm curious which bones didn't map correctly? That could explain the problem. The only bones I noticed not mapping was spine3, plus the custom and IK bones. There simply wasn't enough bones in the rigify deform spin to have a hip, pelvis, three spines, and a neck.
                      unless we are talking about very small differences I couldn't find any between the default mannequin and blenderman using either a mixamo or starter content animations.I mapped spine 2 to both spine 2 and 3. all ik bones were set to none. in retargeting options all bones were set to 'skeleton' except pelvis which was 'animation scaled' and root which was 'animation' wtih these settings it should work.

                      Comment


                        Originally posted by mzprox View Post
                        unless we are talking about very small differences I couldn't find any between the default mannequin and blenderman using either a mixamo or starter content animations.I mapped spine 2 to both spine 2 and 3. all ik bones were set to none. in retargeting options all bones were set to 'skeleton' except pelvis which was 'animation scaled' and root which was 'animation' wtih these settings it should work.
                        Thanks! The only difference from that is that I simply didn't map spine3. I'll try that when I'm next at my personal computer.

                        Update: mzprox - targeting spine2 to both spine2 and spine3 was the solution. Not sure there's any way to automate that, though, since I can't assign the same name to two bones in Blender, but I can deal with manually selecting one bone.
                        Last edited by Kneebiter; 06-24-2017, 12:51 AM.

                        Comment


                          Originally posted by mzprox View Post

                          unless we are talking about very small differences I couldn't find any between the default mannequin and blenderman using either a mixamo or starter content animations.I mapped spine 2 to both spine 2 and 3. all ik bones were set to none. in retargeting options all bones were set to 'skeleton' except pelvis which was 'animation scaled' and root which was 'animation' wtih these settings it should work.
                          What actually happens when you map one bone to two bones like that, do both bone rotations get additively applied in succession to a single bone when you retarget an animation?

                          Comment


                            Unreal Engine is supposed to remove the extra bone now. so make sure you are using the version of Blender & UE4 mentioned in the stream!

                            Comment


                              Originally posted by ayretek View Post
                              Unreal Engine is supposed to remove the extra bone now. so make sure you are using the version of Blender & UE4 mentioned in the stream!
                              I meant the extra spine bone, not the armature root bone.
                              Last edited by muchcharles; 09-06-2017, 12:49 AM.

                              Comment


                                oh.. sorry, wow usually pay more attention.

                                I've done this before & usually doesn't hurt the animation & I actually didn't notice any adverse effect.
                                ( there may be some certain 'use' case where there's an issue but I haven't seen one yet, that you couldn't adjust settings etc. to come up with decent results)

                                Comment

                                Working...
                                X