Announcement

Collapse
No announcement yet.

4.11 Released!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Have someone found yet any more info what causes the AllEnabledTickFunctions.Remove crash? Still getting that during playing and also if there is ai near each other, often the whole thing just freezes. In 4.10.3 I got some PNewPose.isValid() crash randomly. Thats gone but, now seeing much e.g. ArmedBP_C_27 is stuck and failed to move! spamming in log which seems to be connected to crashing. The AI even can move, just not always since there is other AI character sometimes blocking. If I dont spawn the AI characters, its stable. Would be so excited to get work without crashes but still struggling. Else performance is getting very smooth.

    Edit: Btw. currently the answers.unrealengine.com forces simplied chinese for me.
    Last edited by SaOk; 04-03-2016, 02:12 PM.

    Comment


      I have submitted bug report for a major issue with Lightmass from the source build, it fails to build even on a frehsly formated and installed system with the same errors.

      https://answers.unrealengine.com/que...-in-swarm.html


      EDIT: Source can not compile (lightmass will fail) if Visual Studio Update 2 is downloaded, others are having the same issues:

      https://answers.unrealengine.com/que...moted-bra.html

      Dev note by Stephen Ellis: This is set to be fixed in our upcoming 4.11 Hotfix.
      Last edited by Stephen Ellis; 04-05-2016, 11:06 AM. Reason: update
      ______________________________________________
      https://www.facebook.com/madhousesoftware
      Where sanity is a virtue

      Comment


        The bug where child blueprints reset to their defaults hasnt been fixed, although it says it has in the change log.
        Stylized Low Poly Environment
        Stylized Low Poly Pine Forest
        Stylized Low Poly Buildings
        First Person Horror Template

        Comment


          Has there been some change internally that makes compiling more resource-intensive?

          I can't even compile blueprints anymore (unless they're extremely simple), I literally have to save uncompiled, close the editor, and reopen it, because UE almost invariably times out and becomes unresponsive when compiling starts.

          Comment


            I don't know if the method is the same from Ektophase Adam, but what I could get is here:
            https://answers.unrealengine.com/que...letalmesh.html
            I've found this other post:
            https://answers.unrealengine.com/que...nt-assert.html
            He should have the same issue but he didn't included the crashlog, I've downloaded the pdbs to get more info.
            VIDA - U4 Indie Goth Horror Game
            Project Thread

            Comment


              Originally posted by Shirk View Post
              The bug where child blueprints reset to their defaults hasnt been fixed, although it says it has in the change log.
              I can confirm that too.

              Comment


                Originally posted by motorsep View Post
                True that. Isn't this something like what Simplygon used to do: https://forums.unrealengine.com/show...-Static-Meshes ?
                Oh I must have missed that one. That looks fantastic! Hopefully they'll add support for merging multiple actors as well. Thank you.

                Comment


                  Originally posted by SaOk View Post
                  Have someone found yet any more info what causes the AllEnabledTickFunctions.Remove crash? Still getting that during playing and also if there is ai near each other, often the whole thing just freezes. In 4.10.3 I got some PNewPose.isValid() crash randomly. Thats gone but, now seeing much e.g. ArmedBP_C_27 is stuck and failed to move! spamming in log which seems to be connected to crashing. The AI even can move, just not always since there is other AI character sometimes blocking. If I dont spawn the AI characters, its stable. Would be so excited to get work without crashes but still struggling. Else performance is getting very smooth.

                  Edit: Btw. currently the answers.unrealengine.com forces simplied chinese for me.
                  I had a similar issue with one of my blueprints that had a Tick Interval over 0.0. I fixed it by messing with the state in which the tick occurs, making it PostUpdateWork I believe and it seemed to solve the issue for now. Finding the blueprint that crashes may be difficult, it's best to attach the visual studio debugger to the process and get that crash to occur, then look in the FTickFunction auto variables to try find the name of the blueprint that's crashing.

                  Comment


                    Thanks also spotted related ticket last night and so far good. No more AllEnabledTickFunctions.Remove crashes yet, but still getting freezes that seem to be related to ai controllers. I noticed "cast to character" dosent always success, especially it connected to "controlled pawn" and if that is connected to play montage (as converted pure cast), that seem to cause crashing. After changes getting noticeable less freezes but still too many. Will keep working on that. Also check if there is some other blueprints with tick over 0.0. Been using much slow ticks, but will use then event timers instead.

                    But will try that PostUpdateWork settings. Also check the visual studio debugger.

                    Comment


                      What changes there are for post process materials? I noticed that Camera Vector is bugged at sky pixels and just give black.

                      Comment


                        Can anyone explain the textures in the new hair material and how i should go about making them? I mean to me it looks like a bunch of alpha channels, but clearly they are not.. so what exactly is this?

                        Comment


                          Originally posted by Galeon View Post
                          It looks like this was made for Paragon exclusively.
                          This is a mistake not proposing some custom Hierarchical LOD for all that does not rely on Simplygon.
                          Hi Galeon,

                          Without Simplygon there still is functionality for the HLOD system to use. In this case the system takes the source meshes and merges them together (note, this will not give triangle count reduction). However it will bake out the proxy material to atlas textures, so you will get a reduction in draw call count. The idea for 4.12 will be calculating the correct source LOD model to be used for merging, and creating a new unique UV set for the proxy material rather than an atlas texture.

                          Cheers,

                          Jurre

                          Comment


                            Originally posted by [EPIC] Smurf View Post
                            Hi Galeon,

                            Without Simplygon there still is functionality for the HLOD system to use. In this case the system takes the source meshes and merges them together (note, this will not give triangle count reduction). However it will bake out the proxy material to atlas textures, so you will get a reduction in draw call count. The idea for 4.12 will be calculating the correct source LOD model to be used for merging, and creating a new unique UV set for the proxy material rather than an atlas texture.

                            Cheers,

                            Jurre
                            Any reason why we cant have the ability to create our own proxy lod meshes manually? Every other engine seems to have this feature and for an engine like unreal to be touting VR so much you would think that performance mattered for VR... Most of us here cannot afford a fortune on simplygon SDK... simplygon normal fine thats cheap, but its not compatible to be used within unreal... Unity has a great way where tehy can take an entire building full of different meshes.. and you can literally decide whta the LOD is going to be... from makign a distnace low res different material model.. to even deciding which lod has lights or particle fx in it...

                            Comment


                              Seem to be crashing when trying to sculpt terrain with foliage that was saved during 4.10.

                              Also seem to be having stuttering, where the game will hang while playing in editor. Then after a second or two it starts again most times. A few times it has totally just froze.

                              Comment


                                reverting between these two builds, I am getting all sorts of crashes and errors in 4.11

                                Then reverting back to 4.10, it can't see the blueprints that were saved in 4.11

                                Comment

                                Working...
                                X