Announcement

Collapse
No announcement yet.

4.11 Released!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Too bad, i was hoping you would hand out the paragon character showcase in the content demo, would be interesting to take a look at the shader network.

    Comment


      Hi all,

      Thank you for the new UE4 release. I installed the Engine only. Where I can find the default templates and the Starter Content? I have nothing in my engine!

      EDIT: I know! Launcher -> Click the drop down Menu on the Engine installed -> Choose Options
      Last edited by Tomza; 04-02-2016, 09:28 AM.

      Comment


        Thank you a LOT for this release. I love it, when you improve the performance so drastically. Wonderful job, you can be very proud of yourselves, EPIC .
        Main channel:
        https://www.youtube.com/channel/UCGC...o9s3YcA/videos

        Comment


          I got troubles with the SkeletalMeshComponents on my Async Loaded Modular Character Class.

          After update an assert is breaking the project because BoneIndexes, something related to MasterBoneMap getting empty, I think SetMasterPoseComponent() is not filling the MasterBones properly with dinamically loaded meshes, the project runs fine on 4.10.3.

          I'm dying to try the new features, but, without my character class working there is not much sense on the remaining things.

          The trouble is get another 1.9GB download of the pdbs to debug the entire thing, was this already reported?
          VIDA - U4 Indie Goth Horror Game
          Project Thread

          Comment


            Just want to thank you for optimization pass!
            I remember having 70 fps in SuperGrid in 4.7 version with fullscreen and epic quality, now I have 90-100 fps in the same scene! <3
            SuperGrid: Marketplace Page | Feedback Thread | Demo | Website
            Level design and prototyping for newbies

            Comment


              Hi!

              I have notice that material parameters is no longer accessible by using "Set _____ Parameter Value" node

              Is it have anything to do with the following update?

              "New: Material parameters can now be animated in level sequences."

              Comment


                Hi all, I am trying to run 4.11 with my 4.10.3 content. It crashes without loading. I have marketplace content in the project file? Anyone else having issues starting it up?

                This is the error log I get:

                MachineId:FF3262974747C3D0094195AAFA061B9F EpicAccountId:f8bb1bec01b34170b565f2309a638857
                Access violation - code c0000005 (first/second chance not available)
                UE4Editor_CoreUObject!UStruct::FindPropertyByName() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\runtime\coreuobject\private\uobject\property.cpp:1307] UE4Editor_BlueprintGraph!UK2Node_MakeStruct::Serialize() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\editor\blueprintgraph\private\k2node_makestruct.cpp:372] UE4Editor_CoreUObject!FLinkerLoad::Preload() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:3277] UE4Editor_CoreUObject!EndLoad() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1383] UE4Editor_CoreUObject!LoadPackageInternal() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1143] UE4Editor_CoreUObject!LoadPackageInternal() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1258] UE4Editor_UnrealEd!UEditorEngine::Map_Load() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\editor\unrealed\private\editorserver.cpp:2392] UE4Editor_UnrealEd!UEditorEngine::HandleMapCommand() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\editor\unrealed\private\editorserver.cpp:5946] UE4Editor_UnrealEd!UEditorEngine::Exec() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\editor\unrealed\private\editorserver.cpp:5436] UE4Editor_UnrealEd!UUnrealEdEngine::Exec() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\editor\unrealed\private\unrealedsrv.cpp:744] UE4Editor_UnrealEd!FEditorFileUtils::LoadMap() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\editor\unrealed\private\filehelpers.cpp:2070] UE4Editor_UnrealEd!FEditorFileUtils::LoadDefaultMapAtStartup() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\editor\unrealed\private\filehelpers.cpp:3283] UE4Editor_UnrealEd!FUnrealEdMisc::OnInit() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\editor\unrealed\private\unrealedmisc.cpp:299] UE4Editor_UnrealEd!EditorInit() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\editor\unrealed\private\unrealed.cpp:86] UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\runtime\launch\private\launch.cpp:133] UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() [d:\buildfarm\buildmachine_++ue4+release-4.11\engine\source\runtime\launch\private\windows\launchwindows.cpp:200] UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll
                Matt Norman - Wingman Games Pty Ltd
                Email: mattnorman@wingmangames.com
                Web: www.police1013.com
                Facebook: www.facebook.com/police1013

                Comment


                  Originally posted by Luupinh View Post
                  Hi!

                  I have notice that material parameters is no longer accessible by using "Set _____ Parameter Value" node

                  Is it have anything to do with the following update?

                  "New: Material parameters can now be animated in level sequences."
                  Set Scalar/Vector/Etc Parameter Value nodes work the same as before. Make sure you're trying to add it to Material Instance Dynamic type (or cast to it first)..
                  • Follow me on twitter
                  • Visit our website traverse.world
                  • Checkout our game's forum thread

                  Comment


                    The substance plug-in is not supported yet for this version.

                    There was a message when opening a 4.11 copy about the missing substance plug-in, but on the marketplace it is not available for 4.11.
                    The copy also crashed before opening, but this might be related to the substance plug-in.

                    Comment


                      Unreal Engine 4.11: Realtime Lightning from final fantasy XIII

                      Hi this my first work with unreal using the new updated version, for the next step i will make the character playable using persona and blueprint script in nice environment, my goal is to achieve square enix quality game with unreal engine.






                      This is a demo video for my work:

                      https://www.youtube.com/watch?v=TzzhI_Oezac
                      Last edited by Cartamania; 04-03-2016, 05:23 AM.

                      Comment


                        Can someone tell me how to update to 4.11 from 4.10.4? I must be blind.
                        Last edited by toiletpotato; 04-03-2016, 06:03 AM.

                        Comment


                          Originally posted by toiletpotato View Post
                          Can someone tell me how to update to 4.11 from 4.10.4? I must be blind.
                          Open the launcher - go to the library tab - click on "add version" - choose 4.11 - install

                          Comment


                            Originally posted by Ektophase View Post
                            +1 have the same problem, goes away when I do a an actual build and seems to only happen in editor when F11 fullscreen (Win7 64 with AMD hd7870)
                            Originally posted by creasso View Post
                            I got troubles with the SkeletalMeshComponents on my Async Loaded Modular Character Class.

                            After update an assert is breaking the project because BoneIndexes, something related to MasterBoneMap getting empty, I think SetMasterPoseComponent() is not filling the MasterBones properly with dinamically loaded meshes, the project runs fine on 4.10.3.

                            I'm dying to try the new features, but, without my character class working there is not much sense on the remaining things.

                            The trouble is get another 1.9GB download of the pdbs to debug the entire thing, was this already reported?
                            Hi everyone,

                            If you are running into a bug, please report it to the Bug Reports section of the answerhub so we can assist you more in depth. You can find a link to the Bug Reports section as well as a link for how to report a bug in my signature. Thanks!
                            Adam Davis | Marketplace Support | Epic Games
                            How to report a bug? | Installation & Setup issues? | Answerhub Bug Reports | Twitter

                            Comment


                              Too bad the character rendering example misses a lot of very important pieces!

                              We have the eyeball itself. However the tear line, eye shell and tear duct blend meshes & shaders are missing, despite the fact that these parts are equally important to realistic eye rendering. I hope the example will be updated with the eyes sitting in the example head including all the components I just listed.

                              Thanks!
                              Last edited by The_Distiller; 04-04-2016, 11:07 AM.
                              ArtStation - Portfolio

                              Comment


                                Custom build doesn't work.

                                Can anyone using OSX build and run the engine at all?

                                I've tried on two machines and the build works successfully:

                                -------- End Detailed Actions Stats -----------------------------------------------------------
                                Total build time: 3703.46 seconds
                                Compiling with MacOSX SDK 10.11
                                Deploying now!

                                === BUILD TARGET UE4 OF PROJECT UE4 WITH CONFIGURATION Development Editor ===

                                Check dependencies

                                Touch /Users/doug/dev/unreal/UnrealEngine/Engine/Binaries/Mac/UE4Editor.app
                                cd /Users/doug/dev/unreal/UnrealEngine/Engine/Intermediate/ProjectFiles
                                /usr/bin/touch -c /Users/doug/dev/unreal/UnrealEngine/Engine/Binaries/Mac/UE4Editor.app

                                RegisterWithLaunchServices /Users/doug/dev/unreal/UnrealEngine/Engine/Binaries/Mac/UE4Editor.app
                                cd /Users/doug/dev/unreal/UnrealEngine/Engine/Intermediate/ProjectFiles
                                builtin-lsRegisterURL /Users/doug/dev/unreal/UnrealEngine/Engine/Binaries/Mac/UE4Editor.app

                                ** BUILD SUCCEEDED **
                                ...but launching the editor results in:

                                MachineId:142D037BD44E186B57F275BC6DC73D34
                                EpicAccountId:

                                Generating report for minidump

                                Application version 4.11.0-0
                                ... built from changelist 2818068

                                OS version 10.11.4.24165
                                Running 1 x64 processors
                                Exception was " SEGV_MAPERR at 0x3"

                                Source context from "engine/source/runtime/core/private/genericplatform/genericplatformmisc.cpp"

                                <SOURCE START>
                                <SOURCE END>

                                <CALLSTACK START>
                                FGenericPlatformMisc::RaiseException(unsigned int) Address = 0x1069fa97b [/Users/doug/dev/unreal/UnrealEngine/Engine/Source/Runtime/Core/Private/GenericPlatform/GenericPlatformMisc.cpp, line 294] [in UE4Editor-Core.dylib]
                                The machine specs are:

                                10.11.4 (15E65)
                                iMac (Retina 5K, 27-inch, Late 2015)
                                3.2 GHz Intel Core i5
                                32 GB 1867 MHz DDR3
                                AMD Radeon R9 M380 2048 MB
                                Notice that this occurs when opening existing projects, or when just launching the editor in general, the debug output shows this when running in automation mode to try to get some idea of what's going on:

                                Syncing project file for TestProject

                                Setting up Unreal Engine 4 project files...

                                Setting up Mono
                                Generating data for project indexing... 100%
                                Writing project files... 100%
                                Building: /Users/doug/dev/unreal/packages/unreal-npp/tests/bin/../TestProject.uproject
                                Setting up Mono
                                Building UBT...
                                0 Error(s)
                                Building TestProjectEditor...
                                2016-04-04 00:02:12.241 defaults[24951:228578]
                                The domain/default pair of (/Users/doug/Library/Preferences/com.apple.dt.Xcode, IDEBuildOperationMaxNumberOfConcurrentCompileTasks) does not exist
                                Running command : Engine/Binaries/DotNET/UnrealBuildTool.exe TestProjectEditor Mac Development -deploy /Users/doug/dev/unreal/packages/unreal-npp/tests/bin/../TestProject.uproject
                                Compiling with MacOSX SDK 10.11
                                Target is up to date
                                Compiling with MacOSX SDK 10.11
                                Deploying now!
                                Fatal error: [File:/Users/doug/dev/unreal/UnrealEngine/Engine/Source/Runtime/Engine/Private/ShaderCompiler/ShaderCompiler.cpp] [Line: 1308]
                                Couldn't launch /Users/doug/dev/unreal/UnrealEngine/Engine/Binaries/Mac/ShaderCompileWorker! Make sure the file is in your binaries folder.
                                No special flags were passed to build this, just:

                                git clone git@github.com:EpicGames/UnrealEngine.git --recursive --depth 1 --branch 4.11.0-release
                                cd UnrealEngine
                                sh ./Setup.sh
                                sh ./GenerateProjectFiles.sh
                                xcodebuild -workspace UE4.xcworkspace -scheme UE4

                                Comment

                                Working...
                                X