Announcement

Collapse
No announcement yet.

Unreal Engine 4.11 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Hey,

    pretty bad bug here, if you show the mouse cursor through the setting in the player controller, you wont get any mousex/y events in your game then (this works when the mouse cursor is hidden).

    https://answers.unrealengine.com/que...se-events.html

    Cheers,
    Indy
    I belive it was always like that. It bothers me too (https://forums.unrealengine.com/show...input-handling)
    Last edited by Skylonxe; 03-25-2016, 05:35 PM.

    Comment


      Is this correct

      Editor symbols for debugging = 8.17 GB? Thats a lot of symbols
      LEGENDS OF EPICA | CS - SPACE ALPHA

      Comment


        Yeah, it's normal. Debugging symbols are typically larger than the executable. The .pdb for your game will probably be more than 100MB as well.
        Helium Rain, a realistic space opera

        Comment


          Originally posted by Skylonxe View Post
          I belive it was always like that. It bothers me too (https://forums.unrealengine.com/show...input-handling)
          Nope,

          in that case with 4.11 i press a mouse button and then i never get any mouse input; The other issue you linked is that you only get input when a button is pressed.
          This worked flawlessly up to 4.10.

          This effectively means that the FinalCamera from the Marketplace is unusable in the current state of 4.11 which worries me a bit :/


          Cheers,
          Indy
          FinalCamera on Marketplace / Web Demo
          TopDown Toolkit on Marketplace / Web Demo

          Comment


            Hey Epic guys,

            great work so far. I love coding with the unreal engine.
            But will there be a way to give different canvas planes in UMG another z location or rotation value?

            Comment


              Originally posted by Skylonxe View Post
              I belive it was always like that. It bothers me too (https://forums.unrealengine.com/show...input-handling)
              It wasn't always like that
              Originally posted by SinineSiil View Post
              Newest preview made so that mouse axis getters won't give any values if mouse cursor is set to be visible.

              Why such weird changes?
              In 4.10 the behavior was strange as well requiring you to hold any mouse button down for value to update if cursor was visible.
              4.11 was great so far with no weirdness - axis values updated without needing mouse buttons to be held, but now it doesn't work at all if cursor is visible.

              Edit:
              I'm talking about this setup:

              Comment


                Originally posted by SinineSiil View Post
                It wasn't always like that
                Hey SinineSiil,

                sorry, didnt see your earlier post; I wouldnt have spent an hour in the debugger if i had seen this before

                So yes, this is a really bad issue, [MENTION=9161]ep[/MENTION]ic, you got this on your radar?

                Cheers,
                Indy
                FinalCamera on Marketplace / Web Demo
                TopDown Toolkit on Marketplace / Web Demo

                Comment


                  Originally posted by indygoof View Post
                  Hey SinineSiil,

                  sorry, didnt see your earlier post; I wouldnt have spent an hour in the debugger if i had seen this before

                  So yes, this is a really bad issue, [MENTION=9161]ep[/MENTION]ic, you got this on your radar?

                  Cheers,
                  Indy
                  It should be, but I'm unsure if it'll be fixed for final 4.11 release.. It's not on known issues list.
                  https://answers.unrealengine.com/que...ow-cursor.html
                  After doing some testing and a bit of digging I was able to find that this is a known issue (UE-19925) and that it has been submitted to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

                  Comment


                    Is 4.11 still targeted for this upcoming week?

                    Comment


                      Originally posted by SinineSiil View Post
                      It should be, but I'm unsure if it'll be fixed for final 4.11 release.. It's not on known issues list.
                      https://answers.unrealengine.com/que...ow-cursor.html
                      Ok, made a pull request for the 4.11 to fix this issue: #2206
                      [MENTION=9161]ep[/MENTION]ic, please consider this one, as it is really small and makes the mouse capture working correctly again!

                      Edit: Also fixed this now in a seperate pull request for the master branch: #2207

                      Cheers,
                      Indy
                      Last edited by indygoof; 03-28-2016, 07:07 AM. Reason: Added additional pull request
                      FinalCamera on Marketplace / Web Demo
                      TopDown Toolkit on Marketplace / Web Demo

                      Comment


                        Originally posted by indygoof View Post
                        Ok, made a pull request for the 4.11 to fix this issue: #2206
                        [MENTION=9161]ep[/MENTION]ic, please consider this one, as it is really small and makes the mouse capture working correctly again!

                        Edit: Also fixed this now in a seperate pull request for the master branch: #2207

                        Cheers,
                        Indy
                        Thank you!
                        Do you think this is a bug and not intended change? I really hope it's a bug, but I have feeling that it's may be intentional change related to input modes (game only/ui only). Does Show Mouse cursor change input mode?
                        There's still no GET Input Mode node so I can't even test it https://forums.unrealengine.com/show...nput-Mode-node

                        Comment


                          Originally posted by TheJamsh View Post
                          Answerhub is down for me again (I give up with that website), so I'm posting issues here for now.
                          Try clearing all browsing data, that's what fixed all problems for me on AnswerHub and this forum.
                          | QuinnVR | Portfolio | Twitter |

                          Comment


                            Originally posted by SinineSiil View Post
                            Thank you!
                            Do you think this is a bug and not intended change? I really hope it's a bug, but I have feeling that it's may be intentional change related to input modes (game only/ui only). Does Show Mouse cursor change input mode?
                            There's still no GET Input Mode node so I can't even test it https://forums.unrealengine.com/show...nput-Mode-node
                            Hey,

                            nope, this was done during a refactoring for the individual views to manage their active state; so i guess the change was done because it "looked correct" at the first look, but when following the whole flow that change meant that mouse capture would only work if either the mouse cursor was hidden from the playercontroller or the mouse cursor would be intentionally be hidden during the mouse capture (and i have to admit i got no idea why this would make sense, but maybe on a different platform?). So all i did was to move the capture up a little (as it was before actually).

                            Cheers,
                            Indy
                            FinalCamera on Marketplace / Web Demo
                            TopDown Toolkit on Marketplace / Web Demo

                            Comment


                              Originally posted by indygoof View Post
                              Hey,

                              nope, this was done during a refactoring for the individual views to manage their active state; so i guess the change was done because it "looked correct" at the first look, but when following the whole flow that change meant that mouse capture would only work if either the mouse cursor was hidden from the playercontroller or the mouse cursor would be intentionally be hidden during the mouse capture (and i have to admit i got no idea why this would make sense, but maybe on a different platform?). So all i did was to move the capture up a little (as it was before actually).

                              Cheers,
                              Indy
                              Thank you
                              I had similar issue year ago with mouse capture and input modes which turned out to be intentional so I was afraid it would happen again.

                              Comment


                                question, do we have access to unreal jira ?

                                Thanks

                                Comment

                                Working...
                                X