Announcement

Collapse
No announcement yet.

Unreal Engine 4.11 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Any info on UE-26410? Thanks!

    Comment


      I'm still having this issue, it's been a couple of months now since I initially tried to upgrade to 4.11 - my project just refuses to open. Have updated to 4.11 P7 now, still the same problem.

      I get to 90% loaded everytime, and then I get this.

      Click image for larger version

Name:	Project.JPG
Views:	1
Size:	244.1 KB
ID:	1102105

      Project literally works flawlessly in 4.10 and previous versions, it's only 4.11 where I start to get this problem. I haven't messed around with any modules or plugins, and the call stack isn't really helpful.

      Answerhub:
      https://answers.unrealengine.com/que...geeditmod.html

      EDIT: Updating the answerhub post too, but I seem to have found a workaround... the issue appears to be caused by the 'Plugins' section of my .UProject file. I guess ages ago I disabled a whole bunch of plugins I don't use, but not using one of them is causing a module crash.

      .UProject File Causing Crash
      Code:
      {
      	"FileVersion": 3,
      	"EngineAssociation": "4.11",
      	"Category": "",
      	"Description": "",
      	"Modules": [
      		{
      			"Name": "BZGame",
      			"Type": "Runtime",
      			"LoadingPhase": "Default",
      			"AdditionalDependencies": [
      				"UMG",
      				"Engine",
      				"CoreUObject",
      				"AIModule"
      			]
      		}
      	],
      	"Plugins": [
      		{
      			"Name": "GearVR",
      			"Enabled": false
      		},
      		{
      			"Name": "OculusInput",
      			"Enabled": false
      		},
      		{
      			"Name": "OculusLibrary",
      			"Enabled": false
      		},
      		{
      			"Name": "OculusRift",
      			"Enabled": false
      		},
      		{
      			"Name": "SteamVR",
      			"Enabled": false
      		},
      		{
      			"Name": "GitSourceControl",
      			"Enabled": false
      		},
      		{
      			"Name": "SubversionSourceControl",
      			"Enabled": false
      		},
      		{
      			"Name": "LightPropagationVolume",
      			"Enabled": false
      		},
      		{
      			"Name": "CodeLiteSourceCodeAccess",
      			"Enabled": false
      		},
      		{
      			"Name": "KDevelopSourceCodeAccess",
      			"Enabled": false
      		},
      		{
      			"Name": "NetcodeUnitTest",
      			"Enabled": true
      		},
      		{
      			"Name": "HTML5Networking",
      			"Enabled": false
      		},
      		{
      			"Name": "MacGraphicsSwitching",
      			"Enabled": false
      		},
      		{
      			"Name": "SlateRemote",
      			"Enabled": false
      		},
      		{
      			"Name": "AndroidMoviePlayer",
      			"Enabled": false
      		},
      		{
      			"Name": "AndroidMedia",
      			"Enabled": false
      		},
      		{
      			"Name": "AppleMoviePlayer",
      			"Enabled": false
      		},
      		{
      			"Name": "AvfMedia",
      			"Enabled": false
      		},
      		{
      			"Name": "LeapMotionController",
      			"Enabled": false
      		},
      		{
      			"Name": "ArchVisCharacter",
      			"Enabled": false
      		},
      		{
      			"Name": "ScriptGeneratorPlugin",
      			"Enabled": false
      		},
      		{
      			"Name": "UObjectPlugin",
      			"Enabled": false
      		},
      		{
      			"Name": "LevelSequenceEditor",
      			"Enabled": true
      		},
      		{
      			"Name": "AndroidDeviceProfileSelector",
      			"Enabled": false
      		},
      		{
      			"Name": "ExampleDeviceProfileSelector",
      			"Enabled": false
      		},
      		{
      			"Name": "IOSDeviceProfileSelector",
      			"Enabled": false
      		},
      		{
      			"Name": "LinuxDeviceProfileSelector",
      			"Enabled": false
      		},
      		{
      			"Name": "WindowsDeviceProfileSelector",
      			"Enabled": true
      		},
      		{
      			"Name": "Paper2D",
      			"Enabled": false
      		}
      	],
      	"TargetPlatforms": [
      		"WindowsNoEditor",
      		"Desktop"
      	]
      }
      .UProject File Not Causing Crash
      Code:
      {
      	"FileVersion": 3,
      	"EngineAssociation": "4.11",
      	"Category": "",
      	"Description": "",
      	"Modules": [
      		{
      			"Name": "BZGame",
      			"Type": "Runtime",
      			"LoadingPhase": "Default",
      			"AdditionalDependencies": [
      				"UMG",
      				"Engine",
      				"CoreUObject",
      				"AIModule"
      			]
      		}
      	],
      	"TargetPlatforms": [
      		"WindowsNoEditor",
      		"Desktop"
      	]
      }
      Last edited by TheJamsh; 03-09-2016, 05:10 PM.

      Comment


        i noticed, that the bug "UE-26273" (related to Hot Reload) is not listed in neither known issues, nor in fixed with preview 7 (i remember in preview 5 it was in the "known issues" list)

        Comment


          Originally posted by Gwenn View Post
          I'm guessing you meant "migrate from 4.11 to a stable 4.10". I don't have an answer but not all versions behave the same - 4.10 to 4.9 worked for example, 4.9 to 4.8 didn't. I'm afraid the downgrade doesn't work for valid reasons, like changes in the file format , so you should wait the 4.11 stable and deal with it, or go back to your last 4.10 commit and branch in your version control system - so that you can keep working, and get your changed bvack with a merge once 4.11 is released.
          I actually meant migrating from unstable 4.11 to stable 4.11 when it comes out . Fully aware downgrading will cause issues .I dont mind the wait so long as i can be certain i can go to the stable path again whenever i need to through the 4.11 release . Thanks for the info though .

          Comment


            Originally posted by Stephen Ellis View Post
            Hi all. Thanks for the feedback, but the forums are not an ideal place for investigations into bug reports. Please click the link in my signature to log a report on the UE4 Answerhub so that Epic's Support staff can investigate.

            Thanks!
            Here's the crash report on AnswerHub. Thanks !

            Originally posted by codehawk64 View Post
            I actually meant migrating from unstable 4.11 to stable 4.11 when it comes out .
            I never had issues upgrading from preview to stable builds, so I guess that's safe.
            Helium Rain, a realistic space opera

            Comment


              Originally posted by Saah88 View Post
              i noticed, that the bug "UE-26273" (related to Hot Reload) is not listed in neither known issues, nor in fixed with preview 7 (i remember in preview 5 it was in the "known issues" list)
              Hi Saah88,

              Sorry for any confusion this may have caused, but it looks like the fix version has been shifted to the future release of 4.12 to be looked into for a fix. This would explain why you're not seeing it in the 4.11 known issues list any longer.
              Tim Hobson | Learning Resources | Epic Games
              UE4 Documentation
              Wiki Troubleshooting Guides: Lighting | Swarm Agent | Destructibles |
              _____________________________________________
              Follow me on Twitter @TimHobsonUE4 | My Personal Website
              Photons Be Free: Mini-Tutorials and other Curiosities

              Comment


                Sorry for posting again, but just wanted to get my question out there again: On the roadmap, it says that lighting channels have some serious performance implications, and should be considered cinematics only. This was written a year ago, so I just wanted to quickly check if this is still going to be the case?

                Comment


                  Possible bug on terrain flickering with tessellation enabled and height map values above 10 in my case, I know this has been reported before but I was wondering since it hasn't yet been addressed in 4.11?

                  Perhaps I missed a solution but i looked everywhere!

                  Previous reports here:

                  https://answers.unrealengine.com/que...landscape.html

                  Edit - I have noticed that there are posts mentioning that I shouldn't use tessellation on landscapes? I don't know if this still applies.
                  Last edited by William K; 03-10-2016, 01:07 PM.

                  Comment


                    Originally posted by William K View Post
                    Possible bug on terrain flickering with tessellation enabled and height map values above 10 in my case, I know this has been reported before but I was wondering since it hasn't yet been addressed in 4.11?

                    Perhaps I missed a solution but i looked everywhere!

                    Previous reports here:

                    https://answers.unrealengine.com/que...landscape.html

                    Edit - I have noticed that there are posts mentioning that I shouldn't use tessellation on landscapes? I don't know if this still applies.
                    even i am interested about this because of distance flickering when ground is tessellated
                    tox.chat - Skype alternative
                    blender.org - 3D suite

                    Comment


                      Originally posted by AE_3DFX View Post
                      even i am interested about this because of distance flickering when ground is tessellated
                      Okay Managed to come around it by not scaling the landscape and instead using "manage component" to add resolution tothe after I created it. I'm not sure if it was a good idea to scale terrain but I wont be doing it anymore just in case, even thought Unreal Documentation mentions scaling.

                      Regarding Flickering, that has to do with your material setup, you can do a few tricks there consider this:

                      https://wiki.unrealengine.com/Distan...lation_-_Video

                      Also make sure to have "Max displacement" in your material set to 100 no matter what took me hours to find out what the camera edge artifact was all about.

                      Hope this helps.

                      Comment


                        Hi All,
                        I'm trying to test on Apple TV, it did not work (prew 1-7). I have all set up. (Apple cert/profiles/DeviceID TV/AppID/ for TV in Dev Member central , In UE 4 all is Green, cert/profiles/bundle name, Apple TV as target platform)

                        When cooking from editor,

                        1. Mobile Device 'TV' connected - OK
                        2. Transferring IPA to device 'TV' - OK
                        3. Installing IPA on device 'TV' - OK

                        at end shows "PackagingResults:Error: Error Deployment failed! Unknown Error"

                        where could I make a mistake?

                        Thanks

                        Win 8.1, PC, Apple TV 2015, UE4 4.11. p 1-7

                        PS: sorry for my english
                        Last edited by 3DA; 03-11-2016, 12:13 PM.

                        Comment


                          hi, in 4.11p1-7 my vehicles start lagging(visually this looks like a lags in games via bad internet, when one player drive a vehicle and another gunner.... ) when i drive them.... first i think this a 4.11p1 but now im in 4.11p7 and i still have this problem, now I start worried about final release of 4.11, maybe Epic change something in vehicles? also i try recreate new simple car in maya and then import it in ue in standard vehicle example and i also have a little lags(not big like in my advanced suspension car but i have it) so maybe some one else saw this in yours projects?

                          Comment


                            Originally posted by William K View Post
                            Okay Managed to come around it by not scaling the landscape and instead using "manage component" to add resolution tothe after I created it. I'm not sure if it was a good idea to scale terrain but I wont be doing it anymore just in case, even thought Unreal Documentation mentions scaling.

                            Regarding Flickering, that has to do with your material setup, you can do a few tricks there consider this:

                            https://wiki.unrealengine.com/Distan...lation_-_Video

                            Also make sure to have "Max displacement" in your material set to 100 no matter what took me hours to find out what the camera edge artifact was all about.

                            Hope this helps.
                            Thanks but setting to 100 wont help, i use DR_TESS_LAND01 ground tessellation. Selecting ground helps and until it is selected then no light flashes, this is temporary workaround.
                            tox.chat - Skype alternative
                            blender.org - 3D suite

                            Comment


                              Just an advise, when you finally release 4.11, can you include a list of "known issue" including any fixes in 4.12 or internal but not fixed in 4.11?

                              Comment


                                I am using preview 6.

                                After doing a Full Rebuild of multiple sub levels (20 or more) in a Large Map using World Composition, I cannot save the maps, the editor hangs at 'Updating File(s)Source Control Status' dialogue, and doesn't save the map files.

                                These same maps save extremely fast and and do not get this source control message when saved at any other time. We are using Perforce. I can re-open the level and save them all if I don't rebuild the map first. Building each map individually also works, as does doing 4 or 5 at a time, there seems to be a threshold of of actors or maps getting rebuilt in one go, after which they cannot be saved.

                                - EDIT - After turning off Source Control, I have the same problem saving maps after more than 20 have been rebuilt. The editor hangs on 'Saving Map - name' dialogue instead of the source control dialogue.

                                I have also tried with rebuilding combinations different sub levels, there is not one specific map that won't save after being rebuild, it just seems to be the number of them.
                                Last edited by UppercutAJ; 03-11-2016, 09:55 AM.

                                Comment

                                Working...
                                X