Announcement

Collapse
No announcement yet.

Unreal Engine 4.10 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Thanks very much KVogler, that fixed it!

    Leave a comment:


  • replied
    I still can't create a c++ project with 4.10... I have downloaded Preview 2 and I have also installed VS2015, and I still get this:
    I think its the same error I had in the beginning.
    VS2015 did install everything, except the C++ stuff.
    Just rerun the setup program or access the entry in the windows control panel.
    After you click it, you can either repair, modify or uninstall. Choose modify and add the missing C++ components. Then you should be good to go...

    Leave a comment:


  • replied
    I still can't create a c++ project with 4.10... I have downloaded Preview 2 and I have also installed VS2015, and I still get this:

    Leave a comment:


  • replied
    Originally posted by tyoc213 View Post
    I'm not sure, but AFAIK this only apply to build/distributed version, if you compile from source unreal engine you should be OK.
    Correct. For now, you can still stick with VS2013 if you compile with Source code out of Github.
    Last edited by Stephen Ellis; 10-20-2015, 04:19 PM.

    Leave a comment:


  • replied
    Originally posted by Antidamage View Post
    Ouch. We only bought VS Pro 2013 three months ago because UE didn't support 2015 then. Now it's 2015 or nothing. Any chance of fixing this Stephen? It doesn't seem like a technical limitation.
    I'm not sure, but AFAIK this only apply to build/distributed version, if you compile from source unreal engine you should be OK.

    Leave a comment:


  • replied
    update topic name to PREVIEW 2

    Leave a comment:


  • replied
    Oh no, I didn't try that. Though that hints at more UBT/project generation script bugs.

    But you can try to execute (in your games dir):

    Code:
    UnrealBuildTool.exe -projectfiles -project="fullpath" -game -2015
    Have the UBT of your launcher engine install in path (Engine\Binaries\DotNet I believe).

    Leave a comment:


  • replied
    Originally posted by Mikand79 View Post
    You write "GenerateProjectFiles -2015" on the command prompt in the root of your UE source clone, after you run Setup.bat, and it will generate a vs2015 build.

    I didn't yet test p2 but p1 may need some environment variables set/changed (see further up in this thread). It just doesn't seem to do the right thing for game projects outside of the engine tree, Im not able to get the environment right. Probably some bugs on both VS2015 side and UBTs side.
    Even in Binary / Launcher version where that file doesn't exist?

    Leave a comment:


  • replied
    Originally posted by KitatusStudios View Post
    I'm having a problem where VS2015 won't run at all; I'm getting an error where it's forcing 2013 for Android and to fix it run with -2015 but nothing is actually telling me where to put -2015. Everywhere I tried isn't working.
    You write "GenerateProjectFiles -2015" on the command prompt in the root of your UE source clone, after you run Setup.bat, and it will generate a vs2015 build.

    I didn't yet test p2 but p1 may need some environment variables set/changed (see further up in this thread). It just doesn't seem to do the right thing for game projects outside of the engine tree, Im not able to get the environment right. Probably some bugs on both VS2015 side and UBTs side.

    Leave a comment:


  • replied
    I notice you merge 4.10.0-preview-2 to release branch... ???

    Leave a comment:


  • replied
    Are there any advances on the implementation of DX12 when using LPV and/or Distance Fields? I'm refering to this entries UE-21075 and UE-20622. Great update btw!

    Leave a comment:


  • replied
    I'm having a problem where VS2015 won't run at all; I'm getting an error where it's forcing 2013 for Android and to fix it run with -2015 but nothing is actually telling me where to put -2015. Everywhere I tried isn't working.

    Leave a comment:


  • replied
    UPDATE!

    We have just released Preview 2 for 4.10! Please view the Known Issues List on page 1 of this thread for the updated list of known issues.

    Thank you for your continued help in testing the 4.10 build before its official release. As a reminder, the Preview builds are for testing only, and should not be used for the active development of your project.

    Cheers!

    Fixed in Preview 2 - CL 2733139

    Fixed! UE-20705 Adding more than two blank strings to a Combobox using a new Userwidget causes crash
    Fixed! UE-22148 UFE Crashes on Mac when clicking a dropdown located in an inactive UFE window
    Fixed! UE-22182 UFE crashes on Mac in FAndroidDeviceDetection::UpdateADBPath()
    Fixed! UE-15914 [CrashReporter] Crash when adding/editing camera to auto activate on player
    Fixed! UE-22063 The initial compile for code projects fails in Xcode
    Fixed! UE-21413 Exporting mesh results in a corrupt FBX
    Fixed! UE-22076 UE4 Releases: UE4_Win64_Mono_Precompiled Compile Failure on CL 2726813
    Fixed! UE-21962 Github editor source fails to compile with virtual memory range error
    Fixed! UE-22101 Xbox One: Projects packaged for shipping hard-lock
    Fixed! UE-21995 Packaged games should run the VS 2015 vcredist installer
    Fixed! UE-21785 Log spam when deleting a Level Sequence from Sequencer
    Fixed! UE-22051 Potential for copyData to run off the end of the command buffer
    Fixed! UE-21707 Checkboxes and highlighting of chosen mobileprovision can be inconsistent
    Fixed! UE-22170 Tooltips are jumping to the bottom of the editor on Mac
    Fixed! UE-21669 Window->Developer Tools->Device Profiles doesn't show any specific Android device profiles
    Fixed! UE-22136 Java files in project's Build/Android/src other than the templates are deleted when packaging for Android

    REMEMBER: Please report any new bugs you find to the UE4 Answerhub

    Leave a comment:


  • replied
    Originally posted by DevUnreal48 View Post
    Did someone answer this problem?
    Error 2 error C1076: compiler limit : internal heap limit reached; use /Zm to specify a higher limit c:\program files\epic games\4.10\engine\source\runtime\core\public\delegates\DelegateSignatureImpl_Variadics.inl 272 1 ZOMBIETOWNAHHH
    I too am having this problem - I am using VS 2013 PRO

    Leave a comment:


  • replied
    This release is super cool for two reasons :

    - bugfixes, not features !
    - first UE release that doesn't break anything on my project !

    I understand that people are always asking for features, but this kind of release is very much welcome and I really appreciate it. I don't even know which bugs were fixed, but the fact that you're doing stability is really good news.

    Leave a comment:

Working...
X