Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Released!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Jimmy_Jazz View Post
    I have a Landscape orientated Android project for an NVidia Shield that was working correctly with Preview 8.

    However, now that I have moved onto the 4.7 Release the camera FoV is significantly wider and the virtual thumb sticks have been squashed vertically to about 2/3 of their original height. Has anyone else seen this before or do they have any ideas on what could be going on?
    Hello,

    Thank you very much for letting us know of the issues you're experiencing with our new release. There is currently a bug (UE-9784) in place for the Android issue you're experiencing. We are working on this issue however, it has yet to be resolved. A way to work around this issue is to relaunch your project onto the device you're using as it does not seem to happen each time it's launched.

    If you notice that it's happening most of the time that you launch the project to the Android device, please submit a question to Answerhub.

    Thank you!
    Twitter @UnrealSamantha
    Mobile Development Troubleshooting Guide | Package and Deployment Troubleshooting | How do I report a bug?
    Call me to a thread by posting this: [MENTION]Samantha Sutton[/MENTION]

    Comment


      FYI

      I compiled a new clean project from ShooterGame this morning that says it works with 4.7.0. And while it did run in the editor fine (BTW, cool new logo screen!) when I compiled it and tried to run it after a successful build, all I got was the infamous black screen of death. However, I did hear the audio of the new logo screen when the game fired up.

      Comment


        Originally posted by John Alcatraz View Post
        I don't really like this release I can't get my project running in 4.7 (crashes on startup). I think Epic should have made some more preview releases and they should not have added new features in preview 6 or 7...
        John, do you have an existing AnswerHub thread or forum post with further information?

        Comment


          Originally posted by Denny View Post
          My Blueprint editing OCD is pleased.

          I wasn't the only one.
          Isaac Nichols
          Game Developer & Music Producer - Threaded Pixel Studios
          Currently working on Drones & Ruins a Sci-Fi twin-stick shooter.

          Comment


            Originally posted by Isaac Nichols View Post
            I wasn't the only one.
            No, you certainly where NOT in a minority on this topic! The new changes are GOOD!

            Comment


              Originally posted by Daniel Vogel View Post
              John, do you have an existing AnswerHub thread or forum post with further information?
              Indeed I have, first this was a problem which occured in 4.6.1 but there fix some stuff in one blueprint fixed it, but I can't get the project to run in 4.7.

              https://answers.unrealengine.com/que...g-project.html

              I think there is some issue with your "project convert algorithm" in 4.7 because I just tried again to convert my fully working 4.6.1 project (no errors at all) to 4.7 and it just crashes on startup, and the log says there are really many warnings and errors (many which have nothing to do with changes of 4.7).
              Easy to use UMG Mini Map on the UE4 Marketplace.
              Forum thread: https://forums.unrealengine.com/show...-Plug-and-Play

              Comment


                Installing now
                System
                ASUS ROG Maximus IX Forumla - ASUS ROG GeForce GTX 1080 8GB - G.Skill RGB 16GB, Samsung M2 500GB

                ArtStation
                Artwork thread

                Comment


                  Originally posted by Demolition Man View Post
                  Hi Guys,
                  I noticed this morning that everything is now listed for one cent less in the marketplace (i.e. instead of $30 for an item, it's $29.99). Is this a glitch in the marketplace related to the 4.7.0 release?
                  Hi! The price change to prices ending in '99' is no accident. Here at Epic Games we're constantly researching ways to improve the Marketplace for both buyers and sellers. When we initially launched the Marketplace, we chose a round pricing structure for asset costs, keeping them as whole numbers. After further research and consideration, we've changed our pricing policy moving forward to adhere to the tenets of pricing theory, so that all prices will now end in ".99" in USD, and converted to the equivalent in other currencies.

                  What this means is that instead of an asset selling for $30, it'll now sell for $29.99 instead. Studies have shown that this actually increases sales, so that's the direction we're going in now to keep the Marketplace competitive and keep content creators happy. Over the last two weeks I've reached out individually to everyone currently selling assets on the Marketplace, and everyone has agreed to the adjustment.
                  -jon [ web: www.jonjones.com | twitter: @jonjones ]

                  Comment


                    I wrote earlier in this thread that bug UE-6988 was fixed but I think I was wrong about that. The bug is still there.

                    Comment


                      The description in the launcher news reads: "Unreal EngVine 4.7 is our biggest [...]" .

                      Comment


                        Originally posted by Demolition Man View Post
                        FYI

                        I compiled a new clean project from ShooterGame this morning that says it works with 4.7.0. And while it did run in the editor fine (BTW, cool new logo screen!) when I compiled it and tried to run it after a successful build, all I got was the infamous black screen of death. However, I did hear the audio of the new logo screen when the game fired up.
                        Hey Demolition Man-

                        When you say "run it after a successful build" are you referring to compiling the code though Visual Studio or the Editor, or do you mean after packaging the game for Windows? Also could you make a post on the AnswerHub to help us monitor this bug better.

                        Cheers

                        Doug

                        Comment


                          just before my subscription ends
                          lol + yeeeeehaaaa

                          Comment


                            Originally posted by John Alcatraz View Post
                            I think there is some issue with your "project convert algorithm" in 4.7 because I just tried again to convert my fully working 4.6.1 project (no errors at all) to 4.7 and it just crashes on startup, and the log says there are really many warnings and errors (many which have nothing to do with changes of 4.7).
                            Could you make a post on the AnswerHub so that we can track this issue better? If you could check if you have the same problem in a new 4.6.1 project that you convert to 4.7 as well it would help in determining what the exact cause is.

                            Thanks

                            Doug

                            Comment


                              I had before custom AndroidManifest.xml with custom activites and meta-data. How can I add this in 4.7? I only see extra settings for MAIN activity but I don't know how to add new activity... Please help. Eventually where is generating AndroidManifest? I would like to change this...

                              Comment


                                [QUOTE=John Alcatraz;228754]I see I cannot place a delay in a macro in a blueprint of type "macro library". So nothing with components.

                                I placed a ticket for this a while back. Here's a quote:

                                [snip] our devs informed me that this is by design. The reason is, Latent nodes (any node with the clock symbol like below) cannot be used in a macro that can then be used inside of a function. To keep errors from occurring, they blocked all latent nodes inside of the engines StandardMacro library. /end quote

                                I haven't played around with 4.7 since I found that in case it'll get changed back, now I'm wondering if there's a way to get around this. Create your own library based on some other class? It'd be great to hear from the devs what they'd recommend.

                                Comment

                                Working...
                                X