Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Released!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    @kamrann

    Thanks for the info. In that case I will start a clean project and see if that helps. I've brought this one from 4.6.1 and I remember toying around with the Monitor Content Directories prior in previous releases. Back then I couldn't get that to work either, perhaps I messed something up when I was changing the settings?

    Comment


      Originally posted by daniele_niero View Post
      Is there a place where we can submit bugs?
      I have found a problem with color pickers, both on Mac OSX and Windows (7) and tested on two different machines.

      Any color picker UI, the one that appears when we click on a color property, disappear immediately when we click anything or anywhere in it, making impossible to adjust colors within it.
      I'm experiencing this as well, it's a bit of an annoyance. I've been opening linear colour variables and adjusting rgb values directly as a workaround.
      Procedural, modular, on-the-fly animation - iTween For UE4
      - Actors - Components - UMG - Ease In - Ease Out - Path-constrained Animation - $0

      Runtime Datatable
      -All the fun of DataTables dynamically loaded from text or Google Sheets while your game is running!

      Comment


        Is anybody else experiencing problems building for Android? We literally can't deploy to an Android build at all.

        Comment


          Originally posted by Jon Jones View Post
          Hi! The price change to prices ending in '99' is no accident. Here at Epic Games we're constantly researching ways to improve the Marketplace for both buyers and sellers. When we initially launched the Marketplace, we chose a round pricing structure for asset costs, keeping them as whole numbers. After further research and consideration, we've changed our pricing policy moving forward to adhere to the tenets of pricing theory, so that all prices will now end in ".99" in USD, and converted to the equivalent in other currencies.

          What this means is that instead of an asset selling for $30, it'll now sell for $29.99 instead. Studies have shown that this actually increases sales, so that's the direction we're going in now to keep the Marketplace competitive and keep content creators happy. Over the last two weeks I've reached out individually to everyone currently selling assets on the Marketplace, and everyone has agreed to the adjustment.
          I cant be the only one that doesn't care if it increases sales or not, I absolutely hate it. I personally think its stupid, its a bit like gas prices with the 9/10th of a cent at the end, its infuriating and demeaning to people's intelligence. I understand Epic's reasoning behind this, and i'm sure that it might actually sell more, but I would opt in to have that $0.01 added back on, even if its just for show.

          Sorry for the rant, but its been a huge peeve of mine for a long time, similar to why don't we add tax prices into the price of object so people know exactly how much they are going to pay by the time they hit the checkout. We do it to trick and deceive. Someone is far less likely to put something back because tax prices pushed the total price beyond what they can afford, than if the whole price was there for them to see at the beginning they might not even try to buy it. I associate the .99 'trick' with the same boat as the tax 'trick'.

          Again sorry for the rant, i'm not trying to attack Epic or anything, I just personally find it demeaning and would love to see whole numbers even if it is just in my launcher.

          Comment


            I agree. It's obviously not of great importance in the scheme of things. However the thing here is that, as specifically stated, Epic had made the decision to use rounded prices. To then do 'research' and decide to explicitly change the approach is just ridiculous.

            Comment


              (Post moved to feedback thread mentioned by Tim Hobson below. Then I realized it was quoted in the post immediately before the one I made, so you can just read it there)
              Last edited by Aetherdyne; 02-27-2015, 09:16 AM. Reason: Moved post

              Comment


                Hey,

                Can we please keep the conversation here on topic with 4.7 and any issues that may be happening specifically with the editor. A thread has already been started in the Feedback section of the forums that you can discuss the Marketplace change.

                You can see that thread here: https://forums.unrealengine.com/show...e-0-99-pricing

                Thank you!

                Tim
                Tim Hobson | Learning Resources | Epic Games
                UE4 Documentation

                Comment


                  Originally posted by Jon Jones View Post
                  Hi! The price change to prices ending in '99' is no accident. Here at Epic Games we're constantly researching ways to improve the Marketplace for both buyers and sellers. When we initially launched the Marketplace, we chose a round pricing structure for asset costs, keeping them as whole numbers. After further research and consideration, we've changed our pricing policy moving forward to adhere to the tenets of pricing theory, so that all prices will now end in ".99" in USD, and converted to the equivalent in other currencies.

                  What this means is that instead of an asset selling for $30, it'll now sell for $29.99 instead. Studies have shown that this actually increases sales, so that's the direction we're going in now to keep the Marketplace competitive and keep content creators happy. Over the last two weeks I've reached out individually to everyone currently selling assets on the Marketplace, and everyone has agreed to the adjustment.
                  That sounds great Jon! Just wondering since it happened right when we switched over to 4.7.

                  Comment


                    Originally posted by Doug Wilson View Post
                    Hey Demolition Man-

                    When you say "run it after a successful build" are you referring to compiling the code though Visual Studio or the Editor, or do you mean after packaging the game for Windows? Also could you make a post on the AnswerHub to help us monitor this bug better.

                    Cheers


                    Doug

                    I packaged the game (i.e. Just Shooter Game) for running on Windows with the minimum OS being Windows XP via the editor. So when I tried to run the application the window popped up, I ended up with a totally black screen. The editor told me that everything was created successfully (Build successful) but all I got was the audio like I mentioned before.

                    Comment


                      There seems to be a problem with SpawnAI from Class BP when using the option "dedicated server" for testing a clients view.
                      When the enemy gets spawned, it does not react to the Navmesh. It stands still and does not move. It still reacts to services and does tasks, but Navmesh is not registered.
                      AI that already exists in the level does not have this issue.
                      When spawning server and client both as players, AI moves normally.

                      Comment


                        Originally posted by artoculon View Post
                        Hey guys, Light build times are incredibly slow for me now. I started up a small scene which is basically floor + ceiling mesh, walls, and 1 point light. It is currently stuck on 5% for 15 minutes, and earlier had it go to 96% after around 30-40 mins but did not finish.

                        Previously on 4.6 and Previews, a simple scene would build within a minute reliably. Anyone else experiencing this??
                        I have the same problem, on 4.6 the build time was about 15sec for a simple test scene. Now in 4.7 its about 5 minutes for the exact same scene. Also since 4.7 i'm experiencing short slowdowns, stutter problems when flying around the viewport in that scene every few minutes. Never had that problem in 4.6.

                        Comment


                          Tim Hobson: I'm hoping to get an acknowledgment for the Build Lighting issues i'm facing. 4.6.1 I had no issues, a simple scene would take less than a minute to build. In 4.7, I am getting a Lightmass Crash issue everytime, or it just gets stuck.

                          Granted I have 4gb of ram, but in 4.6.1 it never was an issue. I am just testing this right now with a simple scene: floor, ceiling, walls, 1 point light.

                          Semmel: Sorry to hear you're facing this same issue. Does yours eventually build though?
                          vr and new media installations
                          www.samuelwalker.xyz

                          Comment


                            Originally posted by Jared Therriault View Post
                            I'm experiencing this as well, it's a bit of an annoyance. I've been opening linear colour variables and adjusting rgb values directly as a workaround.
                            We've got the color picker issue logged as UE-9745 and already have a fix for it in place for 4.7.1.

                            Cheers
                            Stephen Ellis | Enterprise Program Coordinator

                            Comment


                              Reminder about Bugs

                              Hey everyone,

                              If you are experiencing a bug with the 4.7 release, please remember to log a bug report for the issue on the UE4 AnswerHub to the Bug Reports section. This way Epic can investigate and respond to each issue individually. Unfortunately the forums here are not well suited to investigating bug reports due to all the different conversations, and your reports here may be lost or we may not notice each other's replies. It would also be beneficial if you began the title of your AnswerHub report with [4.7.0].

                              We are currently working hard to investigate, reproduce, and log the 4.7 bug reports that are being submitted to us, especially any crashes. Thanks for both your help and your patience.

                              Cheers!
                              Last edited by Stephen Ellis; 02-26-2015, 04:33 PM.
                              Stephen Ellis | Enterprise Program Coordinator

                              Comment


                                Get distance to function has no execition pins anymore which I used often in my game.
                                I have to make a workaround for that which took me some time now :/
                                I made a question related to that on answer hub.

                                https://answers.unrealengine.com/que...on-to-unp.html
                                Game frameworks on Unreal Marketplace:

                                Third Person Shooter Kit - February 2017 Community Pick! - https://www.unrealengine.com/marketp...on-shooter-kit

                                Side Scroller Shooter Kit - https://www.unrealengine.com/marketp...er-shooter-kit

                                Support Discord channel: https://discord.gg/6rgv5Tj

                                Comment

                                Working...
                                X