Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by aussieburger View Post
    Testing on Android - I don't get build failures - it says builds successfully however it only 'works' if I select development mode - as soon as I select Shipping I get a crash directly after staring the app on the mobile. What else doesn't work anymore are the google play services leaderboard and achievements - a connection is no longer made when starting the app (only once every 10 starts or so it might work). No such troubles in 4.6.
    Same here. Development build works, Shipping build fails instantly on startup. In my case its a converted project from 4.51. Tested on Galaxy S4.

    Even when I make an empty new level and set it as a starting level the app is dumped immediatly. I couldn't check the Achievments etc, but I saw other threads with people having problems there too.

    Comment


      Originally posted by Makotech222 View Post
      Does anyone else have a problem with casting shadows being shown in orthographic camera in 4.7p8? None of my objects cast shadows when i set my camera to orthographic.
      Shadows are working in 4.7 P8 with the camera orthographic view from what I see:

      Click image for larger version

Name:	shadows47orthographic.PNG
Views:	1
Size:	395.7 KB
ID:	1066972

      You may want to check the Engine Scalability settings and make sure that they're set to EPIC, otherwise you will lose the ability to see shadows and post processing along with some other things.

      If you're still having the issue, make a post on the AnswerHub and reply here with a link. I'll assign myself and we can look at what may be the root cause.
      Tim Hobson | Learning Resources | Epic Games
      UE4 Documentation
      Wiki Troubleshooting Guides: Lighting | Swarm Agent | Destructibles |
      _____________________________________________
      Follow me on Twitter @TimHobsonUE4 | My Personal Website
      Photons Be Free: Mini-Tutorials and other Curiosities

      Comment


        By the way, Since how long has "Launch Character" been broken? It only works in one direction no matter what settings you choose. Replicated this in multiple projects and multiple engine versions (4.6 and 4.7 preview 8) :<

        Edit: I think I've figure out why, Let me test!

        Edit Edit: Seems to be doing it via world location. My bad.
        Last edited by KITATUS; 02-23-2015, 01:09 AM.
        KITATUS
        "Information shouldn't be behind a paywall, It should be free for all!"

        Comment


          4.7 Preview 8 bug

          Editor is duplicating projects ( they are visible inside the launcher, but they don't really exist on the hard drive )

          Comment


            Originally posted by VSZ View Post
            Question for Epic:

            Curious to know what the chances of UE-10283 being resolved in time for 4.7 are. The recent Twitch stream indicated that RC builds are on the horizon so that makes me a little anxious.

            The reason I'm following up proactively on this bug is because affected projects cannot run their game in standalone mode which makes it a complete blocker for anyone who needs to run standalone or distribute shipped builds for testing or recording (quicker w/o editor). This would be the second major release in a row where standalone builds don't fully work as 4.6 had the widely reported event dispatcher bug for standalone games, so (at the risk of being nagging and annoying ) I want to make sure this bug is highlighted for your consideration.


            Edit: Adding link to reported issue UE-10283: https://answers.unrealengine.com/que...le-issues.html
            Hi VSZ,

            This is still being assessed by the development staff and may take some time to be implemented in the engine. We appreciate your patience while we get to the root of the error. I do not have a timeframe of when a fix will be implemented on this.
            Adam Davis | Marketplace Support | Epic Games
            How to report a bug? | Installation & Setup issues? | Answerhub Bug Reports | Twitter

            Comment


              Guys any estimated date for 4.7.1 to come ?

              Comment


                Sorry for the bump,

                Do I need to report this as a bug?

                Comment


                  Originally posted by NATO_chrisjm View Post
                  Is this bsp colour a permanent change? I rather liked the two tone version.

                  [shot]http://puu.sh/g0WEt/313b3916c5.png[/shot]

                  I didn't see any acknowledgement about this issue. Is this tracked somewhere with a potential ETA or Hotfix CL#?


                  Cheers,

                  Comment


                    Thanks. I believe my scalability is already set to EPIC. I will do some more analysis when i get home from work. If i still have the problem, i will set up a post in answerhub

                    Originally posted by Tim Hobson View Post
                    Shadows are working in 4.7 P8 with the camera orthographic view from what I see:

                    [ATTACH=CONFIG]26687[/ATTACH]

                    You may want to check the Engine Scalability settings and make sure that they're set to EPIC, otherwise you will lose the ability to see shadows and post processing along with some other things.

                    If you're still having the issue, make a post on the AnswerHub and reply here with a link. I'll assign myself and we can look at what may be the root cause.

                    Comment


                      Originally posted by Phobos View Post
                      I didn't see any acknowledgement about this issue. Is this tracked somewhere with a potential ETA or Hotfix CL#?


                      Cheers,
                      I think this was fixed by https://github.com/EpicGames/UnrealE...7c7c72a76608ba

                      Cheers,
                      Michael Noland

                      Comment


                        I am on Windows, with the latest launcher, but i cannot see 4.7 preview listed in the available versions.

                        Has anyone else come across this issue ? What can i do? I tried quitting, logging out, already.
                        Software Engineer, Game Developer & Cat Owner
                        Check out my blog @ http://www.tallior.com

                        Comment


                          I downloaded 4.7 which is said to be much better for VR.

                          When i open my project, i get an instant crash, every time i try it. I have submitted a few crash reports, but on looking more closely at the last one error log, I am sure it is to do with some of my scenes which are using Distant field shadows.

                          Here is a clip from the Log -

                          Assertion failed: NumPlanes < 12 [File:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Runtime\Renderer\Private\DistanceFieldShadowing.cpp] [Line: 115]

                          If i changed the shadows back to normal, re-saved in 4.6. Would it still work in 4.7 with normal shadowing, and would it still work and be stable if I added distance field shadows again in the 4.7 build?
                          My Marketplace Items

                          My Website

                          My Unreal Games

                          Comment


                            Originally posted by lysergide View Post
                            I am on Windows, with the latest launcher, but i cannot see 4.7 preview listed in the available versions.

                            Has anyone else come across this issue ? What can i do? I tried quitting, logging out, already.
                            I had the same problem, I cleared everything out of the Vaultcache except for one 4.7 project and it offered me the update.

                            Comment


                              Originally posted by Swilliams View Post
                              I downloaded 4.7 which is said to be much better for VR.

                              When i open my project, i get an instant crash, every time i try it. I have submitted a few crash reports, but on looking more closely at the last one error log, I am sure it is to do with some of my scenes which are using Distant field shadows.

                              Here is a clip from the Log -

                              Assertion failed: NumPlanes < 12 [File:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Runtime\Renderer\Private\DistanceFieldShadowing.cpp] [Line: 115]

                              If i changed the shadows back to normal, re-saved in 4.6. Would it still work in 4.7 with normal shadowing, and would it still work and be stable if I added distance field shadows again in the 4.7 build?
                              That worked. Took some time, but 4.7 is up and running now. I have 2 small problems now.

                              1: I cant compile a test game, it hangs on compiling a shader for a material which appears to have no problems, and is very very basic, a dif, spec and normal texture, that it?

                              2: I started with the VR template in 4.6.1, its changed a lot from the original template, but i have never touched the character model and linked IK to the steering wheel, and now its not connected. The components are fine, and the blueprints all compile as normal, but mt characters hands no longer attach to the wheel. Apart from these two small problems, it all seems to be working fine and i do get an FPS increase in 4.7 for VR
                              Last edited by MAGtechnologies; 02-23-2015, 10:14 PM. Reason: typos, as usual :)
                              My Marketplace Items

                              My Website

                              My Unreal Games

                              Comment


                                Originally posted by lysergide View Post
                                I am on Windows, with the latest launcher, but i cannot see 4.7 preview listed in the available versions.

                                Has anyone else come across this issue ? What can i do? I tried quitting, logging out, already.
                                Hi there,

                                Are you still having this issue? We are trying to track down the cause of it currently, if possible could you please post a screenshot showing of the contents of this folder: "C:\ProgramData\Epic\EpicGamesLauncher\Data\Manifests"

                                If you are not able to find the ProgramData folder, click on the "View" menu/tab at the top of Windows Explorer and open up the Options menu. From the popup that opens select the View tab, and then change the option for "Hidden files and folders" to "Show hidden files, folders, drives", and press Ok. You should now see ProgramData in the list of folders on your main drive.

                                That will help us find the cause of this issue. Thank you!
                                Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

                                Comment

                                Working...
                                X