Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Not sure if this is reported but my C++ line traces no longer return a PhysicsMaterial even when the bReturnPhysicalMaterial = true. This does work fine in 4.6 and is broken for me in Preview 7 and Preview 8.
    Game Developer @ LODZERO - My Twitter | tomlooman.com UE4 samples & tutorials | C++ Survival Game (Open-Source)

    Comment


      This is not really a big deal, but where did all of Mode tab colors go? They made the editor look better somehow. lol

      Comment


        Hi Guys,
        Thanks for the preview 8 update. I had a chance to re-compile my test program this afternoon which failed under preview 7 (i.e. see note about 2-3 pages back) and everything is working fine today! Thanks!

        Comment


          Originally posted by Tom Looman View Post
          Not sure if this is reported but my C++ line traces no longer return a PhysicsMaterial even when the bReturnPhysicalMaterial = true. This does work fine in 4.6 and is broken for me in Preview 7 and Preview 8.
          Yes, line trace functions are broken on 4.7; I have the same issue.
          | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

          Comment


            I've been playing with the new blueprint components, but as of 4.7 preview 8 I can no longer save a map that contains actors that use one of these components after making any modification to the component.

            In case that's unclear, I started off with a project (in 4.7 preview 7) where I added a few blueprint components and some actors to a level using that component. I updated to 4.7 preview 8 tonight and made a modification to the component. Now I'm getting this error:

            Can't save ../../../../../../Users/ExpiredPopsicle/Documents/Unreal Projects/MBattle/Content/SideScrollerBP/Maps/SideScrollerExampleMap.umap: Graph is linked to private object(s) in an external package.
            External Object(s):
            FactionComponent_1
            FactionComponent_69
            FactionComponent_0

            Try to find the chain of references to that object (may take some time)?
            And then after trying to continue, this shows up in the editor errors:

            Warning Can't save ../../../../../../Users/ExpiredPopsicle/Documents/Unreal Projects/MBattle/Content/SideScrollerBP/Maps/SideScrollerExampleMap.umap: Graph is linked to external private object (unknown culprit) (unknown property ref)
            I have the project in version control and committed my changes last night before the update, so it's pretty easy to test different things by reverting once it breaks...

            Loading up the project and...
            * moving stuff around: Saves fine.
            * adding new instances of the actor that uses the component: Saves fine.
            * modifying an actor that uses the component (without touching component-related properties): Saves fine.
            * adding a second instance of the component to the actor: Saves fine.
            * modifying a variable exposed by the component on an actor: Saves fine.
            * modifying the replication property on the component: No longer saves.
            * modifying the component's event graph: No longer saves.
            * adding a variable to the component: No longer saves.

            Finally, I played around with a new project a bit and found that any case where I modified a blueprint component after adding it to something and to the map it would exhibit this behavior, but I could work around it if I deleted the component from every actor type that used it and re-added it (even if there were already actors of that type in the level). Deleting the component and re-adding it to the actor type works, but deleting all the actors of that type and re-adding them does not.
            Cliff Jolly - Senior Software Engineer
            Neoglyphic Entertainment
            Working on the NeoFur Plugin

            Comment


              I'm afraid to ask - but am I the only one who cannot add code to a 4.7 Pre8 project?
              Neither "Add code to project" nor "Generate Visual Studio files" successfully works.
              Create a blank project without starter content.
              Add code to project just gives (empty class): Failed to add class MyClass. Failed to generate project files.
              Generate project files in Explorer then gives:
              Running C:/Program Files/Unreal Engine/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="C:/Users/ben/Documents/Unreal Projects/BlankUE47P8/BlankUE47P8.uproject" -game -rocket -progress
              Discovering modules, targets and source code for game...
              Errors detected while compiling C:\Users\ben\Documents\Unreal Projects\BlankUE47P8\Intermediate\Build\BuildRules\ProjectFileGeneratorModuleRules.dll:
              c:\Program Files\Unreal Engine\4.7\Engine\Source\Runtime\CEF3Utils\CEF3Utils.Build.cs(5,14) : error CS0101: The namespace '<global namespace>' already contains a definition for 'CEF3Utils'
              c:\Program Files\Unreal Engine\4.7\Engine\Source\Runtime\WebBrowser\WebBrowser.Build.cs(5,14) : error CS0101: The namespace '<global namespace>' already contains a definition for 'WebBrowser'
              UnrealBuildTool Exception: ERROR: UnrealBuildTool encountered an error while compiling source files
              Do I miss any prerequisites / dependencies?
              VR Shooter Guns - Arcade Shooter for Vive
              Unreal Meetup Franken - Unreal Engine 4 Meetup
              Hands for VR: Basic - For Vive and Oculus [Marketplace]
              Hands for VR: SciFi - For HTC Vive and Oculus Touch [Marketplace]

              Comment


                UE-3480 Launching a project with a custom Game Instance assigned will receive an error and crash the launching window
                Any idea on whether the fix for this will be included in the next preview?
                Twitter: @zerofiftyone_
                Website: zerofiftyone.net - My game development blog
                Button Frenzy store page: http://store.steampowered.com/app/454630

                Comment


                  Hey guys!

                  I've just downloaded the 4.7 8 preview and the speedtree glitch is still there, one side of the foliage is pitch black. Is the fix planned in the final release? =)

                  Good luck! And thanks for the work!

                  Comment


                    I'm getting weird issues with the preview builds - I'm not sure if its because I'm just deving in preview (which i know I shouldnt be but meh, I'm learning stuff)

                    LogLinker:Warning: Asset '[asset name here]' has been saved with empty engine version. The asset will be loaded but may be incompatible.
                    can I set the version somewhere?

                    MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: Assertion failed: BlueprintObj->GeneratedClass [File:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Editor\UnrealEd\Private\Kismet2\Kismet2.cpp] [Line: 861]
                    MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: Invalid generated class for myumgwidget
                    this is a weird one - at first I couldnt open my editor because of this, i rename the asset (or move it out) the project loads - i put it back in, relink everything its fine - then i go to package and another one of my umg widgets causes trouble - but only when I package it - I can launch and it works fine. very odd
                    ZOMBIE TOWN AHHH (ANDROID/STEAM) | RIDE SHARE EMPIRE (ANDROID/GAME JAM) | NEVER NOT KNIGHT (ANDROID/GAME JAM) | TWITTER | MY UE4 TUTORIALS | ANSWERHUB

                    Comment


                      Originally posted by btengelh View Post
                      I'm afraid to ask - but am I the only one who cannot add code to a 4.7 Pre8 project?
                      Neither "Add code to project" nor "Generate Visual Studio files" successfully works.
                      Create a blank project without starter content.
                      Add code to project just gives (empty class): Failed to add class MyClass. Failed to generate project files.
                      Generate project files in Explorer then gives:


                      Do I miss any prerequisites / dependencies?
                      Hey btengelh-

                      I created a new project as you suggested and was able to add code to a project without any issue. In the Launcher, verify your engine version by selecting the drop down arrow for preview 8. If you still have problems adding code to a project you may want to try uninstalling the preview version and then reinstalling it.

                      Cheers

                      Doug

                      Comment


                        Originally posted by DotCam View Post
                        Hey guys, thanks for the new update!

                        I tested out my project with preview 8 and am happy to report that the issue I was having with DynamicMaterialInstance's not being created through the Construction Script, which was preventing those materials from being applied, has been fixed in the new release.

                        However I am still receiving the "Externally Referenced" warnings I mentioned to Eric above. They are still being shown in the Map Check section of the Message Log, and I get a warning when I try to save the level about the externally referenced assets (which are not actually externally referenced).

                        I checked this with an already upgraded copy of the project, and also converted another new copy from 4.6.1 to make sure, and both of them show the warnings. It's not a big deal really but it could be confusing if left as is.

                        I just uploaded the newly converted copy of the project in case it will help you guys, you can download it here. Let me know if you need any further details, thank you!
                        Hey DotCam -

                        I am not finding any errors on loading your project in 4.7p8. I also spent a good amount of time trying to convert a project created in 4.6.1 to 4.7p8, both a C++ GitHub build/C++ project and a launcher variety with no success? Can you let me know if you are doing anything in C++ that would or does alter the components that are throwing the errors for you?

                        Let me know -

                        Eric Ketchum

                        Comment


                          Hi. I want to report a bug present both in preview 6,7 and 8. The editor freezes at 50% when trying to import extra large static meshes ( with poly count exceeding 250 thousands of polygons.

                          Comment


                            Hi,

                            i would really love to see UE-10013 considered too for the final 4.7 release (Blueprint components replication not working). Any chance for that?

                            Thanks,
                            Indy
                            FinalCamera on Marketplace / Web Demo
                            TopDown Toolkit on Marketplace / Web Demo

                            Comment


                              Originally posted by Eric Ketchum View Post
                              Hey DotCam -

                              I am not finding any errors on loading your project in 4.7p8. I also spent a good amount of time trying to convert a project created in 4.6.1 to 4.7p8, both a C++ GitHub build/C++ project and a launcher variety with no success? Can you let me know if you are doing anything in C++ that would or does alter the components that are throwing the errors for you?

                              Let me know -

                              Eric Ketchum
                              Hey Eric,

                              The code is fairly straightforward, it is just a BuoyancyMovementComponent that can be attached to actors (such as the Buoy's in scene) and an OceanManager class that is the base class for the BP_Ocean blueprint. All it does is perform the calculations required for buoyancy when requested by the BuoyancyMovementComponent.

                              Neither of those classes affect the appearance of the ocean, they only calculate the wave height for Buoyancy. The Skydome itself is 100% blueprint. Nothing there that should be causing the warnings in editor

                              I deleted some files from the upload in the Intermediate, Saved, and Build folders to reduce the download size, so to make sure I just tested a fresh copy from the upload just now. When first opening the project, there are no Map Errors/Warnings, however if I go to the build button's dropdown box and select "Map Check" all of the warnings re-appear, and if I attempt to save I receive a warning dialog related to the external references error.

                              Would you guys prefer I create an issue on AnswerHub for this? I don't mind posting it all here, either way is fine by me. Thanks for looking into it Eric!
                              Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

                              Comment


                                Originally posted by KitatusStudios View Post
                                I thought the day / night problem (Sun not moving no matter what approach you take!) was fixed for this preview :< I guess not :/
                                KitatusStudios,

                                The sun disc rotation has been resolved in 4.7 P8 from what I can see on my end with my test project.

                                You can test this with my sample project I use for ToD setups.

                                Let me know what you find.

                                Tim
                                Tim Hobson | Learning Resources | Epic Games
                                UE4 Documentation

                                Comment

                                Working...
                                X