Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Has anyone had any success launching to IOS or android? I keep getting errors and build failures?

    Leave a comment:


  • replied
    Question for Epic:

    Curious to know what the chances of UE-10283 being resolved in time for 4.7 are. The recent Twitch stream indicated that RC builds are on the horizon so that makes me a little anxious.

    The reason I'm following up proactively on this bug is because affected projects cannot run their game in standalone mode which makes it a complete blocker for anyone who needs to run standalone or distribute shipped builds for testing or recording (quicker w/o editor). This would be the second major release in a row where standalone builds don't fully work as 4.6 had the widely reported event dispatcher bug for standalone games, so (at the risk of being nagging and annoying ) I want to make sure this bug is highlighted for your consideration.


    Edit: Adding link to reported issue UE-10283: https://answers.unrealengine.com/que...le-issues.html
    Last edited by Tim Hobson; 02-21-2015, 12:20 PM. Reason: added link in the event anyone else wanted to see what UE-10283 was referencing.

    Leave a comment:


  • replied
    Originally posted by TommyBear View Post
    - Hot reload of C++ components causes crash in editor for me (Not good) (VS2014 - windows 8)
    Hey TommyBear-

    Are you still experiencing the same crashes with hot reload in preview 8? If so can you make a post on the AnswerHub (answer.unrealengine.com) with the types of components you're using and how you're setting them up?

    Thanks

    Doug Wilson

    Leave a comment:


  • replied
    Originally posted by polemos View Post
    There is a bug with material alignment if you create a brush and apply a material to the surface and align to fit and then create another brush the alignment of the first brush resets!!
    this is in all the 4.7 previews

    Leave a comment:


  • replied
    There is a bug with material alignment if you create a brush and apply a material to the surface and align to fit and then create another brush the alignment of the first brush resets!!

    Leave a comment:


  • replied
    I am getting hangups and crashes if I have an instanced blueprint selected in the view-port that has already been placed in the level and I hit PLAY IN VIEWPORT. I believe this is related to the ALT+Move that creates an instance of the object instead of a copy bug that has been confirmed in preview 7

    Leave a comment:


  • replied
    Originally posted by mossberg385t View Post
    Are there still plans for a final release of Gear VR plugin?
    I'm still getting no dynamic shadows only baked ones, a reflective ground rather than matte for the FPS template so skybox reflected (I did play around with settings and using a different skybox, so maybe that's why) and the UMG texture is still flipped vertically for me. Otherwise seems to work well though would be nice to get those bugs out of the way before the final release

    Leave a comment:


  • replied
    Hi,

    I don't know if this is a bug or intended but here an area of improvement/fix:

    Let's say you have a multi-level map. You modify a SubLevel BP. You hit save button.
    The current behavior: It will save the TopLevel map asset and not the one you modify.
    To save the Level that you changed in the LevelBP, you need to go in the Level Window or try to close the editor so you are asked to save it.

    you can highlight this behavior easily if you are linked to a SourceControl, as when you click on the save button you will see what fill need to be checked-out.

    Expected Behavior: When clicking on save button, only the Level that are dirty should be saved. Except if they are some information that need to be update in the "Main" level ?? If this is the case, all changed level & the main one should be saved/checkout.

    If you see that as a bug, I can fill a Bug Request in the HUB.

    Leave a comment:


  • replied
    I have encountered a big issue on structure file in 4.7 preview6,7,8 which cause my packaging for IOS and Android failing:

    MainFrameActions: Packaging (iOS): UE4Editor-Cmd: [2015.02.13-18.47.42:296][ 0]LogCookCommandlet:Warning: Package /Game/SpellSystem/System/SpellStruct supposed to be fully loaded but isn't. RF_WasLoaded is set MainFrameActions: Packaging (iOS): UE4Editor-Cmd: [2015.02.13-18.47.42:297][ 0]LogCookCommandletisplay: Cooking /Game/SpellSystem/System/SpellStruct -> E:/Unreal Projects/TopDownGame/Saved/Cooked/IOS/TopDownGame/Content/SpellSystem/System/SpellStruct.uasset MainFrameActions: Packaging (iOS): UE4Editor-Cmd: [2015.02.13-18.47.42:298][ 0]LogWindows:Error: Windows GetLastError: MainFrameActions: Packaging (iOS): UE4Editor-Cmd: begin: stack for UAT

    And this never happens in 4.6.1 and 4.7 preview1,2,3,4.I.And I have posted in answerhub:https://answers.unrealengine.com/que...iew56-bug.html.

    Leave a comment:


  • replied
    Are there still plans for a final release of Gear VR plugin?

    Leave a comment:


  • replied
    Nice; thank you for checking this out.
    A single line change and BOOM! weird things happens

    Leave a comment:


  • replied
    I think the physical material issue was fixed by https://github.com/EpicGames/UnrealE...73d5372148ec74

    Cheers,
    Michael Noland

    Leave a comment:


  • replied
    Originally posted by BrUnO XaVIeR View Post
    Release candidate?? But the bug with is still in there.

    ------


    This function is working on 4.7p8:
    EPhysicalSurface UGameplayStatics::GetSurfaceType(const struct FHitResult& Hit)

    But this one got broken; and both uses Hit.PhysMaterial.Get() so this is weird issue:
    void UGameplayStatics::BreakHitResult(const FHitResult& Hit, bool& bBlockingHit, float& Time, FVector& Location, FVector& Normal, FVector& ImpactPoint, FVector& ImpactNormal, UPhysicalMaterial*& PhysMat, AActor*& HitActor, UPrimitiveComponent*& HitComponent, FName& HitBoneName, int32& HitItem)
    They said it's fixed for the next release.

    Leave a comment:


  • replied
    Release candidate?? But the bug with
    CallFunc_BreakHitResult_PhysMat
    is still in there.

    ------


    This function is working on 4.7p8:
    EPhysicalSurface UGameplayStatics::GetSurfaceType(const struct FHitResult& Hit)

    But this one got broken; and both uses Hit.PhysMaterial.Get() so this is weird issue:
    void UGameplayStatics::BreakHitResult(const FHitResult& Hit, bool& bBlockingHit, float& Time, FVector& Location, FVector& Normal, FVector& ImpactPoint, FVector& ImpactNormal, UPhysicalMaterial*& PhysMat, AActor*& HitActor, UPrimitiveComponent*& HitComponent, FName& HitBoneName, int32& HitItem)
    Last edited by BrUnO XaVIeR; 02-19-2015, 09:07 PM.

    Leave a comment:


  • replied
    from the stream today - 4.7 is in the release candidate stage - around GDC (so ~2 weeks) it sounds like

    Leave a comment:

Working...
X