Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    4.7.7

    Place blueprint actor in level.
    Copy or duplicate creates an instance not a copy.
    This is problematic for blueprints with construction scripts for random material change.
    Dragging from content browser to viewport places a new blueprint actor that is not an instance and works correctly.
    This makes level building very slow.
    ALT+Drag creates an instance as well.
    Spline-Enabled Fence Pack - "Great pack, huge time-saver, top quality and enough variety to really make the assets unique." -Dark Acre Jack
    Destructible Road Signs - "Seriously awesome. Single blueprint for pretty much all the road signs you'll ever need." -thankstipscom
    Zipline/Teleporter/JumpPad - "This is a very flexible system for any project, and really simple to implement." -lunyBunny
    Wooden Storage Pack - "Very good high quality assets and well worth it." -Deathweave
    Digital Portfolio

    Comment


      Originally posted by JJ Hoesing View Post
      Hmm, that usually means the app has crashed. I'll take a look and see if I get the same behavior. Are you still on KitKat, or have you upgraded to Lollipop?
      Here is a log for my crash in case it helps. The same process I got to build this level I repeated every time I compiled the engine, it worked at one point then this morning it just stopped. Should I open a bug report for this? Any luck reproducing?

      Comment


        https://answers.unrealengine.com/que...or-picker.html

        Discovered bug. Kind of annoying, though not critical (;.
        https://github.com/iniside/ActionRPGGame - Action RPG Starter kit. Work in Progress. You can use it in whatever way you wish.

        Comment


          UE-3480 Launching a project with a custom Game Instance assigned will receive an error and crash the launching window
          This bug has been filed under "fixed internally" for a while now; is there any chance of the fix making it into a preview build, or are you waiting for 4.7 proper to include it?
          Twitter: @zerofiftyone_
          Website: zerofiftyone.net - My game development blog
          Button Frenzy store page: http://store.steampowered.com/app/454630

          Comment


            Originally posted by zerofiftyone View Post
            This bug has been filed under "fixed internally" for a while now; is there any chance of the fix making it into a preview build, or are you waiting for 4.7 proper to include it?
            I just took a look at that bug and the changelist that it was fixed in would have been part of preview 5.

            Comment


              Originally posted by Marc Audy View Post
              I just took a look at that bug and the changelist that it was fixed in would have been part of preview 5.
              Oh interesting. I thought I experienced that bug in preview 6; I guess I should do some further investigation into what I saw.
              Twitter: @zerofiftyone_
              Website: zerofiftyone.net - My game development blog
              Button Frenzy store page: http://store.steampowered.com/app/454630

              Comment


                I must admit that I am impressed by the new Two Sided Foliage Shading Model in the 4.7 preview 7
                and believe me I'm not easily impressed by this type of eye candy (long time cryengine user here)
                I'm impressed specially because i'ts Unreal Engine we are talking about here, the engine that makes vegetation looks like plastic plants
                of course it needs more improvement (self shadowing, color bleeding, touch bending, leaves animation affected by wind)
                I really hope that Unreal Engine will improve their shaders and become more elegant and beautiful.

                Regards

                Comment


                  Originally posted by Osok View Post
                  4.7.7

                  Place blueprint actor in level.
                  Copy or duplicate creates an instance not a copy.
                  This is problematic for blueprints with construction scripts for random material change.
                  Dragging from content browser to viewport places a new blueprint actor that is not an instance and works correctly.
                  This makes level building very slow.
                  ALT+Drag creates an instance as well.
                  Hey Osok -

                  Thank you for your report. We found and identified the issue and it will be fixed for the next preview release and for the 4.7 official release.

                  Comment


                    Originally posted by Marc Audy View Post
                    I just took a look at that bug (UE-3480) and the changelist that it was fixed in would have been part of preview 5.
                    This bug was fixed, but we hadn't flagged it to merge it into the 4.7 branch. I just set this right before Marc Audy took a look. We should get it into 4.7 soon.

                    Cheers
                    Stephen Ellis | Enterprise Program Coordinator

                    Comment


                      Thanks for the response, both!
                      Twitter: @zerofiftyone_
                      Website: zerofiftyone.net - My game development blog
                      Button Frenzy store page: http://store.steampowered.com/app/454630

                      Comment


                        Originally posted by Voren View Post
                        Looks like emissive does not work in splitscreen. Just have an emissive to a material in the scene then add another player via the "create player" node and the emissive goes away completely.

                        Tested this with a clean 3rd person project and set one of the objects to have an emissive value of 100.

                        Also when you add a third player everything goes black but when you add a 4th player it starts working again. Resizing the window randomly makes it work again.
                        Hey Voren-

                        The splitscreen emissive issue is already known and currently under investigation (UE-7627). I have also reported the black screen with three person splitscreen (UE-9825) for further investigation as well.

                        Comment


                          little strange one here just tried to update 4.7-p6 to p7 and got "Not enough disk space" i know 13 gb isn't much now a days but come on surely the engine doesn't need to that sort of size, maybe it might be an idea to go back and stream line what is actually needed.

                          ok did a quick size check !!!!
                          4.6.1 = 9.5 gb
                          4.7 p6 = 20 gb

                          i guess hope somethings not right here, i'm not worried about volume but it does seem a bit Over The Top !!!
                          Last edited by Geodav; 02-13-2015, 12:50 PM. Reason: size check
                          UT40K:The Chosen - Warhammer 40,000 for UE4
                          ut40kgeodav - UE4 Tutorials

                          Comment


                            Thank you Epic!

                            Guys 4.7 is looking really cool. Thank you Epic!!

                            And, seriously, thanks for this:


                            Comment


                              Originally posted by Geodav View Post
                              little strange one here just tried to update 4.7-p6 to p7 and got "Not enough disk space" i know 13 gb isn't much now a days but come on surely the engine doesn't need to that sort of size, maybe it might be an idea to go back and stream line what is actually needed.

                              ok did a quick size check !!!!
                              4.6.1 = 9.5 gb
                              4.7 p6 = 20 gb

                              i guess hope somethings not right here, i'm not worried about volume but it does seem a bit Over The Top !!!

                              I think Epic distributes full debug symbols with 4.7, those files are giants (with large spaces of void in them). But they are really good candidates for NTFS compression or deduplication, so if you enable either of these on the location you install the engine to you will save several gigabytes.

                              Comment


                                I've encountered something weird using 4.7 - Packaging a project under Development and running (All done via the Launcher, not source!) is throwing me this error (Taken from Log):

                                Code:
                                Log file open, 02/13/15 18:41:19
                                LogInit: Version: 4.7.0-2440994+++depot+UE4-Releases+4.7
                                LogInit: API Version: 2440994
                                LogInit: Compiled (64-bit): Feb 11 2015 00:17:41
                                LogInit: Compiled with Visual C++: 18.00.21005.01
                                LogInit: Build Configuration: Development
                                LogInit: Branch Name: ++depot+UE4-Releases+4.7
                                LogInit: Command line: 
                                LogInit: Base directory: C:/Users/Ryuuzaki/Documents/Distro/TEST/TEST3/WindowsNoEditor/SuperDistro/Binaries/Win64/
                                LogInit: Rocket: 1
                                [2015.02.13-18.41.19:747][  0]LogTaskGraph: Started task graph with 3 named threads and 6 total threads.
                                [2015.02.13-18.41.19:791][  0]LogOnline:Warning: No default platform service specified for OnlineSubsystem
                                [2015.02.13-18.41.19:791][  0]LogInit: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
                                [2015.02.13-18.41.19:795][  0]LogInit: Object subsystem initialized
                                [2015.02.13-18.41.19:796][  0]LogConsoleResponse:Warning: Skipping Unknown console variable: 'TranslucentSortAxis = (X=0.000000,Y=-1.000000,Z=0.000000)'
                                [2015.02.13-18.41.19:796][  0]LogConsoleResponse:Warning:   Found in ini file '../../../SuperDistro/Saved/Config/WindowsNoEditor/Engine.ini', in section '[/Script/Engine.RendererSettings]'
                                [2015.02.13-18.41.19:796][  0]LogConsoleResponse:Warning: Skipping Unknown console variable: 'UIScaleRule = ShortestSide'
                                [2015.02.13-18.41.19:796][  0]LogConsoleResponse:Warning:   Found in ini file '../../../SuperDistro/Saved/Config/WindowsNoEditor/Engine.ini', in section '[/Script/Engine.RendererSettings]'
                                [2015.02.13-18.41.19:796][  0]LogConsoleResponse:Warning: Skipping Unknown console variable: 'UIScaleCurve = (EditorCurveData=(Keys=),ExternalCurve=None)'
                                [2015.02.13-18.41.19:796][  0]LogConsoleResponse:Warning:   Found in ini file '../../../SuperDistro/Saved/Config/WindowsNoEditor/Engine.ini', in section '[/Script/Engine.RendererSettings]'
                                [2015.02.13-18.41.19:798][  0]LogInit: Selected Device Profile: [WindowsNoEditor]
                                [2015.02.13-18.41.19:798][  0]LogInit: Applying CVar settings loaded from the selected device profile: [WindowsNoEditor]
                                [2015.02.13-18.41.19:801][  0]LogInit: Computer: WIN-5QG95MOVID6
                                [2015.02.13-18.41.19:801][  0]LogInit: User: Ryuuzaki
                                [2015.02.13-18.41.19:801][  0]LogInit: CPU Page size=4096, Cores=4
                                [2015.02.13-18.41.19:801][  0]LogInit: High frequency timer resolution =3.417961 MHz
                                [2015.02.13-18.41.19:801][  0]LogMemory: Memory total: Physical=7.9GB (8GB approx) Virtual=131072.0GB
                                [2015.02.13-18.41.19:801][  0]LogMemory: Platform Memory Stats for WindowsNoEditor
                                [2015.02.13-18.41.19:801][  0]LogMemory: Process Physical Memory: 31.35 MB used, 31.35 MB peak
                                [2015.02.13-18.41.19:801][  0]LogMemory: Process Virtual Memory: 20.36 MB used, 20.42 MB peak
                                [2015.02.13-18.41.19:801][  0]LogMemory: Physical Memory: 2115.15 MB used, 8050.69 MB total
                                [2015.02.13-18.41.19:801][  0]LogMemory: Virtual Memory: 215.66 MB used, 134217728.00 MB total
                                [2015.02.13-18.41.19:822][  0]LogD3D11RHI: Found D3D11 adapter 0: NVIDIA GeForce GTX 760 (Feature Level 11_0)
                                [2015.02.13-18.41.19:822][  0]LogD3D11RHI: Adapter has 1985MB of dedicated video memory, 0MB of dedicated system memory, and 2048MB of shared system memory, 1 output[s]
                                [2015.02.13-18.41.19:825][  0]LogD3D11RHI: Found D3D11 adapter 1: Intel(R) HD Graphics 4600 (Feature Level 11_0)
                                [2015.02.13-18.41.19:825][  0]LogD3D11RHI: Adapter has 32MB of dedicated video memory, 0MB of dedicated system memory, and 1760MB of shared system memory, 0 output[s]
                                [2015.02.13-18.41.19:826][  0]LogD3D11RHI: Found D3D11 adapter 2: Microsoft Basic Render Driver (Feature Level 11_0)
                                [2015.02.13-18.41.19:826][  0]LogD3D11RHI: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 4025MB of shared system memory, 0 output[s]
                                [2015.02.13-18.41.19:826][  0]LogD3D11RHI: Chosen D3D11 Adapter Id = 0
                                [2015.02.13-18.41.19:829][  0]LogRHI: Texture pool is 1361 MB (70% of 1945 MB)
                                [2015.02.13-18.41.19:835][  0]LogD3D11RHI: Async texture creation enabled
                                [2015.02.13-18.41.20:147][  0]LogTextLocalizationManager: The requested culture ('en_GB') has no localization data; parent culture's ('en') localization data will be used.
                                [2015.02.13-18.41.20:165][  0]LogContentStreaming: Texture pool size is 1000.000000MB
                                [2015.02.13-18.41.20:381][  0]LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
                                [2015.02.13-18.41.20:500][  0]LogObj: 20174 objects as part of root set at end of initial load.
                                [2015.02.13-18.41.20:500][  0]LogUObjectAllocator: 3944536 out of 0 bytes used by permanent object pool.
                                [2015.02.13-18.41.20:511][  0]LogEngine: Initializing Engine...
                                [2015.02.13-18.41.22:547][  0]LogInit: XAudio2 using 'HDTV-4 (NVIDIA High Definition Audio)' : 2 channels at 48 kHz using 16 bits per sample (channel mask 0x3)
                                [2015.02.13-18.41.22:549][  0]LogInit: FAudioDevice initialized.
                                [2015.02.13-18.41.22:550][  0]LogInit: Texture streaming: Enabled
                                [2015.02.13-18.41.22:556][  0]LogLinker:Warning: Can't find file '/Game/Blueprints/GameModes/SuperDistroGameInstance'
                                [2015.02.13-18.41.22:556][  0]LogUObjectGlobals:Warning: Failed to load '/Game/Blueprints/GameModes/SuperDistroGameInstance': Can't find file '/Game/Blueprints/GameModes/SuperDistroGameInstance'
                                [2015.02.13-18.41.22:556][  0]LogLinker:Warning: Can't find file '/Game/Blueprints/GameModes/SuperDistroGameInstance'
                                [2015.02.13-18.41.22:556][  0]LogUObjectGlobals:Warning: Failed to load '/Game/Blueprints/GameModes/SuperDistroGameInstance': Can't find file '/Game/Blueprints/GameModes/SuperDistroGameInstance'
                                [2015.02.13-18.41.22:556][  0]LogUObjectGlobals:Warning: Failed to find object 'Class /Game/Blueprints/GameModes/SuperDistroGameInstance.SuperDistroGameInstance_C'
                                [2015.02.13-18.41.22:556][  0]LogWindows:Error: Windows GetLastError: The operation completed successfully. (0)
                                [2015.02.13-18.41.22:962][  0]LogWindows: Could not start CrashReportClient.exe
                                [2015.02.13-18.41.22:963][  0]LogMemory: Platform Memory Stats for WindowsNoEditor
                                [2015.02.13-18.41.22:963][  0]LogMemory: Process Physical Memory: 402.34 MB used, 405.73 MB peak
                                [2015.02.13-18.41.22:963][  0]LogMemory: Process Virtual Memory: 412.03 MB used, 415.53 MB peak
                                [2015.02.13-18.41.22:963][  0]LogMemory: Physical Memory: 2656.24 MB used, 8050.69 MB total
                                [2015.02.13-18.41.22:963][  0]LogMemory: Virtual Memory: 847.46 MB used, 134217728.00 MB total
                                [2015.02.13-18.41.29:205][  0]LogWindows: === Critical error: ===
                                Assertion failed: Class [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Runtime\CoreUObject\Public\UObject\Class.h] [Line: 2563] 
                                ConstructObject called with a NULL class object
                                
                                
                                KERNELBASE.dll!UnknownFunction (0x00007ffb31c24838) + 0 bytes [UnknownFile:0]
                                SuperDistro.exe!FOutputDeviceWindowsError::Serialize() (0x00007ff79b42b69c) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
                                SuperDistro.exe!FOutputDevice::Logf__VA() (0x00007ff79b28a848) + 159 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:144]
                                SuperDistro.exe!FDebug::AssertFailed() (0x00007ff79b267f09) + 113 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:224]
                                SuperDistro.exe!UGameEngine::Init() (0x00007ff79cc71305) + 61 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\gameengine.cpp:421]
                                SuperDistro.exe!FEngineLoop::Init() (0x00007ff79b12f299) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launchengineloop.cpp:1967]
                                SuperDistro.exe!GuardedMain() (0x00007ff79b12e3ba) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launch.cpp:138]
                                SuperDistro.exe!GuardedMainWrapper() (0x00007ff79b12e5ca) + 5 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
                                SuperDistro.exe!WinMain() (0x00007ff79b13ece9) + 17 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
                                SuperDistro.exe!__tmainCRTStartup() (0x00007ff79db7bc01) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
                                KERNEL32.DLL!UnknownFunction (0x00007ffb33c05f72) + 0 bytes [UnknownFile:0]
                                ntdll.dll!UnknownFunction (0x00007ffb347b9b54) + 0 bytes [UnknownFile:0]
                                ntdll.dll!UnknownFunction (0x00007ffb347b9b54) + 0 bytes [UnknownFile:0]
                                
                                
                                [2015.02.13-18.41.29:318][  0]LogExit: Executing StaticShutdownAfterError
                                [2015.02.13-18.41.29:319][  0]LogWindows: FPlatformMisc::RequestExit(1)
                                [2015.02.13-18.41.29:319][  0]Log file closed, 02/13/15 18:41:29
                                Anyone know what's up with that? Note that this is the same project I've used throughout the preview period and this is the first time I've seen this error.
                                Last edited by KITATUS; 02-13-2015, 02:46 PM.
                                KITATUS
                                "Information shouldn't be behind a paywall, It should be free for all!"

                                Comment

                                Working...
                                X