Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by ryanjon2040 View Post
    I have this basic system in which when character shoots it checks for authority and if its client, it calls a Server RPC on weapon. This Server RPC will then call the original function that does all the firing logic. This system used to work in 4.5.1 but i think its broken in 4.7 Preview 3 and 4.8 (master branch). The thing is, Server Handle Firing event is never executed on Client. Its simply not working. I tried putting a print string for Server Handle Firing and it never appear.

    In the below screenshots (4.7 Preview 3) you can see whats happening. Am i doing something wrong?

    If this is a bug then i'll gladly post this on Answerhub but not sure if its a bug in 4.7.

    Hi ryanjon2040,

    If you could, please make a post on the answerhub with this so we can better assist you, it will be easier to keep track of what is going on with a specific page for this error. When you post it there, send me a pm so I'll know it is up.
    Last edited by Adam Davis; 01-19-2015, 05:46 PM.

    Leave a comment:


  • replied
    Originally posted by DasMatze View Post
    Since 4.7 I can't access my macros from my macro libraries anymore when working in widgets. Is this intended or a bug?
    Hi DasMatze,

    Can you access new macro libraries created in 4.7? What version of the editor did you update from?

    Leave a comment:


  • replied
    Originally posted by RickDangerous View Post
    Any news on this bug:
    UE-6988 Game does not gain focus when launching in fullscreen

    It was reported for preview 1 but is still not fixed in preview 3.
    VR games suffers a lot from this because the user is not aware that focus is on the main monitor and not in the game rendered to the HMD. This make it seem like the game is broken, if the user doesn't realize the problem and click on the HMD screen.
    I hope this will be fixed before the final 4.7 release.
    Hi RickDangerous,

    This issue is set to be looked at soon, however, we cannot guarantee that this will be resolved once 4.7 is released. I've added a link to this post to the report so I can update once a fix has been submitted.

    Thank you!

    Tim

    Leave a comment:


  • replied
    Originally posted by SVAD View Post
    Would love it if you could sneak this one into 4.7...

    Still an issue adjusting physics at runtime via blueprints. Seems like the 'set' commands just aren't showing up, but the 'get' commands are working fine.

    (UE-5650)
    https://answers.unrealengine.com/que...ough-blue.html
    Hi SVAD,

    I know you responded on the AnswerHub post, but following up here as well.

    UE-5650 is done by design according to the ticket that was submitted. I've reached out to the engineer to see if there are other ways of manipulating the physical material while in-game since the "set" nodes are not available.

    I'll update the AnswerHub post and this post once I've heard back from the dev.

    Leave a comment:


  • replied
    Originally posted by luis.hernandez View Post
    I was about to install 4.7 preview in the PC to continue working but theb I noticed that there is no way to download it since it seems to have dissapeared from the launcher options.

    The 4.6 editor crashes when trying to open the 4.7 project, so now I can't work on it. Is there still any way to download and install the 4.7 version?
    Hi Luis,

    In the launcher under the Library tab you should see the option at the top for "Engines." There is a "+" sign with add engine next to that. If you click this should place a grayed out engine button below this. If the engine version is not listed that you would like click the white down arrow and select the engine version you would like. Then you can click "Install" to start the download process.

    Give that a shot and let me know if that doesn't resolve your issue.

    Thank you!

    Tim

    Leave a comment:


  • replied
    Any news on this bug:
    UE-6988 Game does not gain focus when launching in fullscreen

    It was reported for preview 1 but is still not fixed in preview 3.
    VR games suffers a lot from this because the user is not aware that focus is on the main monitor and not in the game rendered to the HMD. This make it seem like the game is broken, if the user doesn't realize the problem and click on the HMD screen.
    I hope this will be fixed before the final 4.7 release.

    Leave a comment:


  • replied
    Originally posted by BrUnO XaVIeR View Post
    @Obihb I'm pretty sure you are using nodes that are Editor only; like getting actors by name and things like that.
    Nodes should note when they are Editor-only, on its description.
    It's actually a very simple setup, assign static mesh and some float values.

    Can you give a direct example of this?. I don't see the point of "editor only" nodes and I've never heard of anything like that. Even if that were the case, in older versions of the engine, it all works, it just doesn't work now. So these "editor only" nodes, did they work in older versions in a packaged game?. Sorry, I just don't know what you're talking about, if you can actually show a screen shot or give actual names of such nodes, that would help.

    Leave a comment:


  • replied
    @Obihb I'm pretty sure you are using nodes that are Editor only; like getting actors by name and things like that.
    Nodes should note when they are Editor-only, on its description.

    Leave a comment:


  • replied
    Hi, I am pretty new to UE4 and am having a strange crash/lock up.

    I created a 4.7 (preview3) project using the 3rd person template, placed a cube in the map, and have got a video running on the cube. I can play the project in the editor as much as I like and it all works fine, but if I package the project (windows64bit), then wait for the build to finish, and then try to play in the editor, the editor locks up..

    Anyone had this problem before?

    John


    EDIT: Forgot to add.. The video plays fine in the editor with sound, but only plays the video without sound in the packaged project,
    Last edited by polomint; 01-16-2015, 02:54 PM.

    Leave a comment:


  • replied
    @luis.hernandez: Sounds like you might need to click the add engine option in the launcher if you've never had a version of 4.7 on that machine?

    Leave a comment:


  • replied
    Hi.

    I've been trying 4.7.1 version on a project in my laptop for a couple of weeks and now I planned to continue working on the same project in my desktop computer, where I have 4.6 version installed. After copying the project files, I was about to install 4.7 preview in the PC to continue working but theb I noticed that there is no way to download it since it seems to have dissapeared from the launcher options.

    The 4.6 editor crashes when trying to open the 4.7 project, so now I can't work on it. Is there still any way to download and install the 4.7 version?

    Any help will be appreciated. I would not like to be forced to work in this project on a small laptop forever!

    Leave a comment:


  • replied
    Would love it if you could sneak this one into 4.7...

    Still an issue adjusting physics at runtime via blueprints. Seems like the 'set' commands just aren't showing up, but the 'get' commands are working fine.

    (UE-5650)
    https://answers.unrealengine.com/que...ough-blue.html

    Leave a comment:


  • replied
    I've been focusing more on various PBR research and various tools to try and accelerate some of the PBR based workflow, and with bandwidth constraints and changes in bandwidth monitoring I've had to step back using GitHUB so much as things constantly change as it's produced some other complications.

    This preview release method provides a more relaxed way that feels more natural to regular releases via the launcher, and Unreal Engine 4.7 seems alot more responsive and smooth as compared to the 4.5 and 4.6 series of releases, and no doubt these preview releases using the launcher are providing much alternative feedback from those more actively focusing on their games and learning the Unreal Engine features.

    So I'm happy with the direction things are going as I can still manage to develop game and test third party tools, while participating a bit in the engine portion as reasonable time and bandwidth permits.

    Unreal Engine 4.7 seems like the best release yet so far.

    Leave a comment:


  • replied
    I have this basic system in which when character shoots it checks for authority and if its client, it calls a Server RPC on weapon. This Server RPC will then call the original function that does all the firing logic. This system used to work in 4.5.1 but i think its broken in 4.7 Preview 3 and 4.8 (master branch). The thing is, Server Handle Firing event is never executed on Client. Its simply not working. I tried putting a print string for Server Handle Firing and it never appear.

    In the below screenshots (4.7 Preview 3) you can see whats happening. Am i doing something wrong?

    If this is a bug then i'll gladly post this on Answerhub but not sure if its a bug in 4.7.

    In Character Blueprint:


    Weapon Master Blueprint:

    Leave a comment:


  • replied
    Yes, Mantle and DX12 support needs are special video podcast. This is big and importand theme! I believe what Epic games supports Mantle in future UE4 releases (sorry for English)!

    Leave a comment:

Working...
X