Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    How do I set the editor back to the old behavior of creating new windows whenever I go to edit an asset?

    I keep going up to the right to close Cascade when I'm done editing a particle system, and closing the entire project because now Cascade opens as a tab on the editor screen rather than in a new window the way BPs do.

    Comment


      Originally posted by RhythmScript View Post
      How do I set the editor back to the old behavior of creating new windows whenever I go to edit an asset?

      I keep going up to the right to close Cascade when I'm done editing a particle system, and closing the entire project because now Cascade opens as a tab on the editor screen rather than in a new window the way BPs do.
      You can drag the tab and tear it off the main window to create a new, separate, window.

      Comment


        VR broken
        New project, 3rd Person Template, low res, no starter content, VR preview, Health warning, black/dark screen with one eye worse. wait 30 second crash.
        I'm on:
        Intel Core i7-4820K @ 3.70 GHz, AMD Radeon R9 200 Series, Windows 8.1, DK2 with firmware 2.12
        edit: and 0.4.4 oculus runtime
        Last edited by jjkramhoeft; 02-11-2015, 02:09 AM.

        Comment


          For those of you with broken VR, have you upgraded your Oculus runtimes to 0.4.4? 4.7 is built against the updated runtimes, and they're essential for it to run properly.

          Comment


            Originally posted by Nick Whiting View Post
            For those of you with broken VR, have you upgraded your Oculus runtimes to 0.4.4? 4.7 is built against the updated runtimes, and they're essential for it to run properly.
            Yup, I've been on 0.4.4 for quite some time. This breakage is also on GearVR which is where I first noticed (no 0.4.4 runtime for that) it then I figured I would try it on my DK2 and realized it was the same issue. I'm using a fresh clean build of the 4.7 branch, run Setup.bat, then GenerateProjectFIles and do a full build of Development_Editor and Development x64. Runtime is definitely 0.4.4, is there anything extra we need to download and place in the source directory to build right?

            Comment


              Originally posted by Kenomica View Post
              You can drag the tab and tear it off the main window to create a new, separate, window.
              Can it be set to do that by default? If I could remember to do that, I could just remember to close tabs instead of windows...

              Comment


                is there anything extra we need to download and place in the source directory to build right?
                Nope, that should be it. It appears there was a rendering regression in 4.7 recently. We'll look into it. Thanks!

                Comment


                  I have a very weird bug for 4.7 Preview 6. If I launch the editor and press play, the viewport becomes black. I can see my UMG UI but that's it. I can stop and play again as many times as I want and it's the same. But if I select my camera in the outliner and press play, then the 3d appears. And then it woks as usual (I can stop/play even without selecting the camera).
                  FtheBlocks - a UE 4 Bomberman - Alpha 0.2

                  Comment


                    Originally posted by RhythmScript View Post
                    Can it be set to do that by default? If I could remember to do that, I could just remember to close tabs instead of windows...
                    Not that I am aware, but I honestly haven't had much time with 4.7 - I also keep closing the entire engine by mistake.

                    Comment


                      Was the audio fixed in preview 6?

                      Comment


                        @RoyAwesome the audio is working now for me.

                        Split-screen is borked though. Tried a fresh 3rd person project added a second player with the "create player" blueprint node in the level blueprint. Only the last player added shows somewhat correctly. The other players it looks like object culling is reversed or something because everything disappears when you turn to look at it.

                        Comment


                          Originally posted by Nick Whiting View Post
                          For those of you with broken VR, have you upgraded your Oculus runtimes to 0.4.4? 4.7 is built against the updated runtimes, and they're essential for it to run properly.
                          Running 0.4.4 oculus runtime. I suspect most people are? Running on AMD R9 290. Not sure that helps, seems most others are having similar problems. <3
                          vr and new media installations
                          www.samuelwalker.xyz

                          Comment


                            I'm having both the VR issue and a shadow issue (possibly similar to Majority), which happens without VR active. It looks like the shadow buffer isn't getting cleared or updated correctly or something and old shadows are getting pasted over my scene in places where they shouldn't be.

                            DK2, 0.4.4 Runtime, GTX 780.

                            Comment


                              I just got 4.7 preview 6 and it seems like something is wrong with the paper2D camera (I haven't tried anything with 3D). It seems like it only shows the upper-left quadrant and I tried this with my game and the example Paper2D side scrolling template. This is how it looks like when I tried it with a new 2D template...


                              Comment


                                @Epic/Scrylla
                                I had this issue from the 4.7 github branch too. There appears to be a bug with the 'Resolution Scale' setting (Settings button > Scalability > Engine Scalability Settings).
                                Restoring it to 100% should fix the issue; I'm not sure why it would change, perhaps auto performance monitoring?

                                This manifests itself in two ways:
                                1. In Play mode, the viewport is truncated as in Scrylla's image.
                                2. In Simulate mode, the resolution appears to be reduced as intended, however selection and manipulation of the 3D widget is distorted/impossible.

                                Comment

                                Working...
                                X