Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Mike Fricker View Post
    Cool feature now in 4.7 that we forgot to mention earlier:

    The version of the engine from the Launcher now includes full engine source code and engine debugging symbols for Windows. You should be able to seamlessly step into engine code while debugging, and you will have complete call stacks after a crash. You no longer need to compile the engine yourself to get full engine debugging powers.

    This change did make the download and on-disk footprint larger, but we believe it is a super useful change and worth it. Later on we'll figure out how to make it an optional download, perhaps. Also note that while the full engine source is included, if you want to recompile the editor yourself you'll still need to pull down the code from GitHub so that you have all of the required dependency libraries.

    --Mike
    Holy bucket balls!!!!!! ^ Wow!

    Leave a comment:


  • replied
    Originally posted by Mike Fricker View Post
    This is fixed for the next preview release.



    This is in progress and *might* make it into the next Preview release. We'll see.



    We've talked about this. We won't do this for 4.7 but we'll keep thinking about it. The actor instance can't currently have any variables or visual scripting attached to it, so it would be a one-way trip in many cases.

    Thank you SO much for the feedback and testing the preview release. It's a big help.

    --Mike
    See... and this is why I love you guys so much... Thank you Mike and thank you to the wider Epic team. You guys have spurred a new era is engine developement

    Leave a comment:


  • replied
    Originally posted by Adam Davis View Post
    Hey TheJamsh,

    We are still looking into the root cause of this error. We'll let you know once more information is available on the subject!
    Cracking! Thanks Adam

    Leave a comment:


  • replied
    Originally posted by VSZ View Post
    Issue 3: Loading my game's map crashes while loading "cached shader maps"/materials/etc. There is no error message at all and the logs end abruptly. The starter maps load fine.
    Workaround: In my 4.6 map I changed my map to be fully dynamic and ticked force no precomputed lighting and then migrated this map to 4.7 Preview 5. The map loads fine now although I haven't tried turning lightmass back on and building lights.
    Hey VSZ -

    If you still (hopefully) have the original 4.6 project you can remove the Intermediate and Saved Folders (just delete them) and then convert your project to 4.7p5. This solution should fix the map crash, but you will have to recompile the shaders when you first open the project again. Feel free though to post this on Answerhub and reference my name and I can keep looking into this for you.

    Thank You -

    Leave a comment:


  • replied
    Originally posted by BPANDREW View Post
    Hello I'm unable to start my project at all in preview 5 it was working fine in preview 4


    a fix to this was just checked into source - man I love this github situation

    Leave a comment:


  • replied
    Originally posted by KitatusStudios View Post
    I've got a wonderful bug in 4.7 for you;
    Matinee. Creating an event in the track, saving, then heading into the Level Blueprint and adding a controller:
    The event isn't there.

    Even if you save / compile everything and restart the editor it's not there.

    To get it there, you have to do the ol' "Refresh node" method; Even when the node was created after the event / after everything has been compiled and saved.

    Have replicated this in multiple versions of Preview 5 (Source, Downloaded and various projects).

    Obviously it's not high priority but it's a bug none-the-less! :P
    Thank you for that report. Looks like we did find this bug in testing, it is not fixed yet, but it is being looked into soon.

    Leave a comment:


  • replied
    Originally posted by Mike Fricker View Post
    The version of the engine from the Launcher now includes full engine source code and engine debugging symbols
    Great. I've been fighting with github the last couple of days as I think being able to step through the engine code is really helpful for learning, even though I have no intention of modifying engine code at this point. Having this integrated into launcher versions will make things a lot simpler, thanks.

    Leave a comment:


  • replied
    Cool feature now in 4.7 that we forgot to mention earlier:

    The version of the engine from the Launcher now includes full engine source code and engine debugging symbols for Windows. You should be able to seamlessly step into engine code while debugging, and you will have complete call stacks after a crash. You no longer need to compile the engine yourself to get full engine debugging powers.

    This change did make the download and on-disk footprint larger, but we believe it is a super useful change and worth it. Later on we'll figure out how to make it an optional download, perhaps. Also note that while the full engine source is included, if you want to recompile the editor yourself you'll still need to pull down the code from GitHub so that you have all of the required dependency libraries.

    --Mike
    Last edited by Dark-Veil; 02-04-2015, 06:41 PM.

    Leave a comment:


  • replied
    Anyone else crashing during the 'Encoding Textures' phase of building lighting?

    Logs don't look too helpful, using the Visual Studio Just-In-Time debugger I was able to glean the following:

    'Unhandled exception at 0x0000000077554102 (ntdll.dll) in UE4Editor.exe: 0xC0000374: A heap has been corrupted (parameters: 0x00000000775CB4B0).'

    Leave a comment:


  • replied
    Originally posted by MieszkoZ View Post
    That was the only way to go to make BP-implemented BT decorators work as expected - not sure if you noticed, but it was very broken :P
    The fact that you have only one "return" node in BP functions is, like John Alcatraz said, a generic BP thing.
    I use many decorators and they work like I expect them to work... I have not noticed anything broken in 4.6.1?

    And again, when will it be possible to have multiple return nodes in BP functions? 4.8?

    Leave a comment:


  • replied
    Originally posted by Mike Fricker View Post
    You can change this using the "View" button at the bottom of your Content Browser, or simply hold down Ctrl while scrolling the mouse wheel over the thumbnails. We made the default size a bit bigger because Content Browser gets more screen real-estate in the default layout.
    Yes. I did that . It's set to lowest value, and they are still really big.

    I want them at roughly half of the current size. Because right now they are to big for my compact browser.

    Oh wait. Nevermind this. I just, well extended window a bit, and icons got smaller.

    Though, making them bit smaller would help still, so I could keep content browser smaller as well.

    And if we are on it. Column view, could really use, some ability to actually disable not needed columns (;.
    Last edited by iniside; 02-04-2015, 02:11 PM.

    Leave a comment:


  • replied
    Originally posted by iniside View Post
    I have very small request. Idk, if that is in preview but from the github source yesterday, the icons in content browser are really big.

    Gimme back my small tile icons please!
    Are you not able to change them anymore? Hold down Ctrl with your mouse cursor in the content browser and scroll with the MouseWheel, you should be able to change the size that way.

    EDIT: Lol.. You are too fast Mike!

    Leave a comment:


  • replied
    Originally posted by iniside View Post
    the icons in content browser are really big. Gimme back my small tile icons please!
    You can change this using the "View" button at the bottom of your Content Browser, or simply hold down Ctrl while scrolling the mouse wheel over the thumbnails. We made the default size a bit bigger because Content Browser gets more screen real-estate in the default layout.

    Leave a comment:


  • replied
    I have very small request. Idk, if that is in preview but from the github source yesterday, the icons in content browser are really big.

    Gimme back my small tile icons please!

    Leave a comment:


  • replied
    Originally posted by VSZ View Post
    Tried converting my project and found some issues. Note that 'Preview 5' is the first 4.7 build I've tested.
    ...
    PS: I do intend to post these in Answerhub but like most issues these are only reproducible in my project, the standard maps and Epic samples work fine. I wanted to post a brain dump of these issues here first as I'm swamped with project work right now and it takes a while to diligently gather all the information needed for raising proper bug reports for these.
    Thanks for planning to post these on the AnswerHub to the Bug Reports section, it will be better for us to investigate them individually than on here. Be sure to let us know if you are converting from 4.6.1.

    Leave a comment:

Working...
X