Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by hesham View Post
    Turns out for some reason my Oculus runtime broke. I hadn't restarted the machine so it must have been a graphics or some other update that I ran that broke it. All good now from both Preview 5 and GitHub. Thanks!
    Cheers bud, Not at any point has Epic made clear the code on github for 4.7 preview doesn't compile and that only their launcher version works. Epic fail for Devs who need to compile the code to add new code to the up coming release. # Epic mistake. Thanks for wasting 2 days of my time Epic, Appreciated

    Leave a comment:


  • replied
    Tried that a few times, no dice

    Leave a comment:


  • replied
    Originally posted by Alexander Paschall View Post
    Are you downloading 4.7 off of GitHub? That is not the same as the 4.7 preview 5 that we just released. The version on GitHub includes more recent commits and can cause problems due to lack of internal testing. Preview 5 is available through the launcher and I would suggest trying VR with that to see if it works.
    Turns out for some reason my Oculus runtime broke. I hadn't restarted the machine so it must have been a graphics or some other update that I ran that broke it. All good now from both Preview 5 and GitHub. Thanks!

    Leave a comment:


  • replied
    Had a totally **** day, Tried to compile 4.7 6 times over the last few days. Can anyone confirm or not that 4.7 Preview 5 compiles in VS 2013 Express. All i keep getting is errors, errors, errors.

    Error 1 error C1083: Cannot open include file: 'UObject/LinkerPlaceholderExportObject.h': No such file or directory D:\UnrealEngine-4.7\Engine\Source\Runtime\CoreUObject\Private\Blueprint\BlueprintSupport.cpp 5 1 UE4
    Error 2 error C1083: Cannot open include file: 'LinkerPlaceholderExportObject.h': No such file or directory D:\UnrealEngine-4.7\Engine\Source\Runtime\CoreUObject\Private\UObject\PropertyBaseObject.cpp 6 1 UE4
    Error 3 error C1083: Cannot open include file: 'LinkerPlaceholderExportObject.h': No such file or directory D:\UnrealEngine-4.7\Engine\Source\Runtime\CoreUObject\Private\UObject\LinkerLoad.cpp 10 1 UE4
    Error 4 error : Failed to produce item: D:\UnrealEngine-4.7\Engine\Binaries\Win64\UnrealHeaderTool-CoreUObject.dll D:\UnrealEngine-4.7\Engine\Intermediate\ProjectFiles\ERROR UE4
    Error 5 error MSB3073: The command "..\..\Build\BatchFiles\Rebuild.bat UE4Editor Win64 Development" exited with code 2. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets 43 5 UE4

    Ready to punch some one random in the face

    And no way is it a problem on my end, I reinstalled windows today and VS 2013 from scratch. Still does the same Bloody thing.
    Last edited by KingBadger3D; 02-05-2015, 11:07 PM.

    Leave a comment:


  • replied
    Originally posted by JoeWintergreen View Post
    I dunno if this is addressed somewhere already or I'm just doing this wrong but I can't pull down Preview 5 from the launcher, when I select it I just get a subscribe button. Any other engine version works fine.
    Try logging out of the Launcher, close it, open it again and login and try again, I have to do that sometimes and it works.

    Leave a comment:


  • replied
    Hey Marc,

    Is there currently a way through blueprints to check to see if a upack in the content folder and if not, download it through the game?

    I want my game to carry a light footprint so I can distribute it through my site. Then have the game download "individual content" through user selection in-game, then download it from a high bandwidth file server (Amazon S3).

    Leave a comment:


  • replied
    I dunno if this is addressed somewhere already or I'm just doing this wrong but I can't pull down Preview 5 from the launcher, when I select it I just get a subscribe button. Any other engine version works fine.

    Leave a comment:


  • replied
    Originally posted by Dalon View Post
    https://answers.unrealengine.com/que...mg-cursor.html

    Is this a bug? If so, will it be fixed, soon? I would like to use a custom mouse cursor in my game and I really want to use UMG!
    We have a technician looking into that one right now. Rudy is going to see if that is intended, a workflow error or a bug and he'll get back to you with some info and maybe some questions.

    Leave a comment:


  • replied
    https://answers.unrealengine.com/que...mg-cursor.html

    Is this a bug? If so, will it be fixed, soon? I would like to use a custom mouse cursor in my game and I really want to use UMG!

    Leave a comment:


  • replied
    Originally posted by Alexander Paschall View Post
    I would suggest trying VR with that to see if it works.
    Thanks, will try tonight! I am using GitHub b/c I have some simple Engine changes that I need to make for my project to work so even if preview 5 works I'll need to wait till I can build it properly like I did with 4.6.

    Leave a comment:


  • replied
    Originally posted by hesham View Post
    Anyone having issues getting VR mode working building from source? I had been running 4.6.x straight from GitHub for a while now but building 4.7 doesn't seem to enable the Rift for me. Even if I turn on Simple HMD which gave me the option for VR Preview. I have the Oculus plugin checked but not the GearVR one but it just doesn't seem to detect the Rift.
    Are you downloading 4.7 off of GitHub? That is not the same as the 4.7 preview 5 that we just released. The version on GitHub includes more recent commits and can cause problems due to lack of internal testing. Preview 5 is available through the launcher and I would suggest trying VR with that to see if it works.

    Leave a comment:


  • replied
    Anyone having issues getting VR mode working building from source? I had been running 4.6.x straight from GitHub for a while now but building 4.7 doesn't seem to enable the Rift for me. Even if I turn on Simple HMD which gave me the option for VR Preview. I have the Oculus plugin checked but not the GearVR one but it just doesn't seem to detect the Rift.

    Leave a comment:


  • replied
    So I create an Actor BP and dragged it out into my scene. I then added a spline via the component menu. Awesome so far. Went to edit the spling and it is not editable in scene. I want to be able to edit the spline in scene too. For example, I want to literally BP out a city block and I want to be able to add spline components to it and edit them all in the level view port. When I like it all, I want to create a new BP from this. Then I might want to edit the spline again and apply it to the BP asset or create a new one. Will this be possible in future? Thanks!

    Tommy.

    Leave a comment:


  • replied
    Originally posted by FrankieV View Post
    No sound this time.

    Checked settings and volume is up full.

    I don't hear any sound when playing on an iOS device aswell. (preview 5)


    Also the iOS performance in 4.7 preview 5 seems to be way worse than with 4.6.1 . It went down from 60 fps to 30 fps on an iPhone 5 with ES2 rendering. Game Center does not login aswell. This is easily verifiable with Tappy Chicken.
    Last edited by HEGI; 02-05-2015, 08:41 AM.

    Leave a comment:


  • replied
    @RedEyes, I am not sure if this would work, but you might be able to escape the space with the escpae character \

    /path/path/A\ Folder/file

    /path/path/A folder/file

    Leave a comment:

Working...
X