Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by BPANDREW View Post
    on the topic of bugs and reporting a scenario I'd like to talk about is - when reporting bugs to answer hub - I'm frequency faced with requests to provide additional testing (make a new project and try and reproduce) or on a few occasions I've been asked to hand over my source code.

    if I don't comply to all requests (i do my best to provide logs and screenshots) - the bug is then closed off and marked complete and I'm unsure if that report has been entered into you system or taken seriously

    I'd like to request this procedure be looked at as I feel less inclined to report things there now
    Why? This is all used to make sure that the bug isn't just a one-off and can be replicated. It's to make sure that your installation of Unreal Engine 4 doesn't have a random bug or if it's just your project. They ask for the source code to make sure that you haven't edited anything that has broken the engine.

    It's not like they are going to take your source code and distribute it, They need it to find out what is causing the bug on your end and to confirm that it's happening your end and not for everyone. Saying that, I've never seen them ask for full source code on the Answerhub, But I don't understand why you wouldn't give it to them? You're asking for help and that's exactly what they're trying to do!
    KITATUS
    "Information shouldn't be behind a paywall, It should be free for all!"

    Comment


      when i try to play the vehicle template the engine crash

      error code :
      MachineId:E7623266412BA9E534D4E7AD11674048
      EpicAccountId:22db245d61324773bebdb5943f3c94ca

      Unknown exception - code 00000001 (first/second chance not available)

      Assertion failed: UpdatedComponent->GetBodyInstance()->GetPxRigidDynamic() [File:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Runtime\Engine\Private\Vehicles\WheeledVehicleMovementComponent.cpp] [Line: 175]

      KERNELBASE + 35740 bytes
      UE4Editor_Core!FOutputDeviceWindowsError::Serialize() + 292 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
      UE4Editor_Core!FOutputDevice::Logf__VA() + 248 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:144]
      UE4Editor_Core!FDebug::AssertFailed() + 1042 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:224]
      UE4Editor_Engine!UWheeledVehicleMovementComponent::CreateVehicle() + 188 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\vehicles\wheeledvehiclemovementcomponent.cpp:178]
      UE4Editor_Engine!UWheeledVehicleMovementComponent::CreatePhysicsState() + 115 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\vehicles\wheeledvehiclemovementcomponent.cpp:595]
      UE4Editor_Engine!UActorComponent::ExecuteRegisterEvents() + 357 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\actorcomponent.cpp:871]
      UE4Editor_Engine!UActorComponent::RegisterComponentWithWorld() + 891 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\actorcomponent.cpp:663]
      UE4Editor_Engine!AActor::IncrementalRegisterComponents() + 562 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\actor.cpp:3220]
      UE4Editor_Engine!ULevel::IncrementalUpdateComponents() + 239 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\level.cpp:725]
      UE4Editor_Engine!UWorld::UpdateWorldComponents() + 577 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\world.cpp:1221]
      UE4Editor_Engine!UWorld::InitializeActorsForPlay() + 704 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\world.cpp:2847]
      UE4Editor_Engine!UGameInstance::StartPIEGameInstance() + 1079 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\gameinstance.cpp:195]
      UE4Editor_UnrealEd!UEditorEngine::CreatePIEGameInstance() + 8462 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\playlevel.cpp:2779]
      UE4Editor_UnrealEd!UEditorEngine::PlayInEditor() + 7003 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\playlevel.cpp:2134]
      UE4Editor_UnrealEd!UEditorEngine::StartQueuedPlayMapRequest() + 643 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\playlevel.cpp:972]
      UE4Editor_UnrealEd!UEditorEngine::Tick() + 3409 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\editor.cpp:1200]
      UE4Editor_UnrealEd!UUnrealEdEngine::Tick() + 22 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\unrealedengine.cpp:298]
      UE4Editor!FEngineLoop::Tick() + 4084 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launchengineloop.cpp:2240]
      UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launch.cpp:131]
      UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
      UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
      UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

      Comment


        Tried converting my project and found some issues. Note that 'Preview 5' is the first 4.7 build I've tested.

        Issue 1: Play In Standalone is broken due to blueprint compilation issues that manifest in standalone but not in the Editor or PIE mode. It also crashes with an error Access violation - code c0000005 (first/second chance not available) @ unrealtype.h:996 and the standalone logs complain that the 'Target' attribute of certain blueprint nodes are not disconnected even though they are in fact connected.

        Log excerpts:
        Error The current value of the ' TargetArray ' pin is invalid: Array inputs (like 'TargetArray') must have an input wired into them (try connecting a MakeArray node).
        Error Variable node MyVariable uses an invalid target. It may depend on a node that is not connected to the execution chain, and got purged.
        Error This blueprint (self) is not a SomeGameBlueprint_C, therefore ' Target ' must have a connection.


        Workaround: None.


        Issue 2: Frequent editor crashes with an error Invalid object in GC: 0x0000000000000030, ReferencingObject: MyBehaviorTreeTaskBlueprint_C. The offending BT Task blueprint compiles just fine. The crashes occur i) after a PIE (Play in Editor) session ii) on hitting save iii) on play in standalone

        Workaround: None. Unless I delete all node instances of the offending task from behavior tree, the issue persists.


        Issue 3: Loading my game's map crashes while loading "cached shader maps"/materials/etc. There is no error message at all and the logs end abruptly. The starter maps load fine.
        Workaround: In my 4.6 map I changed my map to be fully dynamic and ticked force no precomputed lighting and then migrated this map to 4.7 Preview 5. The map loads fine now although I haven't tried turning lightmass back on and building lights.


        PS: I do intend to post these in Answerhub but like most issues these are only reproducible in my project, the standard maps and Epic samples work fine. I wanted to post a brain dump of these issues here first as I'm swamped with project work right now and it takes a while to diligently gather all the information needed for raising proper bug reports for these.
        Last edited by VSZ; 02-04-2015, 09:12 AM.

        Steam Early Access: Drunk On Nectar - The Nature Simulator

        UE4 Plugins: DoN’s Dynamic Mesh FX | DoN’s 3D Pathfinding

        Comment


          Just got Preview 5 and finding the new Blueprint UI a mixed bag. It's great to have the 'Defaults' tab moved to a pane, but now when I switch back and forth between 'Graphs' and the 'Viewport' I then have to spend time hiding 'Component' and 'Default' panes and bringing up 'Palette' and 'My Blueprint' panes & vice versa. This isn't efficient for time and the the only other solution would be to have all 4 panes visible, which isn't efficient for screen space.

          Comment


            Originally posted by TommyBear View Post
            You can't seem to add BP based components to actors using the drop down menu, you need to drag the BP into the tree from the content window, which works (not great)
            This is fixed for the next preview release.

            Originally posted by TommyBear View Post
            Click on an instance and then a child in the component window, you immediately see that children are locked. They can't be moved, scaled or even deleted. We really need this. I don't want to go into the BP editor to do this... I want to do this in scene (not good)
            This is in progress and *might* make it into the next Preview release. We'll see.

            Originally posted by TommyBear View Post
            I would almost suggest that it be possible to convert the BP instance back to standalone actor instance in the level too.
            We've talked about this. We won't do this for 4.7 but we'll keep thinking about it. The actor instance can't currently have any variables or visual scripting attached to it, so it would be a one-way trip in many cases.

            Thank you SO much for the feedback and testing the preview release. It's a big help.

            --Mike

            Comment


              Mike, super small request for 4.7. I think it's probably an oversight and would be very simple to fix.
              Could the panels in the profiler be made resizable? They are currently fixed resolution and on my laptop the bottom panel (function list) is unusable as a result.

              Comment


                Originally posted by Jimmy_Jazz View Post
                Just got Preview 5 and finding the new Blueprint UI a mixed bag. It's great to have the 'Defaults' tab moved to a pane, but now when I switch back and forth between 'Graphs' and the 'Viewport' I then have to spend time hiding 'Component' and 'Default' panes and bringing up 'Palette' and 'My Blueprint' panes & vice versa. This isn't efficient for time and the the only other solution would be to have all 4 panes visible, which isn't efficient for screen space.
                * The Default pane is being removed in the next release, the defaults are just a button in the toolbar now (Class Defaults), it selects the CDO in the standard details panel. There should be no reason left to use the "Defaults" panel - that was mostly a hold over from the previous version. Additionally, you can select the Actor (self) root of the component tree to see actor defaults (same using the toolbar), and of course selecting any component shows you their defaults.
                * Components can be used in the graph view also, you can drag components in, just like variables. It's not entirely useless even in graph mode now.
                * The palette is not the recommended workflow. It's not contextual and it is a slower alternative to dragging off pins and the right click menu. Those menus are much easier to navigate because they're scopped to what is actually viable. That menu has been reworked and is much better about finding all the things you can use. That being said, if you still encounter issues where it's not showing functions or variables or events that it should, please report it.
                Last edited by Nick Darnell; 02-04-2015, 10:40 AM.

                Comment


                  Hi everyone,

                  For the crash when loading the Vehicle templates, this is a known issue: UE-8887 - Crash in Blueprint Vehicle template in UE4.7 which we have already fixed internally for the next release.

                  For anyone experiencing issues converting their projects from Preview 4 to Preview 5, please make a post on the AnswerHub to the Bug Reports section so we can investigate the issues in depth.

                  As a reminder, please do not use your actual projects for development on any of the Preview releases. They are only for testing, and should be considered unstable until the final release. Thanks
                  Stephen Ellis | Enterprise Program Coordinator

                  Comment


                    Originally posted by FrankieV View Post
                    No sound this time.

                    Checked settings and volume is up full.
                    Originally posted by Furroy View Post
                    They put in the release notes: UE-8875 - No audio playback in the editor
                    There was a bug that neglected to include the per-platform engine config settings. If you need a workaround for this during this preview you can look in Engine\Config\<Platform> and copy the contents of the <Platform>Engine.ini in to your DefaultEngine.ini for your project.

                    Comment


                      Any news on when we might see some official feedback on this bug? Still hasn't been addressed during 4.7's preview builds, bit worried that a fix might not make it in for 4.7

                      (Plus it'll stop me bumping the thread every few days )

                      https://forums.unrealengine.com/show...d-in-4-7-Pre-4

                      Comment


                        Originally posted by DotCam View Post
                        Right now it is only Epic content though. I would be interested to hear how we can create our own content packs if that is possible, would save me so much time. Is this currently possible?
                        Technically yes, however it is a rather manual process. You need to use the UnrealPak tool to bundle up a collection of files in the correct hierarchy. If you want to see how one is currently set up you can use the command that looks like "UnrealPak d:\Temp\TP_FlyingBP.upack -Extract d:\Temp\FlyingBP". This exports the upack to the folder specified.

                        To make one of your own it can either be done with by directory "UnrealPak d:\Temp\TP_FlyingBP.upack -create=d:\Temp\TP_FlyingBP" which will gather up every file in the directory. However, we typically use a source file that specifies which files to gather up like so "UnrealPak d:\Temp\TP_FlyingBP.upack -create=d:\Temp\TP_FlyingBP\contents.txt", the contents.txt contains a list of the files (wildcards allowed) to gather up and store in the pack, so in the case of the flying BP it looks like:

                        Code:
                        ../../../Templates/TP_FlyingBP/manifest.json
                        ../../../Templates/TP_FlyingBP/Config/config.ini
                        ../../../Templates/TP_FlyingBP/Content/*.*
                        ../../../Templates/TP_FlyingBP/Media/TP_FlyingBP.png
                        ../../../Templates/TP_FlyingBP/Media/TP_FlyingBP_Preview.png
                        Pathing is always fun on both the commandline and in the contents file, may take a few tries to get it all set up right, but in theory you can build one yourself


                        Originally posted by RedEyes View Post
                        looks like I can import some Upack files from the content browser, but i can't to find the way to export a selection of asset to create an Upack file by myself.
                        We do have plans on essentially replacing the current Export Assets functionality to write to a upack and hopefully provide mechanisms to gather up the related C++ to make your own code-based packs, however, that is future work that we haven't started on yet.

                        Comment


                          * Components can be used in the graph view also, you can drag components in, just like variables. It's not entirely useless even in graph mode now.
                          Components were previously listed in the 'My Blueprints' section and could be dragged into the Graph. Would it make sense to merge these two panels into one in the future?

                          Originally posted by NickDarnell View Post
                          * The palette is not the recommended workflow. It's not contextual and it is a slower alternative to dragging off pins and the right click menu. Those menus are much easier to navigate because they're scopped to what is actually viable. That menu has been reworked and is much better about finding all the things you can use. That being said, if you still encounter issues where it's not showing functions or variables or events that it should, please report it.
                          There is one area where the 'Palette' faster than the 'Context Sensitive Menu' and that is when I need to add multiple Events or Nodes to a graph in quick succession (ideally simultaneously but that's not possible). For example, today I wanted to add all my Input Events, generated in the Project settings, to the graph. I can refine my search using the 'Palette' and quickly drag all Inputs into the Graph from there, whereas with the Right Click menu I'm constantly opening it, searching in it, clicking on Events and repeating over and over again.

                          Is there a way to drag or group select Events and / or Nodes in the 'Context Sensitive Menu' before creating them in a graph?

                          Comment


                            Originally posted by Marc Audy View Post
                            Technically yes, however it is a rather manual process. You need to use the UnrealPak tool to bundle up a collection of files in the correct hierarchy. If you want to see how one is currently set up you can use the command that looks like "UnrealPak d:\Temp\TP_FlyingBP.upack -Extract d:\Temp\FlyingBP". This exports the upack to the folder specified.

                            To make one of your own it can either be done with by directory "UnrealPak d:\Temp\TP_FlyingBP.upack -create=d:\Temp\TP_FlyingBP" which will gather up every file in the directory. However, we typically use a source file that specifies which files to gather up like so "UnrealPak d:\Temp\TP_FlyingBP.upack -create=d:\Temp\TP_FlyingBP\contents.txt", the contents.txt contains a list of the files (wildcards allowed) to gather up and store in the pack, so in the case of the flying BP it looks like:

                            Code:
                            ../../../Templates/TP_FlyingBP/manifest.json
                            ../../../Templates/TP_FlyingBP/Config/config.ini
                            ../../../Templates/TP_FlyingBP/Content/*.*
                            ../../../Templates/TP_FlyingBP/Media/TP_FlyingBP.png
                            ../../../Templates/TP_FlyingBP/Media/TP_FlyingBP_Preview.png
                            Pathing is always fun on both the commandline and in the contents file, may take a few tries to get it all set up right, but in theory you can build one yourself .
                            That actually doesn't look too difficult, I was expecting it to be even more manual than that so I will give it a try later on. Too bad the Pak tool doesn't have a GUI yet, although it should be fairly simple to create one. Hmmm... might give that a try actually, just a simple little program to select files then run the command line.

                            Thanks for the info Marc!
                            Last edited by DotCam; 02-04-2015, 02:19 PM.
                            Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

                            Comment


                              I've got a wonderful bug in 4.7 for you;
                              Matinee. Creating an event in the track, saving, then heading into the Level Blueprint and adding a controller:
                              The event isn't there.

                              Even if you save / compile everything and restart the editor it's not there.

                              To get it there, you have to do the ol' "Refresh node" method; Even when the node was created after the event / after everything has been compiled and saved.

                              Have replicated this in multiple versions of Preview 5 (Source, Downloaded and various projects).

                              Obviously it's not high priority but it's a bug none-the-less! :P
                              KITATUS
                              "Information shouldn't be behind a paywall, It should be free for all!"

                              Comment


                                Originally posted by Level1noob_1 View Post
                                when i try to play the vehicle template the engine crash
                                This is one of our "Known Issues" - UE-8887 - Crash in Blueprint Vehicle template in UE4.7
                                Stephen Ellis | Enterprise Program Coordinator

                                Comment

                                Working...
                                X