Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Omg, in preview 5 everything is so different DD:
    SuperGrid: Marketplace Page | Feedback Thread | Demo | Website
    Level design and prototyping for newbies

    Comment


      Originally posted by John Alcatraz View Post
      Mieszko, say something regarding the changed decorator events... Please
      According to our bug reports, only one decorator issue has been resolved for 4.7: UE-7870 BP-implemented BT decorator issues with 4.6 to 4.7 upgrade The resolution had this note: "Added a transition API to mitigate fallout after a drastic change in BTDecorator_BlueprintBase's API"

      Is that what you are asking about? If not, I'll see what else I can find out.
      Twitch /unrealalexander| Twitter @UnrealAlexander
      How to report a bug? | Installation & Setup issues?
      Call me to a thread by posting this: [MENTION]Alexander Paschall[/MENTION]

      Comment


        Originally posted by zeOrb View Post
        Omg, in preview 5 everything is so different DD:
        ^^ Agreed

        Different in a good way though, lots of UX improvements which are really nice to see. It's going to take some time to get used to the new blueprint window, having the viewport as a tab instead of the components window, but I can see it being a time saver! Only gripe is I prefer to have all the panels on the left instead of the right so I had to move things around a bit, no big deal.

        Great having C++ classes in the content browser as well, and the new content packs (can we create our own?).

        Looks really good guys! I'm liking it.
        Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

        Comment


          Nice Job.

          Any update on issue - UE-7000
          Can we expect some fix on it? Do you neeed more information to test it?

          Thanks,

          Comment


            Great update (as usual) guys! thanks.

            I'm noticing a regression from preview 4 when attempting to launch on iOS devices. The output log :

            LogPlayLevel: env: 2015-02-03 19:51:56.845 instruments[91255:2424954] Failed to start Instruments daemon on 'xxxx iPad (8.1.3)' (The service is invalid.)
            LogPlayLevel: env: Instruments Usage Error : Timed out waiting for device to boot: "xxxxs iPad (8.1.3)"
            LogPlayLevel: Deleting /Users/xxxxx/xxx/xxx/xxx/xxx/xxx/Saved/StagedBuilds/IOS/launch.trace
            LogPlayLevel: InternalUtils.SafeFindFiles: SafeFindFiles /var/folders/v5/tg6y76193yb0wnp5jzn4fbtw0000gn/T/+Users+Shared+UnrealEngine+4.7/Logs * False
            LogPlayLevel: InternalUtils.FindFiles: FindFiles /var/folders/v5/tg6y76193yb0wnp5jzn4fbtw0000gn/T/+Users+Shared+UnrealEngine+4.7/Logs * False
            LogPlayLevel: BuildCommand.Execute: ERROR: BUILD FAILED
            LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception:
            LogPlayLevel: Program.Main: ERROR: Exception in AutomationScripts.Automation: Client exited with error code: 255
            LogPlayLevel: Stacktrace: at Project.RunStandaloneClient (System.Collections.Generic.List`1 DeployContextList, System.String ClientLogFile, ERunOptions ClientRunFlags, System.String ClientApp, System.String ClientCmdLine, AutomationTool.ProjectParams Params) [0x00000] in <filename unknown>:0
            LogPlayLevel: at Project.RunInternal (AutomationTool.ProjectParams Params, System.String ServerLogFile, System.String ClientLogFile) [0x00000] in <filename unknown>:0
            LogPlayLevel: at Project.Run (AutomationTool.ProjectParams Params) [0x00000] in <filename unknown>:0
            LogPlayLevel: Program.Main: ERROR: Client exited with error code: 255
            LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes.
            LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=1
            LogPlayLevel: Domain_ProcessExit
            LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes.
            LogPlayLevel: Completed Launch On Stage: Run Task, Time: 30.108714
            LogPlayLevel: RunUAT ERROR: AutomationTool was unable to run successfully.
            PackagingResults:Error: Error Launch failed! Unknown Error

            Comment


              Originally posted by Stephen Ellis View Post
              UPDATE!

              We have just released Preview 5 for 4.7! This update to the preview is a very large one and contains an additional 70 bug fixes and new features. Please view the original post on page 1 of this thread for the updated "Known Issues" list.

              In addition to many fixes, Preview 5 also includes some important new features. We encourage you to test these and provide feedback.

              New Features in 4.7 Preview 5

              - In-level Component Editing
              - HTML5 is now included in the binary release
              - C++ Classes in Content Browser
              - Redesigned Blueprint Editor UI with "unified layout"
              - Automatic asset importing
              - Git source control support (Thanks to community member SRombauts)
              - Convert Actors to Blueprint Classes
              - New Tool-tip look and feel
              - New Asset Thumbnail look and feel
              - Ability to add "Content Packs" and "Feature Packs" to your project through Content Browser
              - Blueprint stablility (eliminated circular dependency corruption)
              - Blueprintable components (EXPERIMENTAL!)
              - Paper2D improvements to tile map support (EXPERIMENTAL!) and 2D Terrain splines.

              This update also contains some important known issues which we wish to call particular attention to.

              Important Known Issues in 4.7 Preview 5

              UE-8819 - Physics actors are failing to Simulate
              UE-8875 - No audio playback in the editor
              UE-8925 - Crash occurred dragging newly converted Blueprint into level
              UE-8635 - Sample games are not working once launched onto Android
              UE-8873 - Mac Binary missing files for HTML5
              UE-8737 - Editor crashes at exit and using drop-downs on Mac
              UE-8395 - PList fails to generate on Mac

              Thank you for your continued help in testing the 4.7 build before its official release. As a reminder, the Preview builds are for testing only, and should not be used for the active development of your project.
              Oh God, YES! My sedatives! Someone bring me my sedatives!

              Comment


                UE4 Preview is awesome but when i created new project.

                I cant open my old project. Engine require rebuild project but cant do that in VS. I have 2 errors.

                1>Project "C:\Users\Tomasz\Desktop\UnrealProjects\Desire\Intermediate\ProjectFiles\Desire.vcxproj" on node 2 (Build target(s)).
                1>Build:
                "C:\Program Files\Epic Games\4.7\Engine\Build\BatchFiles\Build.bat" DesireEditor Win64 Development "C:\Users\Tomasz\Desktop\UnrealProjects\Desire\Desire.uproject" -rocket
                1>EXEC : error : Couldn't find target rules file for target 'DesireEditor' in rules assembly 'DesireEditorModuleRules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
                Location: C:\Users\Tomasz\Desktop\UnrealProjects\Desire\Intermediate\Build\BuildRules\DesireEditorModuleRules.dll
                Target rules found:

                1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ""C:\Program Files\Epic Games\4.7\Engine\Build\BatchFiles\Build.bat" DesireEditor Win64 Development "C:\Users\Tomasz\Desktop\UnrealProjects\Desire\Desire.uproject" -rocket" exited with code -1.
                1>Done Building Project "C:\Users\Tomasz\Desktop\UnrealProjects\Desire\Intermediate\ProjectFiles\Desire.vcxproj" (Build target(s)) -- FAILED.

                Its some like big problem in project folder i havent Source folder. I using that project today, that happened after update.

                Thanks guys.

                Comment


                  Thanks for this but I'm still disappointed there is no easy MySQL access for blueprints as it is a core gameplay mechanic and isn't even supported so far...

                  Comment


                    Originally posted by gegagoflow View Post
                    UE4 Preview is awesome but when i created new project.
                    Its some like big problem in project folder i havent Source folder. I using that project today, that happened after update.
                    Thanks guys.
                    Are you saying that neither your old project or new project had any C++ source code, but the engine is trying to recompile your old project when you load it (and failing as per above)? Sorry about that. Can you try to reproduce this in a new project?

                    --Mike

                    Comment


                      I had base project and clone that project(When main project have crush i can return to earlier version), but all projects havent Source Folder and engine cant start compile. When i create new project on Preview5 engine generete normal project with source folder. I have no clue what happaned. Today thats work. 1 month work to delete. Well, when i cant repire that i will jumps through the window.

                      Comment


                        Originally posted by reefG View Post
                        Great update (as usual) guys! thanks.

                        I'm noticing a regression from preview 4 when attempting to launch on iOS devices.
                        Hi reefG, this may be the same as this item on our Known Issues list:
                        UE-8861 Regression: Windows: Cannot deploy launch on or package for iOS with latest version of iTunes

                        Can you confirm if you are using the latest version of iTunes?
                        Stephen Ellis | Enterprise Program Coordinator

                        Comment


                          Preview 5 is amazing; I just wish the UI would stay the same; Makes writing books just that much harder when the engine changes so much engine to engine!

                          Anyhow, Great work everyone! I'm having a blast using 4.05 !
                          KITATUS
                          "Information shouldn't be behind a paywall, It should be free for all!"

                          Comment


                            Originally posted by KitatusStudios View Post
                            I just wish the UI would stay the same; Makes writing books just that much harder when the engine changes so much engine to engine!
                            Believe us, our Documentation team knows your pain all too well.
                            Stephen Ellis | Enterprise Program Coordinator

                            Comment


                              No sound this time.

                              Checked settings and volume is up full.
                              Clarke's third law: Any sufficiently advanced technology is indistinguishable from magic.
                              Custom Map Maker Discord
                              https://discord.gg/t48GHkA
                              Urban Terror https://www.urbanterror.info/home/

                              Comment


                                Originally posted by FrankieV View Post
                                No sound this time.

                                Checked settings and volume is up full.
                                They put in the release notes: UE-8875 - No audio playback in the editor

                                They also tweaked Paper2DSplineActors and their collision bounds and now all my beautiful grappling hook has to be reworked. Doh!

                                Comment

                                Working...
                                X