Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by JJ Hoesing View Post
    I've confirmed that VR appears to be broken in 4.7 Preview 6. VR is working in the latest 4.7 code, so hopefully that fix should be in the next preview build.
    Thanks, JJ! Any rough ETA on the next preview build?

    Leave a comment:


  • replied
    I've confirmed that VR appears to be broken in 4.7 Preview 6. VR is working in the latest 4.7 code, so hopefully that fix should be in the next preview build.

    Leave a comment:


  • replied
    Originally posted by Ben Halliday View Post
    Hi Scrylla and kamrann,

    I haven't been able to reproduce this, but several other people have had the same issue with Preview 6. We're tracking this on AnswerHub here:

    https://answers.unrealengine.com/que...e-playing.html

    While we investigate the issue here, please provide any other details you can add to that post. In the meantime, it appears that setting the Resolution Scale to 100% is working around the issue for now. Thanks!
    I think Resolution Scale IS the issue. In my project which isn't Paper2D, Setting the editor to "Lowest" (With resolution scale set at 25% causes this to happen in the Editor.

    I don't think it's an issue at all, I think it's actually to do with the when you test your project out, the screen obviously won't re-size to the resolution scale / It doesn't upscale from the percentage. So if you're working on a 1920 x 1080 screen (With 1920 x 1080 PIE set), playing it with resolution scale set to 25% will cause it load at 1920 x 1080 window with the game filling 25% of the window.

    Leave a comment:


  • replied
    Just opened up a test project in 4.7 preview 6 and noticed the content browser icons don't resize correctly. They stay itty bitty now and cutoff some of the words. Not sure if that was reported or not. I'd post a pic, but the forum is being weird about posting it now. =)

    Leave a comment:


  • replied
    Any GearVR performance tips for this preview build? I managed to get it to run the FPS template from latest GitHub, shadows weren't working on the cubes as-of this morning but from above I know it is in the pipeline. I did manage to get it to hit 60FPS by changing the skydome and using a simpler one as well as turning off AA, blur, lens flares, bloom, no mobile hdr, etc...

    Performance even at 60FPS feels laggy though and the evidence is that when you move your head quickly you feel like there is a reduced FOV due to the timewarp kicking in and you seeing the left edge that has been warped. Are there any guidelines? Is performance going to improve further in this release and just being held back a bit or is what we see right now what we will get for 4.7 final? Also, any tips on how the buttons and trackpad are mapped in unreal for use in blueprints?

    Thanks!

    Leave a comment:


  • replied
    Originally posted by Scrylla View Post
    I just got 4.7 preview 6 and it seems like something is wrong with the paper2D camera (I haven't tried anything with 3D). It seems like it only shows the upper-left quadrant and I tried this with my game and the example Paper2D side scrolling template. This is how it looks like when I tried it with a new 2D template...


    Hi Scrylla and kamrann,

    I haven't been able to reproduce this, but several other people have had the same issue with Preview 6. We're tracking this on AnswerHub here:

    https://answers.unrealengine.com/que...e-playing.html

    While we investigate the issue here, please provide any other details you can add to that post. In the meantime, it appears that setting the Resolution Scale to 100% is working around the issue for now. Thanks!

    Leave a comment:


  • replied
    Originally posted by TheJamsh View Post
    https://answers.unrealengine.com/que...usability.html

    Been having some issues with cascades usability lately. 4.5's approach was much better than the current. I like the slider idea, but they would be much better and more intuitive if they behaved like Blueprint sliders, where the max value was not clamped to 1.0 if you enter a higher value.
    Hey TheJamsh!

    I hate this change too however I was doing some work in Cascade and found a way to get past it at least with Color values. I think I missed hearing about this one and what the preferred means are to do this but to get around it, I open up the Color Picker and push the Value field past 1. The Color Picker doesn't seem to clamp it but if you type directly in the field within the details panel, it will clamp it back again.

    Been missing from the community lately but hope all you guys are doing well!
    Last edited by MC Stryker; 02-11-2015, 04:52 PM.

    Leave a comment:


  • replied
    Originally posted by RoyAwesome View Post
    I'm seeing some... eccentricities... with the blueprint UI that are new in Preview 6.

    When I create a Variable or Function in a blueprint, it attempts to rename whatever is above it in the tree. This includes category headers.

    When I change a property of a variable (it's name, whether or not it's replicated, it's type, etc) the change takes effect then the variable becomes unselected. This means I have to reselect the Variable to change additional properties. Kinda annoying.
    I'm happy to say both of these issues have already been fixed in the 4.7 branch.

    Cheers,
    Michael Noland

    Leave a comment:


  • replied
    Originally posted by DotCam View Post
    They just added new Tags to the branches on GitHub yesterday. So each preview and actual release has it's own tag now, which is awesome. Have a look here for more info:
    https://forums.unrealengine.com/show...able-on-GitHub
    Yep, thanks. Will make things much easier going forward.

    Leave a comment:


  • replied
    Originally posted by kamrann View Post
    II've been building 4.7, yeah. Various github commits, though I doubt any of them lined up precisely with specific preview releases. I checked out one commit that didn't compile, but all other have been fine.
    They just added new Tags to the branches on GitHub yesterday. So each preview and actual release has it's own tag now, which is awesome. Have a look here for more info:
    https://forums.unrealengine.com/show...able-on-GitHub

    Leave a comment:


  • replied
    I'm also on 8.1.
    I've been building 4.7, yeah. Various github commits, though I doubt any of them lined up precisely with specific preview releases. I checked out one commit that didn't compile, but all other have been fine.

    Leave a comment:


  • replied
    Originally posted by KingBadger3D View Post
    Are you guys on Win7? I am.
    I'm on Win 8.1 and using VS 2013 Community edition, I have downloaded and built the source for preview 3, 5, and 6 without any issues. Build was successful on my first try. I remember reading you recently re-installed everything, just to make sure did you re-install the DirectX 2010 Redistributable pack as well? If not that could be the problem.

    But the fastest way to get up and running is to copy and paste all of the relevant info into a Bug Report on AnswerHub. Please post it there, and leave a link to it here so the dev's can help you out, I will keep an eye on it for you king.

    Leave a comment:


  • replied
    Originally posted by BPANDREW View Post
    I've had very little issues compiling from the 4.7 branch - I'm using the Visual Studio Professional Edition 2013

    if you are doing it clean and following the instructions maybe express isn't supported
    Are you guys on Win7? I am.

    Leave a comment:


  • replied
    I've had very little issues compiling from the 4.7 branch - I'm using the Visual Studio Professional Edition 2013

    if you are doing it clean and following the instructions maybe express isn't supported

    Leave a comment:


  • replied
    Originally posted by kamrann View Post
    i'm using 2013 express, no issues building from source.
    your kidding me!, wtf!.

    The preview code right?

    Leave a comment:

Working...
X