Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Stephen Ellis View Post
    UPDATE!

    We have just released Preview 7 for 4.7! This update to the preview contains an additional 25 bug fixes. Please view the original post on page 1 of this thread for the updated "Known Issues" list.

    Preview 7 has moved Blueprintable Components out of "experimental". Please help us test this new feature.
    • Create your own component types using Blueprint scripting! You can save these components and reuse them on any actor!
    • Click “Add Component”, then select “New Blueprint Script Component…” right at the top. You can do this on actors in your level, from inside any Actor Class Blueprint, and even from the Content Browser’s “New Blueprint…” window.
    • Choose a Parent Class for your new component. “Scene Components” have a 3D position within the actor, but “Actor Components” only have scripting logic. Unless you need a location for something, choose “Actor Component” for your base class. Afterwards, you’ll be prompted to save your new component as an asset.
    • Write Blueprint script code for your new component.
    • Now, you can drop the component onto any actor in your scene


    Thank you for your continued help in testing the 4.7 build before its official release. As a reminder, the Preview builds are for testing only, and should not be used for the active development of your project.


    Now that looks **** handy,

    Leave a comment:


  • replied
    UPDATE!

    We have just released Preview 7 for 4.7! This update to the preview contains an additional 25 bug fixes. Please view the original post on page 1 of this thread for the updated "Known Issues" list.

    Preview 7 has moved Blueprintable Components out of "experimental". Please help us test this new feature.
    • Create your own component types using Blueprint scripting! You can save these components and reuse them on any actor!
    • Click “Add Component”, then select “New Blueprint Script Component…” right at the top. You can do this on actors in your level, from inside any Actor Class Blueprint, and even from the Content Browser’s “New Blueprint…” window.
    • Choose a Parent Class for your new component. “Scene Components” have a 3D position within the actor, but “Actor Components” only have scripting logic. Unless you need a location for something, choose “Actor Component” for your base class. Afterwards, you’ll be prompted to save your new component as an asset.
    • Write Blueprint script code for your new component.
    • Now, you can drop the component onto any actor in your scene


    Thank you for your continued help in testing the 4.7 build before its official release. As a reminder, the Preview builds are for testing only, and should not be used for the active development of your project.

    Leave a comment:


  • replied
    Originally posted by Mhousse1247 View Post
    in this last preview when you biuld as html5,the game is build as windows game
    Howdy Mhousse1247,

    Thank you for reporting this error that you have been seeing. This is a known issue that has been reported. Here is the JIRA report that has been submitted for the issue:

    UE-9448 - UAT no longer seems to work with -<platform>, it needs -platform=<platform> (this means that packaging for iOS and HTML5 packages for Windows)

    Please let us know if you run into any other errors.

    Thanks and have a great day!
    Last edited by [Epic] Gribbs; 02-12-2015, 09:57 AM. Reason: minor edit

    Leave a comment:


  • replied
    Originally posted by Stephen Ellis View Post
    Thanks for planning to post these on the AnswerHub to the Bug Reports section, it will be better for us to investigate them individually than on here. Be sure to let us know if you are converting from 4.6.1.
    Thanks Ellis, I've now posted the 4.7 standalone game bug in AnswerHub (see link)

    I also downloaded Preview 6 and tested again, there's even more errors in standalone game mode than I found in Preview 5. Details are in thread but I wanted to call out one particular bug from 4.6 (also affecting standalone game mode) which seems to have regressed back again.

    PS: Minor thing, the install is now 20 GB! I'm guessing the engine debug symbols that Mike Fricker alluded are represented here. If so, would be nice to have the option to exclude them.
    Last edited by VSZ; 02-12-2015, 09:46 AM. Reason: fixed wrong attribution

    Leave a comment:


  • replied
    Originally posted by kamrann View Post
    @Epic/Scrylla
    I had this issue from the 4.7 github branch too. There appears to be a bug with the 'Resolution Scale' setting (Settings button > Scalability > Engine Scalability Settings).
    Restoring it to 100% should fix the issue; I'm not sure why it would change, perhaps auto performance monitoring?

    This manifests itself in two ways:
    1. In Play mode, the viewport is truncated as in Scrylla's image.
    2. In Simulate mode, the resolution appears to be reduced as intended, however selection and manipulation of the 3D widget is distorted/impossible.

    Thank you soo much kamrann! That fixed it perfectly!

    Leave a comment:


  • replied
    Originally posted by Steve Robb View Post
    Hey - just to let you know that this change should be making it into 4.7. :-)

    Steve
    Great news

    Leave a comment:


  • replied
    It is a T-Mobile Note 4 so it is still KitKat. Not tweaked and nothing installed as just using for dev purposes. Only real tweak to project since this morning was to update material to use mipmap with sharpen4 on a few textures.
    Last edited by druidsbane; 02-11-2015, 09:53 PM.

    Leave a comment:


  • replied
    Hmm, that usually means the app has crashed. I'll take a look and see if I get the same behavior. Are you still on KitKat, or have you upgraded to Lollipop?

    Leave a comment:


  • replied
    Sadly the latest build from GitHub on the Gear VR causes it to launch Oculus Home rather than my app. My build from this morning launched fine on the Gear, now it says: connect to headset, when I do that rather than opening it beeps as it did before then launches the Oculus Home. Is there a regression there like the app crashing? Are any logs necessary or can this be reproduced by others? Was quite excited to try out some of the tips you gave JJ, especially disabling the dynamic lights and so on to see if that helped. Thanks again!

    Leave a comment:


  • replied
    Thanks JJ, that was very useful. Looking forward to the release of that document!

    Leave a comment:


  • replied
    in this last preview when you biuld as html5,the game is build as windows game

    Leave a comment:


  • replied
    I'm not sure of the exact date, sorry. GitHub should already have the fix if you're building from source.

    Re: GearVR performance, I'm working on a doc right now actually. The short version is: avoid any form of dynamic lighting. It's still a mobile device, rendering 2048x1024 at 60Hz all while trying to avoid thermal throttling. Static lightmaps, and rolling your own simple lighting in an emissive-only shader are going to get you pretty far.

    The other thing to adjust are the CPU and GPU clocks. UE4 currently defaults to 2,2. If you need more GPU and are willing to sacrifice CPU perf, you can set it to GPU 3 CPU 1:

    [GearVR.Settings]
    CpuLevel=1
    GpuLevel=3

    As for timewarp, it should be pretty obvious how much it's kicking in, as it will fill in from the sides of the eye with black. If you see a lot of black encroaching on the image when turning your head quickly, then that's the timewarp. You'll always get this to some degree, but if you're hitting 60 reliably, it shouldn't be too bad. If that's not what you're seeing, then we'll want to take a look and see what's going on.

    Leave a comment:


  • replied
    Originally posted by KitatusStudios View Post
    I think Resolution Scale IS the issue. In my project which isn't Paper2D, Setting the editor to "Lowest" (With resolution scale set at 25% causes this to happen in the Editor.

    I don't think it's an issue at all, I think it's actually to do with the when you test your project out, the screen obviously won't re-size to the resolution scale / It doesn't upscale from the percentage. So if you're working on a 1920 x 1080 screen (With 1920 x 1080 PIE set), playing it with resolution scale set to 25% will cause it load at 1920 x 1080 window with the game filling 25% of the window.
    It's not intentional. The low-res target from resolution scale should then be upscaled to the size of the window. It was transiently broken in 4.7 (I saw it last weekend but it was fixed when I synced on late Monday), so it should be fixed in the next preview build.

    Cheers,
    Michael Noland

    Leave a comment:


  • replied
    Originally posted by JJ Hoesing View Post
    I've confirmed that VR appears to be broken in 4.7 Preview 6. VR is working in the latest 4.7 code, so hopefully that fix should be in the next preview build.
    Would really love some feedback on how to get decent Gear VR performance. Just a basic guide for what we can expect. Managed to get 60fps as mentioned above but still feels like time warp is kicking in and not sure how much further performance will improve and what effects can be used.
    Last edited by druidsbane; 02-11-2015, 07:25 PM. Reason: Specify GearVR not regular VR for performance info

    Leave a comment:


  • replied
    Originally posted by JJ Hoesing View Post
    I've confirmed that VR appears to be broken in 4.7 Preview 6. VR is working in the latest 4.7 code, so hopefully that fix should be in the next preview build.
    Would really love some feedback on how to get decent performance. Just a basic guide for what we can expect. Managed to get 60fps as mentioned above but still feels like time warp is kicking in and not sure how much further performance will improve and what effects can be used.

    Leave a comment:

Working...
X