Announcement

Collapse
No announcement yet.

Unreal Engine 4.7 Preview

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by JJ Hoesing View Post
    Hmm, that usually means the app has crashed. I'll take a look and see if I get the same behavior. Are you still on KitKat, or have you upgraded to Lollipop?
    Here is a log for my crash in case it helps. The same process I got to build this level I repeated every time I compiled the engine, it worked at one point then this morning it just stopped. Should I open a bug report for this? Any luck reproducing?

    Leave a comment:


  • replied
    4.7.7

    Place blueprint actor in level.
    Copy or duplicate creates an instance not a copy.
    This is problematic for blueprints with construction scripts for random material change.
    Dragging from content browser to viewport places a new blueprint actor that is not an instance and works correctly.
    This makes level building very slow.
    ALT+Drag creates an instance as well.

    Leave a comment:


  • replied
    Originally posted by Stephen Ellis View Post
    Hi Benjamin,

    I can answer with an uncertain "yes". This is something we discuss regularly and would like to adopt, although we haven't begun the process yet and have no set timeframe. Thank you for the feedback and the suggestions though.

    Cheers
    Thank you for your quick response

    I eagerly await adoption of of this workflow whenever that may be

    Leave a comment:


  • replied
    Originally posted by benjamin.smith View Post
    Are there any plans to open up Epic Games internal UE JIRA project to the masses?
    Hi Benjamin,

    I can answer with an uncertain "yes". This is something we discuss regularly and would like to adopt, although we haven't begun the process yet and have no set timeframe. Thank you for the feedback and the suggestions though.

    Cheers

    Leave a comment:


  • replied
    Are there any plans to open up Epic Games internal UE JIRA project to the masses?

    I would be happy if it was just read-only for now but perhaps integrating JIRA Service Desk at a later date to perhaps partially or fully replace AnswerHub or hell go the Atlassian route and purchase a JIRA+JIRA Agile 10,000+ license for $28,000 AUD (21,679 USD) and run everything internal+external on JIRA

    You could than hook up whatever SSO login system Epic uses to store users (Atlassian Crowd?) between unrealengine.com, AnswerHub, Wiki and forums with your JIRA instance.

    I feel the benefits of such a move would be great and would allow for a more coherent experience for everyone involved with Unreal Engine 4 one way or the other.


    P.S. I have a feeling such a move is already in the works but I'd thought I would mention it nonetheless as I would very much like to see future UE- JIRA issues/tickets being hyperlinked back to the source

    Leave a comment:


  • replied
    Originally posted by sbnewsom View Post
    I'm unsure if the "Bug" reported on the first post regarding the Sky_Sphere was regarding it being broken in Preview 7, but I can't modify the Sky_Sphere settings anymore. Refreshing doesn't work and any changes to values don't have effect. Restarting the editor after making a change doesn't do anything anymore. So is the Sky_Sphere broken in this update? It seems to be broken on current and new projects.
    Yes, there are some issues with existing Blueprints. https://github.com/EpicGames/UnrealE...ea038379274ea3 has the fix.

    You should also be able to open the blueprint, compile and resave it, and then it will work correctly in levels again.

    This should, generally, only be true for older blueprints. Apologies for the issue.

    Leave a comment:


  • replied
    I'm unsure if the "Bug" reported on the first post regarding the Sky_Sphere was regarding it being broken in Preview 7, but I can't modify the Sky_Sphere settings anymore. Refreshing doesn't work and any changes to values don't have effect. Restarting the editor after making a change doesn't do anything anymore. So is the Sky_Sphere broken in this update? It seems to be broken on current and new projects.

    Leave a comment:


  • replied
    i see, makes sense. thx guys! looking forward to it

    Leave a comment:


  • replied
    To clarify, you can do a lot with components, but two big distinctions between components and actors are:

    1) A component cannot contain other components (there is no components tree or AddComponent call available in them); we will hopefully be allowing AddComponent calls in a future release but there are some significant technical hurdles to solve first.
    2) They cannot be placed in a level on their own; they must always be contained in an actor. However, we've also added the ability to make 'empty actors' in the level editor, and you can drag-drop your components into the components tree on any actor in the level editor, or make a Blueprint of an Actor and add them there as usual.

    Cheers,
    Michael Noland

    Leave a comment:


  • replied
    Originally posted by Ollinator View Post
    oh wow, blueprintable components ftw! how the sudden move? werent they just introduced with 4.7? i really hope they'll be stable enough for production! they'll ease a lot of things for sure, where currently you need to spawn+link+destroy actors manually!

    question: will it be possible to re-parent existing blueprints to be components? or do they have to be created from scratch?
    Blueprintable components are far more low level than actors. You won't be able to reparent them, a UActorComponent doesn't have the same capabilities as an Actor in a Blueprint. We'll be adding to it over time.

    Leave a comment:


  • replied
    Looks like emissive does not work in splitscreen. Just have an emissive to a material in the scene then add another player via the "create player" node and the emissive goes away completely.

    Tested this with a clean 3rd person project and set one of the objects to have an emissive value of 100.

    Also when you add a third player everything goes black but when you add a 4th player it starts working again. Resizing the window randomly makes it work again.
    Last edited by pr4wl; 02-12-2015, 04:19 PM.

    Leave a comment:


  • replied
    Originally posted by jjkramhoeft View Post
    but minor bug (crash) when exiting VR Preview with shift F1 ->[X]. but Escape works fine
    Also, ~ -> exit crashes.

    Leave a comment:


  • replied
    oh wow, blueprintable components ftw! how the sudden move? werent they just introduced with 4.7? i really hope they'll be stable enough for production! they'll ease a lot of things for sure, where currently you need to spawn+link+destroy actors manually!

    question: will it be possible to re-parent existing blueprints to be components? or do they have to be created from scratch?

    Leave a comment:


  • replied
    @Motanum - Yes VR is fixed for me.
    Created new ThirdPerson Game, Build, Save, VR Preview - works fine !!!!
    but minor bug (crash) when exiting VR Preview with shift F1 ->[X]. but Escape works fine

    Leave a comment:


  • replied
    Downloading! Is VR preview fixed?

    Leave a comment:

Working...
X