No announcement yet.

Unreal Engine 4.7 Preview

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by ngrts View Post
    Montage status -
    Branch point track is missing(or are notifies taking over?). Access to animation slot manager is only available via manually going to Window menu. Created slots always go into first group no matter second group is selected. How do you actually view more than one slot? What is a Group? latest/INT/Engine/Animation/AnimMontage is doesn't really match whats in 4.7p2.

    Is Montage currently a work in progress area for preview 2?
    In UE4.7, you can create a branching point by creating an anim notify and then set that to be a branching point.


      Originally posted by Soverance View Post
      Awesome, 4.7 update go!

      Any word on updates to the Audio Visualization plugin? I'm hoping to get a fix for it's packaging problems here in the next release.
      Curently working on that one so far i have been able to completely compile the plugin into my code. The last barrier(this why it cant be packaged) is to decompress the pcm data when dealing with cooked content
      Free Inventory System (BP AND C++ Version): Clicky Clicky
      Player Structure System (Houses!) (BP): Pew Pew Marketplace Version: Yoink!
      Howto: Create Dragable UMG Windows: Zoom Zoom


        Love the release so far but I have a question and I'm not sure if it's a "bug" or an intentional change that just wasn't documented to us yet.. but in 4.6.1, with a blueprint created of "MacroLibrary" type (Blueprints->Blueprint Macro Library) I am able to create a node to "Get Game Instance" (right click the graph and type it in, shows up under the "Game" section ) however in 4.7 this no longer shows up (with or without context sensitivity selected.) Same happens with "Get Game Mode"

        Thank you for your time!


          No fix on Unreal engine 4 stability? The editor got very slow since 4.6 . Please fix the problem with the bug report: UE-6354

          which got discussed here:

          best regards.


            Any update on this bug?

            Seems to have been an issue since 4.5
            Ben Halpin - Lead Developer - Lazy Games
            Overdosed on Early Access: Overdosed - A Trip To Hell
            Give a 'like' on fb: Give a 'follow' on twitter: And why not check out


              Another one who is really looking forward to Gear VR support.

              Just saw the Twitch Broadcast. Sounds like great stuff!



                Are there any plans on adding static lightning build for BP placed instanced meshes? I described everything here (in the answers as well):

                This feature is very important for me, I plan to use a lot of instanced meshes placed like this and I see everything works great only with Foliage tool. It would be a blast to have in BP as well.
                Last edited by Nox_A15; 01-12-2015, 04:21 PM.


                  Originally posted by Lazy Games View Post
                  Any update on this bug?

                  Seems to have been an issue since 4.5
                  Yes this has been fixed in main and will be in an upcoming build.


                    I'm excited for 4.7. Hopefully, we'll see a fix for the notorious 'Set Members in Struct' for Struct contained inside of an Array JIRA UE-6451.

                    Foliage rendering performance significantly improved! Hundreds of thousands of foliage instances can be efficiently rendered and edited, with per-instance LOD support and per-pixel dithered LOD transitions.
                    Awesome!!! Can anyone advise if the same performance improvements have been applied to Instanced Static Meshes in general? If YES, this will boost rendering performance of GOLEMs conglomerated from Hundreds of thousands instances. YAY!

                    GOLEM ECS (Click to Enlarge)
           is now part of


                      Hey everyone !

                      I have some deprecation warnings with server rpc's since 4.7.

                      warning C4996: Function YagActor::ServerSetBodyTexturePath needs native implementation by virtual void ServerSetBodyTexturePath_Implementation(const FString& NewBodyTexturePath) due to its properties.
                      I have one of those for each server rpc.
                      I am using a very standard way to declare/define them and it has been working fine until 4.7.
                      I have started a thead about that but after a few exchanges and tries with some experienced guys, the matter is still unresolved so i just post here to draw some attention to the thread:

                      I still don't know whether or not i am doing anything wrong, any official help to settle that matter would be super nice :-)




                        Originally posted by ruohki View Post
                        Curently working on that one so far i have been able to completely compile the plugin into my code. The last barrier(this why it cant be packaged) is to decompress the pcm data when dealing with cooked content
                        Doing gods work! Thanks so much!


                          My Editor 4.6.1 crashes if I leave the Output Log window open for a few minutes. Didn't happen until 4.6.1; Hope this is fixed on 4.7, didn't try it yet.
                          | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |


                            Hey Team Epic, Great work.

                            I was doing some profiling test with 200 of my units on 4.6.1 and I just repeated the same test in 4.7 and I get a huge improvement in the game thread. I receive almost a 4ms improvment! I'm so excited. The only change in my control test was copying my test over to 4.7.

                            W3 Studios


                              Testing out packaging my game and I had this problem where some blueprint stuff doesn't work in the packaged game vs running in the editor. So I've been trying to narrow down where it goes wrong, I mean, what exactly it is that doesn't work and I think, from what I can tell the blueprints run, (tested by printing at various intervals) but some references get lost for some reason.

                              So, for example, for my enemies, I spawn the enemy and with a BeginPlay Event I spawn a weapon into his hand. The enemy I use is a child blueprint of a base blueprint that I use for all enemy pawns. The weapon I use is a child blueprint of a base blueprint for all weapons I use. Inside the enemy blueprint, in the properties, I have it set up to assign a weapon to that enemy. This is set only on the child blueprint, not the base. This is a reference to one of the weapon blueprints, the child, not the base. So the chain there is a enemy child blueprint, spawning a weapon child blueprint through being set within the enemy child.

                              What gets lost in this is the weapon being spawned. It doesn't spawn. The enemy spawn just fine, but in turn it is supposed to spawn the correct weapon, which it doesn't.

                              Another quick example is with ragdolls. I spawn a new skeletal mesh at death for special cases. Normal death just turn on physics, which works fine, but spawning the special case ragdoll doesn't work. The setup is very similar. The ragdoll to spawn is being set within the child blueprint for the enemy. So just like the weapon, that reference is lost. Though it works fine in editor, it does not when packaged.

                              So this all works 100% in editor, and in fact has worked in editor and packaged, since version 4.4 but now in 4.7 I'm having this problem in a packaged game. I tried both Development and Shipping builds and both act the same way.
                              Ninja Arcade - UE4 - Forum Thread -- Ninja Arcade - UE4 - Demo v0.02a



                                We have just released Preview 3 for 4.7! This update to the preview contains 44 bug fixes that were discovered during Preview 1 and 2. Please view the original post on page 1 of this thread for the updated "Known Issues" list.

                                We would like to call out one particular known issue for Preview 3 - "Launch on" for iOS will fail.

                                Thank you for your continued help in testing the 4.7 build before its official release. As a reminder, the Preview builds are for testing only, and should not be used for the active development of your project.

                                Make it a great day.
                                Last edited by Stephen Ellis; 01-14-2015, 10:02 AM.