Announcement

Collapse
No announcement yet.

4.6.1 Hotfix is Live!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    [HOTFIX] 4.6.1 Hotfix is Live!

    Have a look at the fixes available with 4.6.1!

    4.6.1. Fixes
    • ContentExamples Media map movie no longer renders black.
    • ContentExamples Media map no longer shows the UDK splash screen.
    • ContentExamples Media map is no longer missing source video.
    • XBox One now boots from Visual Studio correctly.
    • Fixed an error that caused material If nodes to break.
    • Fixed a bug that was causing new and converted non-ascii text projects to crash.
    • Corrected a bug that prevented composite decorators from being opened in Behavior Trees.
    • Event Nodes can now be called for Event Dispatchers.
    • Fixed an error that prevented the creation of new events in the AnimBP Eventgraph for new Anim Notifies.
    • Corrected Static Lighting on InstancedStaticMeshes.
    • Corrected the adb path and device serial number for Android packaged install batch files
    • Fixed an error that caused crashes on Android when Touch events were called too early.
    • Fixed a bug in pathfinding when default querying extent was not large enough on the Z axis.
    • InstancedStaticMesh now renders correctly on mobile devices.
    • Corrected a bug with animation retargeting adversely affecting looping animations.
    Last edited by Chance Ivey; 04-20-2015, 11:36 AM.
    Adam Davis | Marketplace Support | Epic Games
    How to report a bug? | Installation & Setup issues? | Answerhub Bug Reports | Twitter

    #2
    Adam, can we expect Fixes to Cascade Color modules to come in the next hotfix? It's a real bummer having to wait for 4.7 otherwise!

    Comment


      #3
      Hey TheJamsh,

      At this moment we do not have plans for another 4.6 hotfix, so the "Color Information Clamped to a Max of 1 in Cascade Color Modules" issue you mention is slated for the fix to be in 4.7. Although if you are using the source code for GitHub, I could find the commit to the master branch which contains the fix. Let me know.

      If you weren't aware, there is a workaround listed for the issue: "You can graph it and select the point you want to change and then set value to any number, but it will be clamped back to 1 if you adjust in Details Panel." Not ideal I know. Sorry for the troubles.
      Stephen Ellis | @TheEpicStephen
      Enterprise Program Coordinator

      Comment


        #4
        Originally posted by Stephen Ellis View Post
        If you weren't aware, there is a workaround listed for the issue: "You can graph it and select the point you want to change and then set value to any number, but it will be clamped back to 1 if you adjust in Details Panel." Not ideal I know. Sorry for the troubles.
        I just use the color picker!

        The color picker values are not weirdly clamped and you can enter the values directly like you would normally

        ~~~

        Github Fix


        For anyone with a Github engine you can apply the fix yourself here:
        https://github.com/EpicGames/UnrealE...46962d7b2d4d34




        Rama
        Last edited by Rama; 12-17-2014, 10:19 AM.
        100+ UE4 C++ Tutorials on the UE4 Code Wiki, including UE4 Multi-Threading!

        UE4 Marketplace: Melee Weapon Plugin & Compressed Binary Save System Plugin | Rama's C++ AI Jumping Videos | Vertex Snap Editor Plugin

        Visit www.ue4code.com to see lots of videos about my C++ Creations! ♥ Rama

        Comment


          #5
          Is there any news on the demo recording/playback bug in Shooter Game?

          Comment


            #6
            Does this fix all the random crashing people are getting?
            Stylized Low Poly Environment
            Stylized Low Poly Pine Forest
            Stylized Low Poly Buildings
            First Person Horror Template

            Comment


              #7
              Originally posted by Shirk View Post
              Does this fix all the random crashing people are getting?
              Not only do I second this question, I would also like to add:

              If I accidentally put a loop in my game, I understand the detection and reporting of that loop is important. It keeps me from crashing my game, however, for the love of the gods, please do not replace that with infinite popups telling me that I have a loop. It is obvious that Unreal detected it, so please terminate the process.

              Thanks for the hard work guys and gals!

              Comment


                #8
                When will the SqliteSupport fix be included? In 4.7?

                Comment


                  #9
                  Originally posted by The Britain View Post
                  Not only do I second this question, I would also like to add:

                  If I accidentally put a loop in my game, I understand the detection and reporting of that loop is important. It keeps me from crashing my game, however, for the love of the gods, please do not replace that with infinite popups telling me that I have a loop. It is obvious that Unreal detected it, so please terminate the process.

                  Thanks for the hard work guys and gals!
                  I agree with this too. +1

                  Comment


                    #10
                    Thank you Epic for this small update

                    Comment


                      #11
                      Originally posted by KoldKam View Post
                      I agree with this too. +1
                      Yeah I have issues with while loops in BP, there are instances when Ive wanted to use them and simply cant because they hit the iteration limit in a split second even when I try to put a delay in there. There are instances when you want a loop to runaway for awhile only to come back when the condition has been met, its just a shame that the iteration limit is the same on both for and while, if I raise it for while then I could potentially put myself in trouble with for loops I dont want to run for so long.

                      I actually suggested a detection in the closed Beta testing because I had put while/for loops in construction script and it was causing my BP to crash out when I opened it, making it an irreversible error. I think I did find a way to stop the construction script of a Blueprint through its properties but that option seems to have been removed in the right click menu update for the Content Browser

                      Comment


                        #12
                        Originally posted by MonsOlympus View Post
                        Yeah I have issues with while loops in BP, there are instances when Ive wanted to use them and simply cant because they hit the iteration limit in a split second even when I try to put a delay in there. There are instances when you want a loop to runaway for awhile only to come back when the condition has been met
                        You could use a Gate-Loop instead, or write your own "while loop with delay" (Double Click the loop node. That works great btw).

                        Comment


                          #13
                          Originally posted by Wolfsblut View Post
                          You could use a Gate-Loop instead, or write your own "while loop with delay" (Double Click the loop node. That works great btw).
                          Different loop options are great, but that popup is annoying at a level words can't explain.

                          Comment


                            #14
                            Originally posted by Stephen Ellis View Post
                            If you weren't aware, there is a workaround listed for the issue: "You can graph it and select the point you want to change and then set value to any number, but it will be clamped back to 1 if you adjust in Details Panel." Not ideal I know. Sorry for the troubles.
                            Ah okay, thanks Stephen! Wasn't aware of the graph workaround!

                            Comment


                              #15
                              Well, the author of his car AI project told me this fix would fix my issue about the event node, but it didnt:

                              https://answers.unrealengine.com/que...n-and-aga.html

                              https://forums.unrealengine.com/show...lying-AI/page2

                              Same issue like with 4.6.0 : You click compile, it works, you save, close project, open again, its broken again.

                              Comment

                              Working...
                              X