Announcement

Collapse
No announcement yet.

Unreal Engine 4.26 Preview

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    The collision doesn't work. Hair falls into the floor and meshes. You can't pull the pigtails!
    Attached Files

    Comment


      I've been playing with distance fields and landscape and noticed that a landscape by itself won't contribute to the global distance field. You have to have at least one static mesh in the scene with "affect distance field lighting" enabled for the landscape to contribute. In other words:

      1) Scene with 1 landscape and 1 static mesh, landscape set to contribute to DF lighting and static mesh set to not contribute, no DF representation and the Visualize Global Distance Field view mode doesn't work. Sampling the DF in a debug material on the static mesh returns 0.

      2) Scene with 1 landscape and 2 static meshes, landscape set to contribute to DF, 1 static mesh to contribute, 1 static mesh set to not contribute, DF representation looks correct and the Visualize mode looks correct. Sampling the DF in my debug material looks as expected.

      Comment


        Originally posted by Viniciusgf View Post
        Hair Groom still very unstable in the preview 4, when I try to drag and drop it into the viewport the engine crash instantly
        Yes, same for me. Imported my alembic hair cache, tried viewing it in the editor and it crashes everytime.

        Comment


          If your .uproject has:

          Code:
          {
          "Name": "ChaosClothEditor",
          "Enabled": false
          },
          {
          "Name": "ChaosCloth",
          "Enabled": false
          },
          Skeletal meshes will fail in OnRegister here:

          Code:
          [void USkeletalMeshComponent::OnRegister()]
          
          ...
          
          UClothingSimulationFactory* const DefaultObject = ClothingSimulationFactory->GetDefaultObject<UClothingSimulationFactory>();


          It crashes even if you don't use cloth anywhere. Maybe it isn't a bug if the old default was removed and you are required to have at least one active, but just pointing it out in case anyone is google searching why this broke for them starting with 4.26.

          Comment


            Two problems so far:
            • Translucent surfaces are only showing reflection captures in the left eye in VR when Instanced Stereo is enabled.
            • Decals only show up in one eye in VR regardless of if Instanced Stereo is disabled.

            edit: submitted bug report, Case # 00260004
            Last edited by muchcharles; 10-24-2020, 03:02 PM.

            Comment


              The updater is stuck on queue'd, how can I get it to actually update? Nothing else is downloading, canecelling and restarting the launcher, etc... none of that works. Is there a cache I need to delete? Never had this happen before. Thanks!
              Last edited by decksounds13; 10-26-2020, 01:53 AM.

              Comment


                Originally posted by muchcharles View Post
                Two problems so far:
                • Translucent surfaces are only showing reflection captures in the left eye in VR when Instanced Stereo is enabled.
                • Decals only show up in one eye in VR regardless of if Instanced Stereo is disabled.

                edit: submitted bug report, Case # 00260004
                Does VR editor mode work for you at all? Since preview 4 my screen just goes black when trying editor in VR mdoe

                EDIT:
                I also had disabled instanced stereo due to translucent objects visible only in one eye(set it up like this in preview 3)
                Now I re-enabled instanced stereo for the project in preview 4 to see if anything changed but now the project won't even start, giving me this nice fatal error
                Click image for larger version

Name:	wat.jpg
Views:	1351
Size:	56.8 KB
ID:	1826021

                using rift S, rtx2070 and ryzen 2700
                Last edited by UElaci; 10-26-2020, 03:44 AM.
                my behance and instagram

                Comment


                  Am I the only one who get blank map running at ~40 fps in editor on 4.26 (no matter which preview version) and ~180fps on 4.25?

                  Comment


                    I was having trouble with the fluid sim but then I activated the volumetric plugin and that seemed to get things going but now when I activate the wave foam I get this:
                    Attached Files
                    Last edited by decksounds13; 10-27-2020, 05:15 PM.

                    Comment


                      Hi,
                      Strange things with raytraced shadows foliage in 4.26 preview 4.

                      I converted my 4.25 scene to 4.26 preview 4.

                      All seems to work well accept foliage shadows.
                      I have 3 grass meshes foliage scaled from 0.2 to 0.4.

                      When I paint these foliages, I have good raytraced shadows. But if I fill the whole mesh (Like i did with 4.25) I loose my shadows.
                      I tried differents ways. I changed the scale to 1 and retry to fill... all is working as expected with nice shadows.
                      So I scaled my original my fbxs to 0.2 and re-import them to fill with scale at 1. And no shadows..

                      Anyone knows what i missed...
                      thx..

                      Comment


                        Not sure If someone has already reported It but Ray Trace Shadows doesn't work with the spotlight.



                        Ray Trace Shadows works with everything else tho.
                        Discord: OP #5992

                        Comment


                          4.26 preview4 linux bugs/Issues:

                          Volumetric cloud , water plugin ( water materials), and volumetrics plugin have issues.
                          Editor crashes almost every time when objects are added to map through viewport.
                          If you try to rearrange UI by dragging it crashes every times. (tried many times to dock level panel)

                          Comment


                            Is there a way to get rid of this blocky division between where the clouds and the water meet? I've tried most of the setting on the water material, WaterMeshActor, and the VolumetricCloud and it's material but can't figure it out. When I raise the Layer Bottom Altitude, it gets a bit better but it's still there. REALLY obvious when seen through foliage.

                            Also, the terrain isn't showing up in high resolution screenshots, this images attached are from snipping tool.
                            Attached Files
                            Last edited by decksounds13; 10-28-2020, 05:41 AM.

                            Comment


                              Good day to all. I tested GPU LIghtmass in 4.26.0 preview 4. And have some problems with UV seams on geometry. When building light use CPU i have not UV seams problem. How can solve this problem?Click image for larger version  Name:	Clip2net_201028162242.jpg Views:	0 Size:	262.3 KB ID:	1826705 Click image for larger version  Name:	Clip2net_201028162333.jpg Views:	0 Size:	328.4 KB ID:	1826706

                              Comment


                                Originally posted by decksounds13 View Post
                                Is there a way to get rid of this blocky division between where the clouds and the water meet? I've tried most of the setting on the water material, WaterMeshActor, and the VolumetricCloud and it's material but can't figure it out. When I raise the Layer Bottom Altitude, it gets a bit better but it's still there. REALLY obvious when seen through foliage.

                                Also, the terrain isn't showing up in high resolution screenshots, this image showing the blocky line was from snipping tool.
                                having the same issue, would be nice to know if it's a known issue waiting to be fixed or any workarounds
                                Follow me on Twitter!
                                Developer of Elium - Prison Escape
                                Local Image-Based Lighting for UE4

                                Comment

                                Working...
                                X