Announcement

Collapse
No announcement yet.

Unreal Engine 4.26 Preview

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Replying to a few comments. Yes Water in 4.26 preview 3 is a bit rough, we are working on it!

    >>Seems like the Fluidsim bp is broken for me. The node for "Get first actor in class" seems to not exist. Do i have something not enabled?

    This bug is due to accidentally using a node from the "Volumetrics" plugin. It will be fixed (replaced with similar "Get Actor of Class"). You can either enable Volumetrics plugin or replace that node for now.

    >>Generate Spectrum function is missing from GerstnerWaveController_BP, along with the blueprint trying to use nonexistent connections.

    We no longer need the GerstnerWaveController_BP. Its is not used for anything and is in the middle of being removed. We now generate wave using the Gerstner Wave Generator class which can be applied directly on waterbodies.

    >>But in 4.26 Water And Volumetrics Preview tutorial we can see there is yellow circle tool too. I don't have such tool in UE 4.26 Preview 3

    That is because for the stream, I switched the Ocean material to be Masked. That caused the selection outline to get a more accurate shape. That said, masked is an expensive solution and we have a better solution that only clips the selection outline shader itself.


    Ryan Brucks
    Principal Technical Artist, Epic Games

    Comment


      For anyone else who was baffled by how to do the initial setup of the water:

      When you go to create a new landscape make sure you turn "Edit Layers" on in the creation panel. If you already have a landscape made then you can enable it from the details panel.

      Now you can start adding water bodies and they will properly alter the terrain. The terrain deformation looks like it will go in whatever layer has the WaterBrushManager added to it.

      Comment


        The buoyancy component seems to cause a crash if you don't replace the DefaultSceneRoot of an actor BP with something else. Maybe that was just me being stupid, but for instance, it can happen fairly easily if you create a new BP and then add something like a sphere/static mesh without manually setting it to be the scene root. This happens specifically in BuoyancyComponent.cpp line 48 (Begin Play):

        Code:
        35 void UBuoyancyComponent::BeginPlay()
              .
              .
        47    SimulatingComponent = Cast<UPrimitiveComponent>(Owner->GetRootComponent());
        48    check(SimulatingComponent);

        Also, I've been running into some problems with waves been attenuated when I don't want them to be (basically the attenuation depth setting not working as I expect/assume it to), and I'm wondering if I'm just being dumb and missing something or if it's the water material. The biggest issue I am running into is that waves get attenuated unless I raise the water body thousands of units above the terrain, which is most apparent when using a heightmap or heavily sculpting the landscape. Besides waves, this also causes the blend materials to break down, and the rivers to not render speed/flow at all.

        I've been digging through things like the WaterBodyData function a bit and have tried debugging the values for things like Water Z Height, Water Depth, and Terrain Z Height in hopes of getting a better understanding of the attenuation factor. I feel like I'm getting some strange values for some of those, like extremely large negative values for the Water Z Height (-10000 to -12000 usually), while the Terrain Z Height is correct (although sometimes also not). I know WaterBodyData uses Black_1x1_EXT_Texture as an input, filters it through HighQualityTextureFiltering, and then isolates the blue channel for the Water Z Height. Not sure if there's something I'm missing there with that. If I just change the Water Z Height to be the blue channel of absolute world position, I get what I would expect to be the right value.

        I assume what's happening is with however I have it set up, it thinks my water body is way below the landscape and so it's basically just maxing out the attenuation factor no matter what I set the attenuation depth value to.

        Additionally, if I set up just a basic flat landscape and lake at z = 0, everything seems to work fine. Then, if I start moving the lake down, the waves start to get attenuated as I approach the default attenuation depth of 2048, with max attenuation happening at that value. But the tooltip for that Wave Attenuation Water Depth is "The depth at which waves start being attenuated." Which to me means the waves will only begin to start being attenuated at that value, but it seems instead to be gradually attenuating the waves up to that value. The other problem I'm running into is the attenuation depth value working the opposite of how I would expect it to. For instance, if I bring the landscape and water body both back to z = 0, increasing the attenuation depth value will start attenuating waves until full attenuation at the max value of 10000. Whereas if I decrease it to zero, the waves start getting larger.

        Sorry if any of that is confusing or worded poorly. I know this is all still being worked on too, but thought it might be worth sharing.
        Last edited by DreamGoblin; 10-17-2020, 05:45 PM.

        Comment


          I don't know if I'm missing something, but I cannot seem to raise or lower the height of the lake water. I have a previously built terrain I'm placing a lake into and no matter where I move the height of the water lake object it stays at the same height, with the only exception being when I change the material of the lake, then the surface appears where I want it.

          Comment


            Chaos' simulation seems a lot more stable now and objects are actually going to sleep. I still can't get a large amount of objects to go to sleep though if any of them are stacking up. They will just constantly push each other around.

            Comment


              The UKismetProceduralMeshLibrary seems to still have trouble creating new collision once sliced.

              Comment


                Morph target animation isn't playing in sequencer even after rendering video.. use custom animation always active when scrubbing in sequencer instead of the use animation asset option

                Comment


                  Couldn't find any code for this:
                  • Support for voice communication in collaborative sessions
                  Is this actually implemented and if so where?

                  Comment


                    Anyone get framerate issue in editor? Blank level runs at ~30% of the previous version framerate (~40-50 instead of ~150)
                    Hope it will be fixed on release

                    Comment


                      Originally posted by Shann39 View Post
                      Can we please have build in 3D navigation system for Flying ?
                      I'm working on a space game that have aerial combat but the engine only have ground Nav mesh. The only plugin alternative we have is abandoned by the developer.

                      The Engine need this please!
                      I needed this for my project as well. Found several approaches, mostly abandoned or unfinished. I ended up using this guy's setup: https://www.youtube.com/watch?v=_6JqV3PHyHA

                      I've since made improvements, but it helped me a lot when starting out, with wrapping my head around programming 3D movement trough forces. The big question now is how well this will work with chaos...
                      GL

                      Comment


                        Tesselation on SingleLayerWater seems to spit out errors now.
                        Is tesselation just no longer supported and you folks intent to disable it or just an error for now?
                        Happens on both Flat and PN

                        Comment


                          Hello,

                          i tried the seemingly fixed materials with subsurface scattering in raytracing, and it works to 50%. You can see the subsurface stuff happening, but only on the mesh itself. I was unable to see the results of subsurface scattering in any raytraced reflections.
                          In this example picture, i would expect to see the more red colored backside from that plane, that contains the sss material, however, only the blue main color gets reflected.



                          Edit:

                          And TwoSidedFoliage also have some problems with raytracing, but there it´s not only their missing reflections, they also seem to ignore any texture in the opacity slot. If i set the directional light to non-raytraced shadows, then it works as expected, back to raytraced shadows, texture gets ignored.

                          Last edited by Suthriel; 10-18-2020, 12:15 PM.

                          Comment


                            Just had some tests with landscape layers (blueprint brush) with World Composition. It seems a little broken in 4.26 Preview.3. Is this supposed to be fixed on 4.26?

                            Comment


                              Originally posted by BulleTime View Post
                              Just had some tests with landscape layers (blueprint brush) with World Composition. It seems a little broken in 4.26 Preview.3. Is this supposed to be fixed on 4.26?
                              Would probably help if you were more specific about the problem

                              Comment


                                What I do wrong? Virtual texture ON. Even pressing Ctrl+R.
                                Attached Files

                                Comment

                                Working...
                                X