Announcement

Collapse
No announcement yet.

Unreal Engine 4.25 released!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I presume is Chaos still not included in the launcher version of this? Will it be soon? Per the instructions on the UE4 developer's wiki, it has all plugins required after the old post says the older version of UE4 needs to be compiled, so I would assume so. I did enable the Fields System plugin which it also said was needed but did not see the chaos editor anywhere, including under modes. Will Chaos be included and further documented in a future release?

    Comment


      You still need to build from source in this version to use Chaos.
      In the last stream about 4.25, one of the devs said that as Chaos changes everything related to physics under the hood, they won't enable it in the launcher version before it's mature enough. He seemed to say that it would not happen soon.

      Comment


        Does chaos get used in other areas like vehicle physics?

        Comment


          Originally posted by paul1489 View Post
          I created a blank Third Person, C++ project with UE 4.25, and before project creation completes... when compiling I get :

          Using Visual Studio 2017 14.13.26131 toolchain (C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.13.26128) and Windows 10.0.16299.0 SDK (C:\Program Files (x86)\Windows Kits\10).
          Building 11 actions with 8 processes...
          @progress 'Compiling C++ source code...' 0%
          @progress 'Compiling C++ source code...' 9%
          [1/11] Default.rc2
          @progress 'Compiling C++ source code...' 18%
          [2/11] SharedPCH.Engine.ShadowErrors.cpp
          E:\UE_4.25\Engine\Source\Runtime\Core\Public\Delegates/DelegateInstancesImpl.h(397): error C2338: You cannot use raw method delegates with UObjects.
          E:\UE_4.25\Engine\Source\Runtime\Core\Public\Delegates/DelegateInstancesImpl.h(521): note: see reference to class template instantiation 'TBaseRawMethodDelegateInstance<bConst,UserClass,WrappedRetValType(ParamTypes...),VarTypes...>' being compiled

          Could anybody try creating new C++ project ? Something wrong with my Visual Studio 2017 communtiy edition ?
          Upgraded to VS 2019 Community , and it worked fine a new project, but upgraded my C++ project and got a UE4 Crash . Sent report.

          Comment


            Originally posted by CodeSpartan View Post

            Oh, I thought I was using ContainerPtrToValuePtr somehow wrong, because whatever I tried, it kept crashing.

            Looks like it's not just me. Do you think you can submit a bug report?
            Hi,
            Did you manage to fix your issue ?

            I can't dig further into this, my knowledge of the engine source code is very limited.
            I can submit a bug report, but I don't really know if it a bug or something wrong on my end. Project works fine on 4.23 tough.

            Comment


              Hi, as soon as the project is opened I get the following crash Unreal Engine is exiting due to D3D device being lost. (Error: 0x0 - 'S_OK')
              Even a Blank Project crashes everytume. UE 4.25 is definitely not working for me.
              Hd intel Graphics + Geforce 1070, 32 GB RAM

              Edit: the problem occurs only when window is maximized, I have to work in a non-full screen window in order to make the UE4 working.


              It seems the Intel HD Graphics 630 is incompatible with full screen mode.
              Last edited by TheFoxSoft; 05-11-2020, 02:11 PM.

              Comment


                any idea when light transmission through translucent materials in ray tracing might be implemented?

                Comment


                  Regarding Steam integration and testing in editor: We're aware of an issue in 4.25.0 that prevents loading Steam OSS when testing in Standalone. We're working on a fix, but in the meantime here's a workaround:

                  Remove the -MultiprocessOSS argument from the CommandLine in PlayLevelNewProcess.cpp line 101:
                  Code:
                  CommandLine += FString::Printf(TEXT("GameUserSettingsINI=\"%s\" -MultiprocessSaveConfig "), *GameUserSettingsOverride); /*-MultiprocessOSS*/

                  Comment


                    Originally posted by dzernesto View Post

                    Hi,
                    Did you manage to fix your issue ?

                    I can't dig further into this, my knowledge of the engine source code is very limited.
                    I can submit a bug report, but I don't really know if it a bug or something wrong on my end. Project works fine on 4.23 tough.
                    No, I didn't. It does look like a bug to me, so I would definitely submit it myself if I had the time. Even if it's not a bug, they should tell you why it's not with proper explanations. Last time I submitted a bug, it turned out that it wasn't, but they wrote a very detailed technical explanation as to why the engine was behaving the way it was.

                    Just make sure you send them a very small project with just the bug in it, and nothing else. If it works in 4.23, but not in 4.25, it's absolutely grounds for a bug report.

                    Let me know how it goes, I'm very interested in this issue.
                    Last edited by CodeSpartan; 05-12-2020, 12:07 AM.
                    MMO Starter Kit
                    Dialogue Plugin
                    Voxel Plugin
                    Character Customization: Female
                    Character Customization: Male

                    Comment


                      I've installed the latest plugins, but I can't seem to find out how to access the Dynamo nodes for exporting. Is there another installer I am missing somewhere?

                      Comment


                        anyone getting slow dwnl/install for 425... like 100mb per hour slow...

                        Comment


                          Where on gods green earth do I put the id etc in for the azure spatial anchors? Is this possible yet? It is in Unity ( dirty word ) Thanks

                          Comment


                            Since update to 4.25, Getting flickering on any materials that are reflective. It occurs not only from any light source that's present, but also if there's a bright additive material within the vicinity of it. Below is a video of it.
                            https://www.youtube.com/watch?v=KI5n...ture=emb_title

                            Update:
                            Found out that it was setting:
                            [/Script/Engine.RendererSettings]
                            r.DefaultFeature.AntiAliasing=1

                            Which was in my upgraded project, removing this parameter fixed the flickering.
                            Last edited by wortek; 05-13-2020, 10:41 AM.

                            Comment


                              Anyone know how to enable the Hair Raytracing Radius Scale for the Groom Asset...

                              Comment


                                Originally posted by muchcharles View Post
                                Virtual texture lightmaps seem to have been broken by 4.25, I haven't found a permutation of settings that fixes it yet. Anyone else had this issue? I saw someone mention it for preview 5 here and never saw any followup:

                                https://forums.unrealengine.com/unre...18#post1741818
                                Have the same issue, reported a bug as i did not found one yet.

                                Comment

                                Working...
                                X