Announcement

Collapse
No announcement yet.

Unreal Engine 4.25 released!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    VictorLerp don't want to saturate the bug reporter with these plugin compile issues. Do you think it's something that could be easily fixed? I always see a point update as a 'soft' update that never really breaks stuff. This has got me - and probably others by the sound of it - quite stuck. If there's a simple fix for those of us non-versed in the build files it'd be great to hear!

    Comment


      Phew! Workaround for plugin compile issues: Copy the plugins from the engine/plugins/marketplace folder to your project's plugin folder where they'll compile ok.

      Comment


        Originally posted by Dannington View Post
        Phew! Workaround for plugin compile issues: Copy the plugins from the engine/plugins/marketplace folder to your project's plugin folder where they'll compile ok.
        Worked here for me too!

        Comment


          Awesome work guys. I hope this fixes up many of my issues in 4.25. I jumped in too far too get out! Great step ahead
          My Marketplace Items

          My Website

          My Unreal Games

          Comment


            It's crashing on Android Armv7 apk + obb only.
            I'm getting this

            2020-07-23 22:36:25.125 32426-32426/? A/DEBUG: pid: 31993, tid: 32060, name: Thread-4 >>> com.thelostroad <<<
            2020-07-23 22:36:25.186 32426-32426/? A/DEBUG: #00 pc 03f8a0d8 /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (FAsyncPackage::PostLoadObjects()+624) (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)
            2020-07-23 22:36:25.186 32426-32426/? A/DEBUG: #01 pc 03f80d5c /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (FAsyncPackage::TickAsyncPackage(bool, bool, float&, FFlushTree*)+500) (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)
            2020-07-23 22:36:25.186 32426-32426/? A/DEBUG: #02 pc 03f80074 /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (FAsyncLoadingThread::ProcessAsyncLoading(int&, bool, bool, float, FFlushTree*)+1820) (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)
            2020-07-23 22:36:25.186 32426-32426/? A/DEBUG: #03 pc 03f84a34 /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (FAsyncLoadingThread::TickAsyncThread(bool, bool, float, bool&, FFlushTree*)+628) (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)
            2020-07-23 22:36:25.186 32426-32426/? A/DEBUG: #04 pc 03f84184 /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (FAsyncLoadingThread::TickAsyncLoading(bool, bool, float, FFlushTree*)+436) (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)
            2020-07-23 22:36:25.186 32426-32426/? A/DEBUG: #05 pc 03f8c4b8 /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (non-virtual thunk to FAsyncLoadingThread::ProcessLoading(bool, bool, float)+156) (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)
            2020-07-23 22:36:25.186 32426-32426/? A/DEBUG: #06 pc 05ff574c /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (FFrameEndSync::Sync(bool)+640) (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)
            2020-07-23 22:36:25.186 32426-32426/? A/DEBUG: #07 pc 03796590 /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (FEngineLoop::Tick()+7992) (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)
            2020-07-23 22:36:25.186 32426-32426/? A/DEBUG: #08 pc 03793834 /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (AndroidMain(android_app*)+2984) (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)
            2020-07-23 22:36:25.187 32426-32426/? A/DEBUG: #09 pc 037975f4 /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (android_main+136) (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)
            2020-07-23 22:36:25.187 32426-32426/? A/DEBUG: #10 pc 037b0af4 /data/app/com.thelostroad-8pursCUAB-lXzGZ3cZW2mQ==/lib/arm/libUE4.so (BuildId: 4d9c9fa0c0c5b3cb6130c35bc24d43369acb40fe)

            Comment


              they need to allow us to roll back if these point fixes are going to start breaking builds

              Comment


                Originally posted by Dannington View Post
                VictorLerp don't want to saturate the bug reporter with these plugin compile issues. Do you think it's something that could be easily fixed? I always see a point update as a 'soft' update that never really breaks stuff. This has got me - and probably others by the sound of it - quite stuck. If there's a simple fix for those of us non-versed in the build files it'd be great to hear!
                We'd rather see an influx of the same issue rather than it not being submitted at all. Thanks for the mention, I don't have a simple fix on hand but I've forwarded the information to the team and will follow up as soon as possible. If you could provide us with more details on which plugins are affected that would help the team!

                Originally posted by Doug_Richardson View Post
                VictorLerp: I have the same question as jimsnomis. When is 4.25.2 going to be released/tagged on github?
                The process for the GitHub version takes longer than the launcher - It's currently processing and should be available soon.

                Comment


                  Well, the Hotfix 4.25.2 just released pushed me out of work In all C++ projects, no marketplace plugin can be used any longer because the project doesn't build!

                  Ineed to urgently roll back to 4.25.1, but I don't find any way to do that I hope Epic will issue a 4.25.3 like immediately or explain how to remove the hotfix.

                  I also submitted a bug, case # 00199239.
                  Life is Short... Keep it Cool

                  Comment


                    Originally posted by VictorLerp View Post
                    We'd rather see an influx of the same issue rather than it not being submitted at all. Thanks for the mention, I don't have a simple fix on hand but I've forwarded the information to the team and will follow up as soon as possible. If you could provide us with more details on which plugins are affected that would help the team!



                    The process for the GitHub version takes longer than the launcher - It's currently processing and should be available soon.
                    Do we use this form?

                    I wonder how a bug like this slipped through, it seems to affect every plugin that is downloaded/installed from outside, ex: MegaScans plugin, Substance plugin, anything from Marketplace. Pretty widespread.

                    Comment


                      Megascan Plugin produces the same error.

                      Comment


                        Hello guys! First of all sorry for writing my problems here but for last three weeks I've worked day and night to solve my project crash, which I've worked for 8 months.
                        After I've updated my project to 4.25 it all went well but after the hotfix 4.25.1, on mobiles with armv7 support my game is crashing.
                        So to use an old 4.24 backup it's a no because I've made significant changes to the game. Here is the strange thing. If I try build the game in development mode it's working. If I build the game in shipping mode and I check to package the game inside the apk it's also working but if in Shipping Mode I uncheck package inside apk (because my game is almost 300mb so I need a OBB file) the game is not working on mobiles with armv7 support only. So only if I have a expansion file it's crashing and only in shipping mode.
                        I've merged my game to another project but still crashes, I've tried to downgrade the project to 4.24 but it's not working. In one cloned project I've deleted all the content and created a new empty map and still the same problem. I've also removed all config files and replaced with defaults one. I've checked all blueprints/widgets but still not working.
                        I'm using Android Studio to debug the game and I get this crash logs. This crash is when using nativization. When disabling the nativization, sometimes it opens the first level ( start game ) and after I hit the play button it's crashing again with the same errors.
                        Other errors I have are when using nativization on my own character. I got a build crash so I have to delete my character from nativization list.
                        I've also reinstalled my windows, ue4 and android studio. Also tested on another PC but still crashing when launching on mobiles.
                        Also all my 4.25 backups (more than 10 backups are not working) so this problems appeared after updating from 4.24 to 4.25
                        crash_01.txt

                        Click image for larger version  Name:	exclusivenativization.png Views:	0 Size:	263.3 KB ID:	1792235

                        Can someone explain to me what this crash logs means? I've worked a lot on this game and now I can't do anything with it. I really have to solve this. Thank you very much
                        Attached Files
                        Last edited by butavpaul; 07-24-2020, 07:13 AM.

                        Comment


                          Hello,
                          I have this bug since last update 4.25.2, in my VR project when I do "play this level" the window looks zoomed by 200%. My log are in the middle of the screen !
                          I use htc vive
                          Work normally after build.

                          Thanks


                          edit : in steam VR view it's ok but not in unreal (photo 2)
                          Last edited by strategia31; 07-24-2020, 09:16 AM.

                          Comment


                            Plugins are broken. How do I go back to 4.25.1? It doesn't show up in the Engine Versions selection dropdown.

                            Comment


                              I think they solved the problem. Click the arrow down and press on verify and wait to update. If no try the top advice. Copy from plugins/marketplace the plugins inside yourproject/Plugins folder and compile after that.

                              Comment


                                Hey All -

                                The blocking issue related to opening projects that have Marketplace Plugins enabled with 4.25.2 has been logged as https://issues.unrealengine.com/issue/UE-95865

                                We've identified the offending changelist and are working on generating and testing a QFE that we'll post link to ASAP to unblock everyone until we can get a proper hotfix build out.
                                Nick Bullard-Bradley
                                Senior QA Lead | Unreal Engine | Epic Games

                                Comment

                                Working...
                                X