Announcement

Collapse
No announcement yet.

Unreal Engine 4.25 released!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I'm still unable to build from source with errors in UnrealInsightsCLI.cpp. It's referencing TraceServices/SessionService.h which looks to have been removed after 4.24. I'm building Development Editor Win64.

    Error C1083 Cannot open include file: 'TraceServices/SessionService.h': No such file or directory UnrealInsightsCLI \Engine\Source\Programs\UnrealInsightsCLI\Private\UnrealInsightsCLI.cpp 9


    Line 9: https://github.com/EpicGames/UnrealE...nsightsCLI.cpp

    https://github.com/EpicGames/UnrealE.../TraceServices - SessionService.h shows up when changing branch to 4.24

    Edit: For anyone running into this issue, it seems to be when building with JetBrains Rider for Unreal Engine. I suspect other IDEs may also have this issue, however have not tested. I have updated my support case for this which you can find at https://issues.unrealengine.com/issue/UE-92977. One thing that I found in my testing is that VS will successfully build from source, however it shows the same error. I'm not sure why VS continues through this error while Rider (and possibly other) IDEs fail. Either way, I view this more a fault on UnrealInsightsCLI.cpp having dependency errors than Rider failing the build.
    Last edited by Cohemus; 05-12-2020, 09:35 PM. Reason: Updated with new information

    Comment


      #17
      Awesome! Thanks for all the hard work the team at Unreal puts into updates, new features, fixes, and everything else you guys do. You put a lot of accessible power into the hands of people who otherwise wouldn't have it, and that means a lot! I'm excited to update and start playing some some of the new changes that have been made and to see where optimizations may have happened.

      Unfortunately one test I've already run still appears to be problematic. It's a performance bottleneck that seems to happen with Niagara systems in a Ray Traced project on the OcclusionSubmittedFence Wait channel (still not sure what information is being processed here). I'm hoping someone with in depth knowledge of the systems and the information used in them gets their eyes on this.

      I've got an in depth post here going over the issue and steps I've taken to troubleshoot: https://forums.unrealengine.com/development-discussion/rendering/1742323-niagara-systems-in-ray-traced-project-killing-fps-from-occlusionsubmittedfence-wait

      Can't wait to see where this engine is at in the next couple of years as SO many new leaps in visual graphics have been happening so quickly. What an exciting time to be a gamer

      Comment


        #18
        Looking forward to upgrade..

        Editor Performance Improvements

        • Efficiency of shader compilation through Incredibuild has been improved by 90% in some cases, leading to a 5x decrease in distributed shader compilation time with our internal setup.
        • Proxy mesh creation process is now better at scaling with the number of CPUs and can easily result in processing time reduction of more than 3x for complex setup.
        • Bulk convex hull computation on big scenes can be more than 100x faster than before and takes 4x less memory in some scenarios, taking a multi-hour long process to a couple minutes.
        • Material baking improvements have made it up to 14x faster and 3x less memory hungry than before, performance improvements may vary depending on which GPU backend is used.
        • Improvements in how Datasmith handle data reimports will result in a healthy decrease of both reimport times and memory usage.
        • A rework of how Datasmith CAD scenes are saved will make new CAD scenes save and load take seconds instead of minutes.
        • Datasmith VRED and DeltaGen FBX import workflow will now feel a lot snappier on huge FBX files.
        • Distance fields are now computed a lot more efficiently on many core CPUs leading to 5x reduction in processing time and better core utilization.
        • Exporting video production to PNG files is faster than ever and will make use of new instruction sets capabilities like AVX-2 when detected on your computer. It's now possible to export a 4K video to loose PNG files in real-time on 16 Core CPUs.

        https://docs.unrealengine.com/en-US/..._25/index.html
        [LEGENDS of EPICA Now on Steam] [Twitter] - [Discord]

        Comment


          #19
          Hi everyone,

          In mobile,
          1. in IOS remote development it gives dll missing error.
          Code:
          UATHelper: Packaging (iOS): ERROR: Precompiled rules assembly '/Users/user/Library/Application Support/Epic/UnrealEngine/4.25/Intermediate/Build/BuildRules/UE4Rules.dll' does not exist.
          PackagingResults: Error: Precompiled rules assembly '/Users/user/Library/Application Support/Epic/UnrealEngine/4.25/Intermediate/Build/BuildRules/UE4Rules.dll' does not exist.
          2. In mobile preview (editor and mobile preview), render target materials not clear the background. When I change the preview rendering model to shader model 5, it works well. I haven't tested in mobile yet because it doesn't compile because of missing dll error.

          3. When you activate auto mesh instance, in editor (IOS preview is active), all static meshes disappears. I looks fine in mobile preview.

          Comment


            #20
            This landscape modifying tool feature is also released? Not sure where this is mentioned in the notes.

            https://twitter.com/i/status/1257689944568598528
            [LEGENDS of EPICA Now on Steam] [Twitter] - [Discord]

            Comment


              #21
              Originally posted by unit23 View Post
              This landscape modifying tool feature is also released? Not sure where this is mentioned in the notes.

              https://twitter.com/i/status/1257689944568598528
              It's not a landscape tool. It's general mesh sculpting.

              New: In-Viewport Modeling and Sculpting Improvements (Experimental)


              We continue to make major improvements in our experimental set of tools for working with geometry directly within the Unreal Editor Viewport, progressing with every release toward the goal of achieving complete, end-to-end workflows for geometry modeling and adaptive mesh sculpting.

              In this release, we've also introduced several mesh repair tools aimed at correcting minor issues with imported Assets, especially those that come from CAD applications. These offer the ability to fill holes, to move pivot points relative to the geometry, and to generate and adjust UV mappings interactively.

              Comment


                #22
                I will just pin here interesting blueprint changes, I believe these deserve more attention.


                New: Implemented variadic function support for Blueprints
                New: Added Blueprint support for FIntPoint.
                New: Users now have the options to display access specifiers for functions and variables in the "My Blueprint" window.
                New: You can now add metadata to FString and FName UPROPERTYs; this metadata specifies a dynamically called function to get the options that are available to the user in a Details panel.
                Attached Files

                Comment


                  #23
                  As usual the most interesting changes are in the footnotes away from the spotlight. Let's take a look at a few!


                  New: FAudioDevice lifespans have now been fully decoupled from the UWorld, meaning that you can arbitrarily spawn and use instances of the audio engine in code. This is useful for building profilers, or for rendering audio for arbitrary systems. \ Example usage: \ FAudioDeviceParams DeviceParams; \ DeviceParams.Scope = EAudioDeviceScope::Unique; \ MyAudioDeviceToRecord = AudioDeviceManager->RequestAudioDevice(DeviceParams);
                  This one will most likely have its uses in stuff like, loading screen audio perhaps, or cross-level music. I know there was some functionality to prevent a audio component from destroying between levels before too.

                  New: All test methods now return a boolean to indicate if the test passed or fail. Implemented new macros run those methods and, if they return false, insert a "return false" in the code, so that it exits the current test immediately. This lets programmers write automated tests much faster.

                  See comments and example in Core/Public/Misc/AutomationTest.h
                  Hooray for Gauntlet!

                  New: Added Physical Material Masks to Materials, which are used to associate multiple physical Materials with a single Material based on a mask. This is only supported when Chaos physics is enabled. In the Material, set the Physical Material Mask to a mask and Physical Material Map to an array of physical materials. In the Static Mesh properties, Support Physical Material Masks must be enabled and additional data will be stored at runtime.
                  This is by far the biggest thing for me in this release. No longer do you have to split your material IDs on metal, wood etc. to get proper physical materials on them. Please oh please tell me this works with landscapes too?

                  New: Added optional per-instance custom data for Instance Static Meshes. This comes with a material node to sample the custom data by index. Also added a Blueprint setter for the data. This data will be serialized on the InstanceStaticMesh Component. By default the number of custom data floats is 0 and this will not allocate any additional data.
                  This one is also gigantic. Custom data per-foliage instance!? Sign me the %!#@# up.

                  Comment


                    #24
                    Somebody goofed up the HDRIBackdrop plugin - rotations of the backdrop are now off by a factor of 6.28. RotateAboutAxis takes a 0->1 Range, not Radians (which is the conversion that is now actually performed).

                    Bug submitted.

                    Comment


                      #25
                      I filed a bug report, but it looks like SSR is totally busted if you change the Anti Aliasing Method to anything but TemporalAA.

                      Comment


                        #26
                        Point cloud...please, where is the budget option??? How can I make it full res now?? Anyone? Thx!

                        Comment


                          #27
                          Thanks for the update! Lots of juicy things to get stuck into!

                          Is it just me or are Instance-synced variables on AI Blackboards now broken? I can't seem to utilize them any blackboards without UE4 crashing, even in a fresh project with a near-empty blackboard.

                          Code:
                          Assertion failed: BlackboardDataToComponentsMap.FindPair(&BlackboardData, &BlackboardComp) == nullptr [File:D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/AIModule/Private/AISystem.cpp] [Line: 220]
                          Had a search online for the error message and noticed someone had this in preview 7. Still seems to be occurring. It was all working in 4.24.

                          I've submitted a bug report with an example project but wondering if I'm just doing something stupid with instance-synced variables. Do I need to do anything behind the scenes other than check the box?
                          Last edited by BtotheLaker; 05-05-2020, 07:59 PM.

                          Comment


                            #28
                            I'm having the TraceServices build error too:

                            Code:
                            40>  [1/3] UnrealInsightsCLI.cpp
                            40>C:\git\UnrealEngine\Engine\Source\Programs\UnrealInsightsCLI\Private\UnrealInsightsCLI.cpp(9): fatal error C1083: Cannot open include file: 'TraceServices/SessionService.h': No such file or directory

                            Comment


                              #29
                              Does anyone have issues with C++ projects where when you add a new Component the source file opens with errors in Visual Studio?

                              I also see this:
                              Warning: HotReload operation took 13.5s.
                              LogSlate: Window 'Add C++ Component' being destroyed
                              LogUObjectGlobals: Warning: Failed to find object 'Class /Script/ArtRunnerCpp.CounterWatch'
                              LogHotReload: New module detected: UE4Editor-ArtRunnerCpp-0562.dll
                              LogHotReload: Starting Hot-Reload from IDE

                              Comment


                                #30
                                No more mobile tonmapper?? Its so bad. How i can back it?

                                Comment

                                Working...
                                X