Announcement

Collapse
No announcement yet.

Unreal Engine 4.25 released!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    With 4.25.1, when I enable ray tracing, I now get periodic hitches on the rhi thread every second or so....almost like pulsing when moving camera. Occurs on blank map.

    Anybody else have a similar experience?

    [UPDATE]
    Installed latest nvidia drivers. Rebooted. Problem gone. sooo strange....
    Last edited by OptimisticMonkey; 06-04-2020, 11:20 PM.
    https://www.casualdistractiongames.com

    Comment


      Originally posted by MostHost LA View Post
      muchcharles
      To be honest, within any material an if statement always caused both pathways to compile. to the point that I have been using Custom nodes to avoid this the whole past year.
      The issue isn't that the both compile, it is that lightmass gets the wrong value. I made a simplified reproduction with purely diffuse. The material instance ends up reflecting red light instead of green light in lightmass (ground is white in image), even though it sets the switch boolean to be green and in the scene it renders as green:

      Click image for larger version  Name:	InstanceStaticSwitchBug.jpg Views:	0 Size:	625.0 KB ID:	1771454


      (edit: fixed here: https://github.com/EpicGames/UnrealEngine/pull/7025 )
      Attached Files
      Last edited by muchcharles; 06-05-2020, 05:54 PM.

      Comment


        I cant download the newer version because the launcher keeps telling me that a game is already running, when its not! Has anybody else experienced this and is there a work round?

        Comment


          In VR mode i can't actually pull the radial menus. In he manual it says to press the track button, but nothing happens. it seems to be rigged differently. Is this just me or is this a bug in UE?

          Comment


            I fixed the static switch issue:

            https://github.com/EpicGames/UnrealEngine/pull/7025

            You have to clear DDC and SwarmCache after applying for it to work, I don't know where in the code to invalidate the DDC lookup and swarmcache automatically by bumping a version number or something... anyone know?
            Last edited by muchcharles; 06-05-2020, 08:15 PM.

            Comment


              I get the following error as well in compiled builds on shipping with 4.25.1s hot-fix

              So i made a quick Windows 7 virtual machine and boom getting the same error as them, also getting various reports of it affecting other Windows 7 users


              Last edited by Dark583; 06-05-2020, 11:34 PM.
              Cepheus Protocol
              recruitment@halcyonwinds.com

              Comment


                Blueprint child animation overrides are bugged when selecting a different target skeleton override in 4.25.1

                These steps don't work:

                1) Create Animation Blueprint for one skeleton, create all logic etc. inside it
                2) Right-Click this base AnimBP in Content Browser and create child blueprint
                3) Open child blueprint AnimBP and go to Class Settings (the icon with the gear), change Target Skeleton there
                4) Go to "Asset Override Editor" tab. If it's not open, click in the menu: Window -> Asset Override Editor
                5) replace all animations from old skeleton with animations from new skeleton
                6) If it's not working as expected, try to compile/save/close/open the AnimBP


                https://forums.unrealengine.com/deve...61#post1765161
                Last edited by hard_code; 06-06-2020, 08:22 AM.

                Comment


                  As a continuation of my previous thread on Windows 7 support broken in 4.25.1 sample projects that come with UE4 also will not run in any Win 7 environment now. Shipping cooked build havent tried the editor itself.

                  Bug report has been filed but I'm anxious on a fix as a forced hotfix shouldnt be breaking things like this. Yes 4.25.0 worked perfectly on Win 7 I confirmed with serveral third parties they are having the issues as well
                  Last edited by Dark583; 06-06-2020, 07:03 PM.
                  Cepheus Protocol
                  recruitment@halcyonwinds.com

                  Comment


                    Originally posted by GRADgr View Post


                    A. 4.25 Source Code ( not Plus) wont compile solution. Any idea? Thank you!

                    edit : copying SessionService.h from 4.24 will build source with some errors, but at least editor this time will launch

                    Click image for larger version

Name:	a1.PNG
Views:	1926
Size:	11.0 KB
ID:	1756521

                    B. Also iOS Remote Build won't complete on binary 4.25

                    Did anyone find a fix for this? Right now we can't build to iOS on our projects
                    David Gillespie
                    Associate
                    Foster + Partners

                    Comment


                      The 4.25.1 hotfix broke transparencies in mobile. Is there a way to roll back to 4.25.0. You can see it in the ES3.1 previewer. Submitted a bug report. Please help.

                      Comment


                        RESTORE IN APP PURCHASES ( v1+v2 ) node is Broken for both iOS/Android

                        SEARCHING FOR ANYTHIN IN ALL BPS WINDOW WILL FREEZE EDITOR
                        Last edited by GRADgr; 06-08-2020, 06:49 PM.

                        Comment


                          4.25.1 crashes now in Windows Editor every time you interact with a windows file open dialog for any reason.

                          Comment


                            Originally posted by david.gillespie View Post

                            Did anyone find a fix for this? Right now we can't build to iOS on our projects
                            for B. check on iOS Development forum, there's a solution

                            Comment


                              Scene Depth for ES3.1 shader model doesn't work anymore and took with it decals, depth fade, world position behind translucency e.t.c

                              Attached Files
                              Check out my works here: Youtube channel. Project: CityBattle | Virtual Earth

                              Comment


                                The AnimationCompression error which I have reported weeks ago is likely also affecting Paragon assets, and the new ACF plugin https://www.unrealengine.com/marketp...on-rpg-creator . The staff responded to my error report asking me to replicate this with Epic assets, which is probably now possible with compiling ACF (which includes Paragon Assets).

                                In order to replicate the bug - getting required info, you have to compile ACF Example project for DebugGame with EventLoader disabled, and AsyncLoading/Level Streaming enabled, perhaps another setting is involved.

                                If you do not disable EDL you get an AsyncLoading error. Perhaps it is related to this commit https://github.com/EpicGames/UnrealE...aa40252caf9561 or may be this one which addressed such an issue in March https://github.com/EpicGames/UnrealE...dea7fb27973c47


                                Code:
                                Assertion failed: !Obj->HasAnyFlags(RF_NeedLoad) [File:D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Engine/Private/Animation/AnimCompressionTypes.cpp] [Line: 403] Failed to load AnimBoneCompressionSettings /Engine/Animation/DefaultAnimBoneCompressionSettings.DefaultAnimBoneCompressionSettings in AnimSequence /Game/ACFExample/RetargetParagon/Unarmed/Travel_Mode_Jump_Start.Travel_Mode_Jump_Start

                                Topic
                                https://forums.unrealengine.com/deve...es#post1773965
                                Last edited by unit23; 06-10-2020, 08:15 AM.
                                [LEGENDS of EPICA][Twitter][FB][YT][Vimeo]

                                Comment

                                Working...
                                X