Announcement

Collapse
No announcement yet.

Unreal Engine 4.25 Preview

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by rasamaya View Post
    We can get the project to send to headset successfully. So no errors building/cooking etc. This requires a bunch of file transfers discussed earlier. When running on quest it crashes right way. Epic is aware of this. I don't think it was fixed in preview 5, but you could try but it failed on 4 and there was no mention of the quest fix. I am curious if its been logged as official bug or not? Better to wait for the Oculus build anyway.
    didn't they say 4.25 release would be the fix for that? and btw oculus will still have to update their plugins and UE4 Integration AFTER full release so tbh stay on an earlier release till then.

    These Preview versions DON'T have updated oculus integrations yet. none of the oculus stuff like DASH integrations are working yet, oculus audio is broken and these will be updated by release i hope.
    Last edited by frostic; 03-31-2020, 08:25 PM.
    Matt Walton: Programmer and owner for WireLiteSoft Games.

    Comment


      Just an update, this release corrected an issue i was having with Visual Studio 2019 (Not officially supported), my c++ projects are working! Also appears to be working with Resharper if anyone is interested to know

      Edit:
      Spoke too soon, newly added Components are showing strange intellisense errors in Visual Studio, though i can build the project and functionally it works

      Edit#2:
      If you include any other headers the intellisense issues go away. I added "#include "Engine/TriggerVolume.h" to my component and the syntax issues in the editor went away.

      I don't want to install Vis 2017 unless I need to, the entire office uses 2019 with 4.24.3 with no issues so i'm trying to see if we can get things to work properly.
      Last edited by Nupaul; 03-31-2020, 10:31 PM.

      Comment


        Insights is still not functional in preview 5. Frame time graph is empty, trace doubles up on itself and then breaks off.

        Comment


          It would be nice to have the option to use a selected asset from the content browser in the Movie Render Queue window:

          Comment


            tested 4.25.0p5. Making builds for Oculus Quest are successful. After installing and launching on the Quest though, the app is immediately stuck at the three blinking dots. Same as in p4. No errors when using
            Code:
            adb logcat *:S DEBUG:V UE4:V VRAPI:V > debug.log
            Last edited by maxbrown; 04-01-2020, 03:28 AM.

            Comment


              Is there any info on the DMX fixtures - can't quite seem to configure the dmx map for my fixtures. Looking at DMXLibrary under Fixture Types tab, and DMXImport field, there is no object to select from or option to create new.



              Also, is it possible to set the ethernet port to listen to DMX/ sACN on a machine with multiple ports

              thanks

              Comment


                Originally posted by Ninicoda View Post
                guys, if I download the preview edition, do I need redownload anything from start again if the stable version available? or I just need update it like updating from 4.x.1 to 4.x.2 (not redownload anything from start?)
                pretty sure you have to download the whole thing again...

                Comment


                  Originally posted by jpaulM View Post
                  Hello, is the landscape layers considered as stable in 4.24.3, or should i wait for 25 before including this into my project. Because that thing sounds really awesome. the question i'm asking to myself, do i continue, or go back a bit to jump better
                  if you go back, don't go past 4.23, there were fundamental changes there... i am jumping 4.24, it's kind of a mess... layers is still new, so i'm not sure on that, try to migrate first rather than 'open in new version', it could corrupt stuff...

                  Comment


                    Fixed! UE-91110 Landscape Grass renders offset from Landscapes

                    yeah i noticed that, but being in cinematics i just moved the camera or bumped the landscape... very cool

                    Comment


                      Originally posted by frostic View Post

                      didn't they say 4.25 release would be the fix for that? and btw oculus will still have to update their plugins and UE4 Integration AFTER full release so tbh stay on an earlier release till then.

                      These Preview versions DON'T have updated oculus integrations yet. none of the oculus stuff like DASH integrations are working yet, oculus audio is broken and these will be updated by release i hope.
                      They actually did update the Oculus integrations, at least they did for Oculus Audio (which I follow closely in GitHub and now finally has Android support added) but you are right, it is broken and it is not the latest from Oculus but one or two versions behind. I found a fix (it's very simple) and also reported the bug but haven't heard back.

                      The issue is that it is not clear who takes care of bugs in third party plugin integrations for the official Epic engine releases. I've asked before about this and Epic says it's on Oculus and Oculus seems to only take care of their own integration (which anyways updates very slowly for Unreal Engine). A solution would be to get Oculus to produce a plugin that can be used directly in the official engine release and not having to build whole versions of the engine. I wonder why even though they are called plugins a lot of third party integrations release whole engine versions with them. It's unpractical and it's not really working conceptually as a plugin. It also makes it impossible or really hard to merge different third party plugins. In the case of Unity Oculus just releases packages that work with the official version (of course, it would be impossible otherwise since Unity has no engine source available).
                      Last edited by virtualHC; 04-01-2020, 01:20 PM.

                      Comment


                        Originally posted by maxbrown View Post
                        tested 4.25.0p5. Making builds for Oculus Quest are successful. After installing and launching on the Quest though, the app is immediately stuck at the three blinking dots. Same as in p4. No errors when using
                        Code:
                        adb logcat *:S DEBUG:V UE4:V VRAPI:V > debug.log
                        Thanks for checking! I wasnt going to waste my time as I didnt see this in the fixes. But I was still very curious. Its a known issue with Epic.

                        Comment



                          In my plugin, I need to set default variables for the assembly, but I do not find the event when the project started to build.
                          Attached Files

                          Comment


                            Mobile Depth of field doesn`t work in UE 4.25 preview 5 or any preview.. In 4.24 works well with same settings. There is no focus everything is blurry no matter of parameters. Please any comments on this. Thanks.BR
                            Last edited by Nire2020; 04-01-2020, 04:50 PM.

                            Comment


                              Originally posted by Nire2020 View Post
                              Mobile Depth of field doesn`t work in UE 4.25 preview 5 or any preview.. In 4.24 works well with same settings. There is no focus everything is blurry no matter of parameters. Please any comments on this. Thanks.BR
                              Submit a bug report!

                              Comment


                                Originally posted by The_Distiller View Post
                                Ray traced translucency breaks the shader. Switching it back to raster should fix it.
                                thank you. will give it a shot!

                                Comment

                                Working...
                                X