Announcement

Collapse
No announcement yet.

Unreal Engine 4.23 Released!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #91
    Originally posted by Slavq View Post



    I also have a tool on the Marketplace that uses the in-editor ticking. Other project that I know also relies on it, so it's a really unfortunate situation.
    For now, the only workaround I've found is to create an Editor Utility Widget and run it - this one can tick in editor, but only when it's opened and in focus, so that's definitely not ideal.
    Dear dev team, please restore the ability to tick in editor for Editor Utility Actors (or any other editor utility actor that can be placed in level), just like the deprecated Placed Editor Utility Base was able to tick.
    I submitted a bug report and included this video. I should get a response sometime next week. If this is an oversight they might be able to remedie this in a hot fix for 4.23.

    Comment


      #92
      Originally posted by Ore Creative View Post

      I submitted a bug report and included this video. I should get a response sometime next week. If this is an oversight they might be able to remedie this in a hot fix for 4.23.
      That's great, thanks - I also submitted a bug report yesterday: https://imgur.com/a/MMoSy5k (simple repro steps, creating an Editor Utility Actor and plugging a PrintString to EventTick)
      Let's hope that they'll hotfix it soon, I've tried to find any workaround, but without luck. I'll post here if I get any news.

      Comment


        #93
        I use "GetAssetByObjectPath" and "GetAsset" BP nodes in 4.22, I just opened the project in 4.23 and every instance of those throws an error:

        "The current value of the ' In Asset Data ' pin is invalid: 'In Asset Data' in action 'Get Asset' must have an input wired into it ("by ref" params expect a valid input to operate on)."

        Also the GetAssetByObjectPath gets disconnected.

        Anybody got that problem?
        Snap Plugin for EditorSnap Plugin for Games
        Modular Japanese HouseScaffold System
        TwitterBlogYoutubeitch.io

        Comment


          #94
          Originally posted by Slavq View Post

          That's great, thanks - I also submitted a bug report yesterday: https://imgur.com/a/MMoSy5k (simple repro steps, creating an Editor Utility Actor and plugging a PrintString to EventTick)
          Let's hope that they'll hotfix it soon, I've tried to find any workaround, but without luck. I'll post here if I get any news.
          That's great the more people that bring it up the more likely it will be taken care of quickly. When you say "effects field only has preview version" what does that mean exactly?
          Last edited by Ore Creative; 09-07-2019, 01:38 PM.

          Comment


            #95
            Originally posted by Ore Creative View Post

            That's great the more people that bring it up the more likely it will be taken care of quickly. When you say "effects field only has preview version" what does that mean exactly?
            Oh, that's only for the bug report clarification, the final 4.23 version was not listed in the "Affects Version" list in the form, so I just picked the "4.23 Preview".

            Comment


              #96
              Originally posted by Slavq View Post

              Oh, that's only for the bug report clarification, the final 4.23 version was not listed in the "Affects Version" list in the form, so I just picked the "4.23 Preview".
              Ahh I see. Makes sense.

              Comment


                #97
                Originally posted by scha View Post
                I use "GetAssetByObjectPath" and "GetAsset" BP nodes in 4.22, I just opened the project in 4.23 and every instance of those throws an error:

                "The current value of the ' In Asset Data ' pin is invalid: 'In Asset Data' in action 'Get Asset' must have an input wired into it ("by ref" params expect a valid input to operate on)."

                Also the GetAssetByObjectPath gets disconnected.

                Anybody got that problem?
                If it is the same issue that I ran into, you have to go to each of the nodes and connect up their execution pins to the rest of your nodes. I haven't looked back at 4.22 but I'm guessing these used to be "pure" style nodes. And now they need to be on an execution pathway to function. I hope that helps.

                - Dave
                Latest Demo, Turtle VR: http://www.turtlevr.com
                Mobile VR Jam 2015 Entry: Circumpaint
                VR game, Here Come The Dead: http://www.herecomethedead.com/
                Main web site: http://www.gnometech.com/

                Comment


                  #98
                  Originally posted by Gnometech View Post

                  If it is the same issue that I ran into, you have to go to each of the nodes and connect up their execution pins to the rest of your nodes. I haven't looked back at 4.22 but I'm guessing these used to be "pure" style nodes. And now they need to be on an execution pathway to function. I hope that helps.

                  - Dave
                  Aha, okay, that makes sense. That's why the rest of the bp is connected correctly.
                  Snap Plugin for EditorSnap Plugin for Games
                  Modular Japanese HouseScaffold System
                  TwitterBlogYoutubeitch.io

                  Comment


                    #99
                    When cross compiling my dedicated server, I'm getting:

                    Code:
                      LogInit: Display:
                      LogInit: Display: Warning/Error Summary (Unique only)
                      LogInit: Display: -----------------------------------
                      LogInit: Display: LogOutputDevice: Error: begin: stack for UAT
                      LogInit: Display: LogOutputDevice: Error: === Handled ensure: ===
                      LogInit: Display: LogOutputDevice: Error:
                      LogInit: Display: LogOutputDevice: Error: Ensure condition failed: PlatformInfo.PlatformType != PlatformInfo::EPlatformType::Editor [File:C:/git/UnrealEngine/Engine/Source/Developer/BlueprintNativeCodeGen/Private/BlueprintNativeCodeGenUtils.cpp] [Line: 159]
                      LogInit: Display: LogOutputDevice: Error: Nativized Blueprint plugin is for cooked projects only - it isn't supported in editor builds.
                      LogInit: Display: LogOutputDevice: Error: Stack:
                      LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00007fff25100139 UE4Editor-BlueprintNativeCodeGen.dll!DispatchCheckVerify<bool,<lambda_52396d979bc0f1ea09551fc2fc5fd585> >() [C:\git\UnrealEngine\Engine\Source\Runtime\Core\Public\Misc\AssertionMacros.h:164]
                      LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00007fff250dbf39 UE4Editor-BlueprintNativeCodeGen.dll!BlueprintNativeCodeGenUtilsImpl::GeneratePluginDescFile() [C:\git\UnrealEngine\Engine\Source\Developer\BlueprintNativeCodeGen\Private\BlueprintNativeCodeGenUtils.cpp:159]
                    I'm building with:

                    Code:
                    .\RunUAT.bat  BuildCookRun -project="C:\path\to\MyProject.uproject" -noP4 -platform=Linux -clientconfig=Shipping -serverconfig=Shipping -cook -server -serverplatform=Linux -noclient -build -compile -pak -allmaps -stage -archive -archivedirectory="C:\UE4Packaging\MyProject\20190907\1"
                    I never had this happen on 4.22 or before, any idea what's going on? It seems to be trying to create my nativized assets into an editor plugin instead of shipping config plugin?

                    Comment


                      Anyone got any idea how to make it work? Simply overriding the Run function in an Editor Utility Actor doesn't fire it.

                      MMO Starter Kit
                      Dialogue Plugin
                      Voxel Plugin
                      Character Customization: Female
                      Character Custmization: Male

                      Comment


                        Also, can't find Blutilities anymore (gone from Edit > Editor Preferences).
                        MMO Starter Kit
                        Dialogue Plugin
                        Voxel Plugin
                        Character Customization: Female
                        Character Custmization: Male

                        Comment


                          Originally posted by CodeSpartan View Post
                          Also, can't find Blutilities anymore (gone from Edit > Editor Preferences).
                          I believe they are not experimental anymore, so they are always enabled by default.

                          About blutitlities, is there a way to make GlobalEditorUtilityBase derived BP work like before? I have one bp like that, with various "run-in-editor" functions. In 4.22 it will open as a window with different buttons for call-in-editor functions. But in 4.23 it's not working anymore. When I open it it will just complain about "Run" function and that's it. Any way to make it work again?
                          Snap Plugin for EditorSnap Plugin for Games
                          Modular Japanese HouseScaffold System
                          TwitterBlogYoutubeitch.io

                          Comment


                            Originally posted by scha View Post

                            I believe they are not experimental anymore, so they are always enabled by default.

                            About blutitlities, is there a way to make GlobalEditorUtilityBase derived BP work like before? I have one bp like that, with various "run-in-editor" functions. In 4.22 it will open as a window with different buttons for call-in-editor functions. But in 4.23 it's not working anymore. When I open it it will just complain about "Run" function and that's it. Any way to make it work again?
                            The class was renamed to UDEPRECATED_GlobalEditorUtilityBase. The shelf is also gone.
                            MMO Starter Kit
                            Dialogue Plugin
                            Voxel Plugin
                            Character Customization: Female
                            Character Custmization: Male

                            Comment


                              Are there any plans to expose the custom primitive data to be edited inside the details panel inside the editor?
                              So you can simply use this data for level design purposes (different colors and so on).
                              AFAIK as for now you can only set the custom data with code/blueprints at runtime.
                              Last edited by pDunkl; 09-08-2019, 05:31 AM.


                              [PLUGIN] Free Radar Chart Widget

                              Comment


                                I just noticed the material node 'EyeAdaptation' does absolutely nothing, it just outputs 1.0 - both as a postprocess material (in whatever Blendable Location) and as a regular material applied to an actor. is this known?


                                Edit - oh it's also broken in 4.22. since when is this broken?
                                Last edited by Chosker; 09-08-2019, 05:48 AM.
                                Follow me on Twitter!
                                Developer of Elium - Prison Escape
                                Local Image-Based Lighting for UE4

                                Comment

                                Working...
                                X