Announcement

Collapse
No announcement yet.

Unreal Engine 4.23 Released!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    The launcher does not list any 4.2x versions for downloading. I am on iMac, latest OS version, using Safari.

    Comment


      Hopefully we see a hotfix soon. The landscape grass bugs are frustrating
      Outer Planet Studios
      http://outerplanet.webflow.io/

      Comment


        If you have a weird motion blur/smear when moving camera in PIE after updating to 4.23, uncheck the Generate Mesh Distance Fields in the projects settings, restart, check it again, restart.
        This has fixed it in my case. Just leaving the info here for anyone having the same problem.

        UPDATE: It fixes it only temporarily As soon as I open any map that uses distance fields, the issue is back.
        I'll try to reproduce this in a new project. There is a weird motion blur/smear when moving camera, but only in PIE or Standalone play mode. In editor (without the game running) everything looks correctly.

        Update 2:
        I'm not sure if this is related to distance fields at all, maybe the issue lies somewhere else. I'm still trying to reproduce that in a new project.

        Update 3: I've found the bug! The issue is related to the Scene Capture Component 2D! When there is a blueprint actor in a scene with it, and a render target with 2048 or 4096 res, it corrupts the rendering after hitting Play! There is a very visible smearing/blur when moving camera. "Capture Every Frame" is disabled. This was not happening in 4.22. I'll reproduce this now in a new project and submit a bug report.

        Update 4: I've reported the bug. For anyone interested, here are the repro steps:

        1. Add a blueprint actor with Scene Capture Component 2D into any scene
        2. Create a render target asset with 4094x4096 resolution (can also be 2048, but the issue is more visible with larger res)
        3. In the Scene Capture Component 2D, assign the render target to the Texture Target field
        4. Move camera in the viewport, there is no smearing. Now Play in editor and do the same (e.g. look at objects like the sun on the default sky sphere), there is visible smearing/blurring when moving camera.

        I've also attached a simple repro project:

        https://www.dropbox.com/s/zkv210v8w2...Repro.zip?dl=0

        To see the issue:
        1. In the included ReproMap, play in editor and move camera when looking e.g. at the sun. There is no smearing.
        2. Stop playing, in the ActorWithSceneCapture actor that is placed in the scene, assign the RenderTarget_4k asset to the Render Target field.
        3. Play in editor, move the camera when looking at the sun - there is a visible smearing/blurring.
        Last edited by Slavq; 09-19-2019, 10:24 AM.

        Comment


          Slavq Thanks for the info! As soon you have the issue number, please let us know, so we can track the fix release.
          Nilson Lima
          Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
          Join us at Discord: https://discord.gg/uFFSEXY

          UE4 Marketplace: Cloudscape Seasons
          supporting: Community FREE Ocean plugin

          Comment


            Sure, I'll drop the info here as soon as I have any news.

            In the meantime, another issue with 4.23: When you have a large landscape with tessellated material, it takes much longer to load after hitting Play. In 4.22 the same setup loads in 1-2s, in 4.23 it takes 7-8s on my end. I've reported that with an example project & repro steps, if you want to test if your project is affected: https://imgur.com/a/MUWJRyq
            https://www.dropbox.com/s/n31cee8vuskts9d/LongPlayLoadRepro.zip?dl=0

            Comment


              As I promised: I've just got an update on the blurring/smearing issue from my report:
              This is a known issue that is currently being investigated.
              Link to track: https://issues.unrealengine.com/issue/UE-80576

              Comment


                Originally posted by Slavq View Post
                As I promised: I've just got an update on the blurring/smearing issue from my report:
                This is a known issue that is currently being investigated.
                Link to track: https://issues.unrealengine.com/issue/UE-80576
                target fix 4.24... >.>
                Nilson Lima
                Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
                Join us at Discord: https://discord.gg/uFFSEXY

                UE4 Marketplace: Cloudscape Seasons
                supporting: Community FREE Ocean plugin

                Comment


                  Yes, this is a quite severe issue so I'm also surprised that the target is set to 4.24.
                  I've replied with some additional info regarding the issue happening even with the Capture Evey Frame checkbox off on the component.

                  Comment


                    Thank you Epic. Looking real good.

                    Tiny things, but a bit of a hassle in workflow.

                    1. Upon loading a level, Sequencer resets.

                    2. If you used "set as pivot offset" for an object. Every time you move it, the pivot goes back to original, until you deselect and re-select.

                    Thanks again!

                    Comment


                      Any estimate on when Chaos will be out of beta?

                      Comment


                        Originally posted by lazysnake61 View Post
                        Any estimate on when Chaos will be out of beta?
                        Just like our release dates for the engine, we don't like to set form dates or release versions. Sorry.

                        Keep checking back each major release for the latest information, though!
                        Tim Hobson | Learning Resources | Epic Games
                        UE4 Documentation

                        Comment


                          Tim would you have time to use the fps to destroy a GeoCollection. I have been using shooter in the Chaos Demo, but like to fps do the destruction. Thanks.

                          Comment


                            I am getting insane HZB hit (124ms) when having DX12 enabled on my detailed map. With DX11 HZB is only 0.24ms and FPS over 70. What could cause that difference?

                            Comment


                              Originally posted by Slavq View Post
                              Yes, this is a quite severe issue so I'm also surprised that the target is set to 4.24.
                              I've replied with some additional info regarding the issue happening even with the Capture Evey Frame checkbox off on the component.
                              I agree it sounds like a very bad bug that should be fixed in a 4.23 hotfix. Did you find any workaround for the issue?
                              Last edited by John Alcatraz; 09-24-2019, 12:36 PM.
                              Easy to use UMG Mini Map on the UE4 Marketplace.
                              Forum thread: https://forums.unrealengine.com/show...-Plug-and-Play

                              Comment


                                Originally posted by muchcharles View Post
                                When cross compiling my dedicated server, I'm getting:

                                Code:
                                LogInit: Display: LogOutputDevice: Error: Nativized Blueprint plugin is for cooked projects only - it isn't supported in editor builds.
                                https://github.com/EpicGames/UnrealEngine/pull/6242

                                Comment

                                Working...
                                X