Announcement

Collapse
No announcement yet.

How to enable Chaos

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Fieol View Post
    Hi FlyingPencil I followed the instructions mentioned in the epic link here
    https://docs.unrealengine.com/en-US/...iew/index.html

    Could you elaborate me a little bit how did you run the project ?
    use my guide.

    https://forums.unrealengine.com/unre...34#post1780034

    Leave a comment:


  • replied


    Hi everyone, I have a question about chaos, I'm developing a project that has physics as its main part. Is Chaos fully usable in multiplayer? Is every piece that is destroyed perfectly replicated between clients? Thanks for the reply

    Leave a comment:


  • replied
    @Fieol
    After i got the UE4 engine built and working I created a new FPShooterBP Project. ( checked and made sure the Chaos plugins were enabled and had the Fracture Mode available in editor), What I did then was grab the ChaosDemo project for correct UE4 version and copied the Content folder into the new FPShooter project. Then start up the FPShooter project and change the Level Map to one of the Chaos Maps and ran it. It seemed to work ok. Hope this helps. If you try it this way
    "BuildEnvironment = TargetBuildEnvironment.Unique;" should be fine. I'll check back in tomorrow, maybe i'll remember abit more by then. I did try the other methods, but for me this worked out best for me.

    Leave a comment:


  • replied
    Hi FlyingPencil I followed the instructions mentioned in the epic link here
    https://docs.unrealengine.com/en-US/...iew/index.html

    Could you elaborate me a little bit how did you run the project ?

    Leave a comment:


  • replied
    @Fieol
    I think your UE4Editor.Target.cs should look like this:
    BuildEnvironment = TargetBuildEnvironment.Shared;

    Chaos Demo one's looks ok with Unique.

    Leave a comment:


  • replied
    Hi Devs I'm using 4.24.3 repository to build the source. Here is how my UE4Editor.Target.cs looks:
    Code:
    using UnrealBuildTool;
    using System.Collections.Generic;
    
    public class UE4EditorTarget : TargetRules
    {
    public UE4EditorTarget( TargetInfo Target ) : base(Target)
    {
    Type = TargetType.Editor;
    BuildEnvironment = TargetBuildEnvironment.Unique;
    bBuildAllModules = true;
    ExtraModuleNames.Add("UE4Game");
    
    bCompileChaos = true;
    //Note that the following line is not needed for 4.23 or previous versions.
    bUseChaos = true;
    
    }
    }
    I build the source and it compiles successfully. Here is the UE4Game.Target.cs
    Code:
    using UnrealBuildTool;
    using System.Collections.Generic;
    
    [SupportedPlatforms(UnrealPlatformClass.All)]
    public class UE4GameTarget : TargetRules
    {
    public UE4GameTarget( TargetInfo Target ) : base(Target)
    {
    Type = TargetType.Game;
    BuildEnvironment = TargetBuildEnvironment.Shared;
    
    ExtraModuleNames.Add("UE4Game");
    
    if (Target.Platform == UnrealTargetPlatform.IOS)
    {
    // to make iOS projects as small as possible we excluded some items from the engine.
    // uncomment below to make a smaller iOS build
    
    }
    }
    }
    Now after the compilation is successful, I downloaded the ChaosDemo from learn tab from Epic Launcher and generated the solution file based on the engine binaries I build above (4.24.3)
    Here is how the ChaosDestructionDemoEditor.Target.cs looks
    Code:
    // Copyright 1998-2019 Epic Games, Inc. All Rights Reserved.
    
    using UnrealBuildTool;
    using System.Collections.Generic;
    
    public class ChaosDestructionDemoEditorTarget : TargetRules
    {
    public ChaosDestructionDemoEditorTarget(TargetInfo Target) : base(Target)
    {
    Type = TargetType.Editor;
    
    ExtraModuleNames.AddRange( new string[] { "ChaosDestructionDemo" } );
    
    bCompileChaos = true;
    bUseChaos = true;
    bCompilePhysX = true;
    bCompileAPEX = true;
    bCompileNvCloth = true;
    bCustomSceneQueryStructure = true;
    BuildEnvironment = TargetBuildEnvironment.Unique;
    // DefaultBuildSettings = BuildSettingsVersion.V2;
    
    }
    }
    And how the ChaosDestructionDemo.Target.cs looks
    Code:
    // Copyright 1998-2019 Epic Games, Inc. All Rights Reserved.
    
    using UnrealBuildTool;
    using System.Collections.Generic;
    
    public class ChaosDestructionDemoTarget : TargetRules
    {
    public ChaosDestructionDemoTarget(TargetInfo Target) : base(Target)
    {
    Type = TargetType.Game;
    
    ExtraModuleNames.AddRange( new string[] { "ChaosDestructionDemo" } );
    
    bCompileChaos = true;
    bUseChaos = true;
    bCompilePhysX = true;
    bCompileAPEX = true;
    bCompileNvCloth = true;
    bCustomSceneQueryStructure = true;
    }
    }
    Both of the projects UE4.sln and ChaosDesctructionDemo.sln has compiled successfully. However when I tried running the Chaos demo it failed with an error. So I copied the content of the Chaos Demo and pasted into a new template project made from the source build 4.24.3. I build this template project with the project settings and build settings copied from ChaosDestructionDemo.Target.cs and ChaosDestructionDemoEditor.Target.cs , and the build is successful! But with a sad news, the project is not able to run. Here I shared the output log.

    I'm very much frustrated with the chaos build and how it to start with the demo, I've tried building with 4.24.3 multiple times and its always ending up with the error log mentioned as this.

    Please devs I need your help.

    Leave a comment:


  • replied
    Hey guys!
    Has anybody tried to built the project?
    In my build I can see collections but can't interact with them. It looks like plugin doesn't work, but there weren't any errors while building.
    Help please If someone succeed with that.

    Leave a comment:


  • replied
    I was excited to try out chaos destruction. I played around with it for a bit and figured I'd share my experience. For reference I'm an experienced developer, but completely new to C++ / unreal / 3d game engines.

    I compiled release and failed. Then compiled release with chaos demo in the folder (why would compiling the engine depend on the demo... not a good sign), then finally using frostic instruction (exactly except using VS2019). Thanks Frostic! Compiles fine, demo works, but not excellently. Caching example was "under construction."

    Pieces slide about the ground. Lots of shaking / vibrating (particularly on some of the marble columns). Oddly adding a sleep field seemed to make the fidgeting worse.

    Using in my own maps, I found creating geometry collections, fracturing, clustering, damage levels pretty easy and good looking. I'm getting excited. I quickly found that the performance hit for using chaos was very heavy. Dropped down to 1-2 FPS when I imported the example building. Quite possibly I'm making some sort of stupid mistake here, and I haven't done any optimizing, but this seems like it would take a ton of optimization and manual tuning to do something like the video demo -- and there was probably a lot of "cheating" in rigging the buildings for that exact sequence even if it wasn't prerendered.

    It crashes the engine intermittently if you try to interact with the chaos enabled objects.

    If using "separate process" preview or compiled package the chaos objects were invisible (on the demo map as well as on my own maps). Don't know why -- they were set to visible, and were visible in the "play in viewport" and other modes.
    On one map Chaos objects fell through ground -- not sure why.

    Haven't tried integrating niagra, or caching.
    I'm leaning towards dropping it, but if anyone has had good success or fixes let me know.

    Leave a comment:


  • replied
    Chaos enabled blank project compiles fine but gives error Assertion failed Cooked mesh != 0 in physxsupport.cpp. There is no other actors in scene,only default blank scene.

    Leave a comment:


  • replied
    Originally posted by frostic View Post

    did you get the source from the 4.25-plus repo?
    you need to use VS 2017 not 2019. on page 32 use my guide. it works perfect. as long as you use visual studio 2017 not 2019.
    I tried all sorts of 4.25 branches but no luck. I've been using 2019 so I'll uninstall it and give 2017 a go instead.

    you have to do setup.bat first. it will take an hour or 2 downloading the files. you cant generate files till that finishes.
    in your image it shows that some dependencies was not downloaded yet this is what your error is etc.
    Yes, I did setup first. I've been using source code since version 4.8 I think. Every version comes with some new bugs and issues!
    Last edited by Raed Abbas; 06-29-2020, 04:32 AM.

    Leave a comment:


  • replied
    Originally posted by Raed Abbas View Post

    The thing is I can't even generate files.
    you have to do setup.bat first. it will take an hour or 2 downloading the files. you cant generate files till that finishes.
    in your image it shows that some dependencies was not downloaded yet this is what your error is etc.
    Last edited by frostic; 06-28-2020, 10:41 PM.

    Leave a comment:


  • replied
    Originally posted by Raed Abbas View Post

    The thing is I can't even generate files.
    did you get the source from the 4.25-plus repo?
    you need to use VS 2017 not 2019. on page 32 use my guide. it works perfect. as long as you use visual studio 2017 not 2019.
    Last edited by frostic; 06-29-2020, 01:27 AM.

    Leave a comment:


  • replied
    Originally posted by frostic View Post

    DONT USE VS 2019.... USE VS 2017 it will compile. I tried 2019 and it won't compile for some odd reason. it gives hundreds of errors and thousands of warnings in 2019. i don't think its fully supported yet.
    The thing is I can't even generate files.
    Attached Files

    Leave a comment:


  • replied
    volvicTM odd it says you sent me a PM on the forums and it don't show a message.

    Click image for larger version

Name:	Screenshot_33.png
Views:	609
Size:	9.2 KB
ID:	1781955
    please try and message me here i don't know whats going on. all my inbox are now empty messages. i see they changed how we get notifications. i think they messed up recieving messages. they show up blank

    Leave a comment:


  • replied
    Originally posted by Raed Abbas View Post
    Hello,
    I'm struggling with this as well. Could someone please post their VS2019 setup/components?
    DONT USE VS 2019.... USE VS 2017 it will compile. I tried 2019 and it won't compile for some odd reason. it gives hundreds of errors and thousands of warnings in 2019. i don't think its fully supported yet.

    Leave a comment:

Working...
X