Announcement

Collapse
No announcement yet.

How to enable Chaos in 4.23

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by theProfessor View Post
    I just loaded into Github. Where is 4.23 source? I did compile 4.10. And it worked. It was a while ago.
    With the page from GitHub opened with Unreal Engine 4 repository, you need to select in the combobox called "branch" the value: 4.23 at the dropdown list. Once you select that you can clone or download as zip file and follow the build process described in the front page of the repository. Minimum Visual Studio release supported is the VS 2017, it is not necessary build with VS 2019.

    Leave a comment:


  • replied
    I just loaded into Github. Where is 4.23 source? I did compile 4.10. And it worked. It was a while ago.

    Leave a comment:


  • replied
    Originally posted by theProfessor View Post
    I am trying to use Chaos witn 4.23.1. Installed from the launcher. Will Chaos work with the 4.23.1 from the launcher? When I create geometry collection and then click on it Unreal crashes.
    It won't work from the version at launcher. You need to build the engine by source as the steps on the 1st post, and if you are not familiar with source build I recommend for you to wait when 4.23 releases.

    Leave a comment:


  • replied
    I am trying to use Chaos witn 4.23.1. Installed from the launcher. Will Chaos work with the 4.23.1 from the launcher? When I create geometry collection and then click on it Unreal crashes.

    Leave a comment:


  • replied
    > I built you with Chaos enabled as described, but it crashes when I start the engine.
    > It looks like the shaders are not loaded, but do you need anything else?

    This issue will be raised by loading WindowsMixedRealityPlugin at PostEngineInit phase. Normally it will be loaded at PostConfigInit.
    You can set EnableByDefault true in WindowsMixedRealityPlugin.uplugin to fix it temporarily.

    Leave a comment:


  • replied
    Originally posted by VictorLerp View Post
    Follow these steps to enable Chaos in 4.23 Preview:

    1. Download 4.23 Preview from Github (source build is required, and we recommend you grab the latest preview version)
    2. Add the following in the UE4Editor.Target.cs file:
    Code:
    bCompileChaos = true;
    BuildEnvironment = TargetBuildEnvironment.Unique;
    3. Make sure the following plugins are enabled:

    ChaosEditor
    Planar Cut
    Editable Mesh
    Geometry

    4. Build!

    NOTE: This will enable Chaos for all of your Blueprint and C++ projects. If you'd like to enable Chaos per project, you will have to add the lines under step 2 to your project's Target.cs file and create a C++ project (it won't work with a Blueprint project).

    Feel free to use this thread for discussions related to Chaos. We appreciate your feedback!

    I built you with Chaos enabled as described, but it crashes when I start the engine.
    It looks like the shaders are not loaded, but do you need anything else?

    Click image for larger version

Name:	20190714_14h42_01.png
Views:	4762
Size:	145.4 KB
ID:	1642134 ​​​​​​​

    Leave a comment:


  • replied
    VictorLerp do the three plugins, that you have listed as requirement (Planar Cut, Editable Mesh and Geometry), have anything to do with the new advanced programmatic mesh features that we can see on trello?

    Leave a comment:


  • replied
    I've tried to generate Geometry Collection asset but immediately editor crashed.
    Here is UE4Editor.Target.cs code I've changed.
    Code:
    using UnrealBuildTool;
    using System.Collections.Generic;
    
    public class UE4EditorTarget : TargetRules
    {
        public UE4EditorTarget( TargetInfo Target ) : base(Target)
        {
            Type = TargetType.Editor;
            bCompileChaos = true;
            BuildEnvironment = TargetBuildEnvironment.Unique;
            ExtraModuleNames.Add("UE4Game");
        }
    }
    }
    Last edited by tekktekk128; 07-13-2019, 09:02 AM.

    Leave a comment:


  • replied
    Originally posted by pstarace View Post

    Not having any luck adding this. Would you be able to post what your UE4Editor.Target.cs file looks like?

    Thank you,

    PatS
    Originally posted by VictorLerp View Post
    Follow these steps to enable Chaos in 4.23 Preview:

    1. Download 4.23 Preview from Github (source build is required, and we recommend you grab the latest preview version)
    2. Add the following in the UE4Editor.Target.cs file:
    Code:
    bCompileChaos = true;
    BuildEnvironment = TargetBuildEnvironment.Unique;
    3. Make sure the following plugins are enabled:

    ChaosEditor
    Planar Cut
    Editable Mesh
    Geometry

    4. Build!

    NOTE: This will enable Chaos for all of your Blueprint and C++ projects. If you'd like to enable Chaos per project, you will have to add the lines under step 2 to your project's Target.cs file and create a C++ project (it won't work with a Blueprint project).

    Feel free to use this thread for discussions related to Chaos. We appreciate your feedback!
    same for me.

    Leave a comment:


  • replied
    Originally posted by VictorLerp View Post

    Code:
    bCompileChaos = true;
    BuildEnvironment = TargetBuildEnvironment.Unique;
    Not having any luck adding this. Would you be able to post what your UE4Editor.Target.cs file looks like?

    Thank you,

    PatS

    Leave a comment:


  • replied
    Will this change anything regarding PhysX as we are actually turning on Chaos? or just using it as a plugin for fracture and threaded destruction at present.

    Leave a comment:


  • replied
    Is it just me, or fractured geometry collection objects are not getting simulated? They just hang on air...

    Leave a comment:


  • replied
    Originally posted by VictorLerp View Post
    Follow these steps to enable Chaos in 4.23 Preview:

    3. Make sure the following plugins are enabled:
    ChaosEditor
    Planar Cut
    Editable Mesh
    Geometry
    ohhh those look fun, I can't wait to try it out!

    Leave a comment:


  • replied
    Originally posted by VictorLerp View Post
    Follow these steps to enable Chaos in 4.23 Preview:

    1. Download 4.23 Preview from Github (source build is required, and we recommend you grab the latest preview version)
    2. Add the following in the UE4Editor.Target.cs file:
    Code:
    bCompileChaos = true;
    BuildEnvironment = TargetBuildEnvironment.Unique;
    3. Make sure the following plugins are enabled:

    ChaosEditor
    Planar Cut
    Editable Mesh
    Geometry

    4. Build!

    NOTE: This will enable Chaos for all of your Blueprint and C++ projects. If you'd like to enable Chaos per project, you will have to add the lines under step 2 to your project's Target.cs file and create a C++ project (it won't work with a Blueprint project).

    Feel free to use this thread for discussions related to Chaos. We appreciate your feedback!
    In Step 3, I can't find a plugin called Editable Mesh or Geometry. For ChaosEditor and PlanarCut, everything seems to already be set to true... except for "Installed," which is set to false.

    Leave a comment:


  • replied
    Originally posted by VictorLerp View Post
    (it won't work with a Blueprint project).
    Will it work with blueprint only projects at the final release ?

    Leave a comment:

Working...
X