Announcement

Collapse
No announcement yet.

Unreal Engine 4.23 Preview

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    4.23 P7 Vertex Snapping error.

    Comment


      What I hope is a tiny bit of good news for the engineers toiling away on 4.23, I'm making use of preview 7 for the betatest branch of my project. I can see that GI behaves differently, and ray tracing seems more stable. In 4.22 RT shadows would sometimes just fail. Randomly shadows wouldn't be there or they would only be there for some objects. Looks like that might be fixed now.

      I'm still developing in 4.22, then I drop the latest Content folder into a copy of the project for 4.23p7 and I'm able to generate a build in a few steps. The only issue I've run into is one map has a large number of foliage meshes which runs real slow in 4.23p7. But I saw from the siggraph talk that dealing with and supporting foliage in a RT scene is a known challenge, so I'm not worried about this. Everything is working pretty smoothly and the ease of transition to the preview build has allowed me to generate playable builds. Very happy with all this!
      Stay in the Light on Steam
      https://www.youtube.com/watch?v=EI1_pqHMSCk

      Comment


        Whenever I try to launch 4.23 I get this:

        Click image for larger version

Name:	Capture.PNG
Views:	4
Size:	5.5 KB
ID:	1656134

        I can't remember installing anything called "BlastPlugin". What is this? Can I just delete it? I think I'm just going to delete it.

        Comment


          Originally posted by remozseo View Post
          HDRIBackdrop: How can you increase the resolution in the viewport?

          When loading an 8k HDRI map, I would like to have full resolution.
          Inside the viewport it looks blurry and like low res.
          Same here, did you find a solution?

          Only the default example HDRI by Epic is sharp, and that's only 4K. What setting are we missing? Why didn't this work seamlessly?

          Also, the HDRIBackdrop complains that another skylight is active, but if I remove that skylight (and directional light), my entire scene becomes black. So this is RTX only? That's rather unfortunate if that's the case. I saw a Youtube video demonstration where a guy from Epic used this in a helicopter scene on an iPad. Again, I wonder what setting I am missing?

          Comment


            Originally posted by roberteker View Post
            Only the default example HDRI by Epic is sharp, and that's only 4K. What setting are we missing? Why didn't this work seamlessly?
            If I remember correctly, HDR images get set to maximum res of 256, by default. So even if it is 4k or something like that, you have to set the maximum size for the texture in the texture properties window (double click the texture).

            Freelancer Game Dev Generalist and Unreal Consultant | Portfolio
            Unreal products: Dynamic Picture Frames, Neo Kinect

            Comment


              Is any body have similar problem? In 4.23 Sample Pseudo Volume Texture doesn't work. A think, its related to texture management.
              https://forums.unrealengine.com/deve...volume-texture

              Comment


                is RT GT still broken in preview 7?
                TOUR of DUTY

                Comment


                  Originally posted by SonKim View Post
                  is RT GT still broken in preview 7?
                  I'm not sure what you mean by broken. I'm making use of it (as an option to turn on/off) and I think its fine in most cases with the right settings. I'm sure they don't consider it to be final or as good as it can be.
                  Stay in the Light on Steam
                  https://www.youtube.com/watch?v=EI1_pqHMSCk

                  Comment


                    Originally posted by Farshid View Post
                    Click image for larger version Name:	t1.jpg Views:	1 Size:	167.2 KB ID:	1656485







                    Click image for larger version Name:	t2.jpg Views:	1 Size:	150.5 KB ID:	1656486





                    i am very happy for the result (auto generated uv)

                    Comment


                      Originally posted by REC View Post

                      I'm not sure what you mean by broken. I'm making use of it (as an option to turn on/off) and I think its fine in most cases with the right settings. I'm sure they don't consider it to be final or as good as it can be.
                      Sorry currently busy with work so no time to test 4.23, someone mention it wasn't working in preview 5/6, can you post some screenshot of the feature(RT GI)? Is the sampling better(less noise in the denoiser)?
                      TOUR of DUTY

                      Comment


                        Originally posted by SonKim View Post
                        Sorry currently busy with work so no time to test 4.23, someone mention it wasn't working in preview 5/6, can you post some screenshot of the feature(RT GI)? Is the sampling better(less noise in the denoiser)?
                        It's there and working, but the denoiser still produces WIP results. The behavior does look different to me than 4.22.3, might be better in some cases, but I wouldn't say it looks perfect yet. I've settled on some particular settings that are giving me decent results until RTGI can be finished.
                        Stay in the Light on Steam
                        https://www.youtube.com/watch?v=EI1_pqHMSCk

                        Comment


                          Originally posted by REC View Post

                          It's there and working, but the denoiser still produces WIP results. The behavior does look different to me than 4.22.3, might be better in some cases, but I wouldn't say it looks perfect yet. I've settled on some particular settings that are giving me decent results until RTGI can be finished.

                          Thanks for posting the result, it does look great! Using 1 bounce or 2 ? In your opinion has the performance improved? I've give it a try once I got some free time.
                          TOUR of DUTY

                          Comment


                            Originally posted by NilsonLima View Post

                            I think you didn't read my previous answer at https://forums.unrealengine.com/unre...87#post1651087, but nowhere I affirmed Epic devs are struggling, but it is an effort that for the sanity has to be released on steps. Right now you can have raytracing working as solution, not 100%, but mixed. It is hard to do it? Yes, but the Troll Demo film was made with the tools released for the public, so it is a matter of finding how. I am not even worried about shadows right now regarding realtime raytracing, what really worries me is how is going to be handled the translucency at reflections, currently not working at all, and I have special needs into this matter.

                            Also, I don't agree that support tickets should be refrained, on the opposite, everyone finding an issue must report it. There are people at Epic to analyze the reports, check if reproducible and not repeated, and to redirect them to the devs behind the features being reported, so not the main devs themselves deal with screening out the issues, that would be insane.
                            Hi Nilson! It is very commendable for any of us to show our appreciation and defend the progress made, but do not worry. Epic is able to stand on their own and answer themselves when they have not made progress in a situation yet, if they want. So, if they have a fix coming (ie - opaque shadows in Raytracing), they can assist users to knowing what forward progress is being made. But they say/show the opposite (ie - it is an ongoing Beta).

                            Comment


                              Originally posted by SonKim View Post
                              Thanks for posting the result, it does look great! Using 1 bounce or 2 ? In your opinion has the performance improved? I've give it a try once I got some free time.
                              My game's default settings are:
                              GI Bounces: 1
                              GI Samples: 6
                              GI Upsampling: 25%

                              I give the player controls to adjust those (I'm finding not every upsample resolution is relevant). 25, 50 and 100% seem to give clear results in both perf and quality. The lower upsample rate of 25% definitely reduces quality and makes the result muddier, but it makes GI performance tolerable. 2 Bounces look better for sure but it comes at a noticeable performance cost. 6 Samples seems to keep the GI noise to a minimum along with the 25% rate but doesn't impact perf too much.

                              My scenes are all dynamically lit and Ray Traced. With GI off perf is around 90fps, with GI on (using the default settings) its more like 55-60. My hope is that GI will get better over time, maybe by the time UE reaches 4.24 they'll have all the quality and perf issues sorted out.

                              GI rendering quality looks better in 4.23 but the denoiser dance is still present. The noise dance is a different result than 4.22, and it may be improved. Right now I can just tell that its a different but still noisy result.

                              But I have seen RT performance is absolutely better. I have some scenes where a reflected image can consume the screen, and in 4.22 this would cut the framerate in half. In 4.23 there's no perf loss at all.
                              Stay in the Light on Steam
                              https://www.youtube.com/watch?v=EI1_pqHMSCk

                              Comment


                                Oculus quest strange things.
                                good day. I follow the instructions in this video: https://youtu.be/hEtu-ciPc7g I was able to successfully install the standard VR template on Oculus Quest, all the mechanics (tracking of the head and hands, buttons on the controller, and so on, work successfully), but there is one strange thing: when the application is launched for the first time, immediately after creating lunch through the menu, everything looks great. but after closing, disconnecting from the computer and reopening, some objects and hands become covered with green highlights.
                                What am I missing?

                                Comment

                                Working...
                                X