Announcement

Collapse
No announcement yet.

Unreal Engine 4.22 Released!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by darkxex View Post
    hello, someone could see why the sprites in paper2d are distorted in movement, when you do it from a blank project? the picture is paper2d with gravity.
    Looks like TemporalAA thats causing this? Try turning it of in the project settings->rendering

    Comment


      material compiling is extremely slow in compare with 4.15 version , sometimes freezes for some seconds. Using 6 core processor 16gb ram , gtx1060. Maybe there is something with workers. Any way to debug , stat somehow how much time different shaders takes to compile ?
      Last edited by Rapid_Wirehead; 05-05-2019, 05:44 PM.

      Comment


        Originally posted by Rapid_Wirehead View Post
        material compiling is extremely slow in compare with 4.15 version , sometimes freezes for some seconds.
        Did you also just install new Visual Studio 2019 by any chance? If yes, try uninstalling IncrediBuild. It was slowing down my shader compiling times significantly until I removed it.

        Comment


          I have a question to the developers. Why did you add a check inside TSceneCastCommon function that prevents to do a test with the same Start and End locations? How to get a Hit result now for box o sphere trace in one location?
          Last edited by blink7; 05-08-2019, 12:36 PM.

          Comment


            Originally posted by YuriNK View Post
            So, what about Steam Audio plugin? Seems it doesn't work.

            Not sure about another spatialization plugins.

            UPD. Works after rebuilding phonons.
            Do you mean exporting the scene again? I have problem with spatialized sounds not playing at all/some playing from time to time. The problem started with 4.22, I made a copy of my 4.21 project and suddenly almost all the sounds are not working anymore. Seems like the only one that works properly is a Modular Synth. I'm using 4.22.1 and the Steam Audio plugin, exporting the scene again doesn't help. I'd go back to 4.21 but that keeps crashing with Vive Wireless adapter.

            Anyone have any tips what to try?

            Also noticed the engine crashes and no crash reporter pops up when I press the Export as obj -opiton on Steam Audio panel.

            Comment


              I'm seeing a new memory leak in 4.22 on iOS. It might be related to the stats system, I'm not sure. But I just want to know if anyone else is seeing this, and/or if it affects any other platforms.

              I open a blank level, turn on "stat unit", and the "Mem" field continually goes up (about 10MB in about 15~20 minutes on an iPhone SE and an iPad Pro). When I open a different blank level (via OpenLevel node), the leaked memory is not getting freed. In other words, the leak just keeps getting bigger the longer the game is on.

              When I check the same setups in 4.20, "Mem" stays constant.

              Comment


                Hello i just bought a brand new RTX 2080ti, to test raytracing. Everything cool, but metallic/rough materials are very noisy. I tried increasing sampling, reducing ray distance, etc. but nothing seems to work. I think is something related with reflection, or material settings, maybe?

                Comment


                  Originally posted by FabioA View Post
                  Hello i just bought a brand new RTX 2080ti, to test raytracing. Everything cool, but metallic/rough materials are very noisy. I tried increasing sampling, reducing ray distance, etc. but nothing seems to work. I think is something related with reflection, or material settings, maybe?
                  Have you increased sampling for both Skylight (if you use it), all the postprocessing (reflections etc) and for raytraced GI (if you use that)? Also, in some cases it's necessary to increase samples for the lights you use as well.

                  Comment


                    Hi all!
                    Is anyone experiencing lighmap issues with static\stationary directional light + ISMs on Android ES3.1/Android Vulkan using UE4.22.1?
                    Or is it know issue?
                    Device:
                    Click image for larger version  Name:	LightmapES31_Device.jpg Views:	1 Size:	169.4 KB ID:	1619108

                    Preview:

                    Click image for larger version  Name:	PreviewES31_ISM.jpg Views:	1 Size:	388.5 KB ID:	1619109

                    In case of not using ISMs, lightmaps are correct on device.
                    Last edited by Astartis; 05-14-2019, 07:29 PM.

                    Comment


                      Every time I open material editor in my VR project (Instanced stereo on, forward shading on), I get this in my output log:

                       
                      Spoiler


                      EDIT. Fixed: https://issues.unrealengine.com/issue/UE-74673
                      Last edited by YuriNK; 05-19-2019, 01:26 AM.
                      Marketplace: Vive Mocap Kit / Fingers Solver / VR IK Body Solver / Subtitles to LipSync / Dialogue System with Character Animation
                      And random stuff at Youtube

                      Comment


                        Originally posted by OneReality_Main View Post

                        Have you increased sampling for both Skylight (if you use it), all the postprocessing (reflections etc) and for raytraced GI (if you use that)? Also, in some cases it's necessary to increase samples for the lights you use as well.
                        I'll try, but someone told me that is not possible at the moment to have a noise free result when using rough reflection. Anyway i'll give it a try, thank you.

                        Comment


                          Originally posted by Astartis View Post
                          Hi all!
                          Is anyone experiencing lighmap issues with static\stationary directional light + ISMs on Android ES3.1/Android Vulkan using UE4.22.1?
                          Or is it know issue?
                          Device:
                          Click image for larger version Name:	LightmapES31_Device.jpg Views:	1 Size:	169.4 KB ID:	1619108

                          Preview:

                          Click image for larger version Name:	PreviewES31_ISM.jpg Views:	1 Size:	388.5 KB ID:	1619109

                          In case of not using ISMs, lightmaps are correct on device.
                          I have same issue.

                          For Editer, there is no error message, but on Android "Lighting Needs to be Rebuilt" message.

                          Here are log messages for "DumpUnbuiltLightIteractions"


                          [2019.05.16-10.26.27:643][447]DumpUnbuiltLightIteractions
                          [2019.05.16-10.26.27:643][447]Lights with unbuilt interactions: 6
                          [2019.05.16-10.26.27:643][447] Light DirectionalLight3_1
                          [2019.05.16-10.26.27:643][447] Light PointLight2
                          [2019.05.16-10.26.27:643][447] Light PointLight3
                          [2019.05.16-10.26.27:643][447] Light PointLight4
                          [2019.05.16-10.26.27:643][447] Light PointLight5
                          [2019.05.16-10.26.27:643][447] Light PointLight6
                          [2019.05.16-10.26.27:643][447]
                          [2019.05.16-10.26.27:643][447]Primitives with unbuilt interactions: 14
                          [2019.05.16-10.26.27:643][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_7
                          [2019.05.16-10.26.27:643][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_9
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_8
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_6
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_5
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_4
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_3
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_2
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_13
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_10
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_1
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_0
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_12
                          [2019.05.16-10.26.27:644][447] Primitive FoliageInstancedStaticMeshComponent /Game/Environment/BG_Levels/Plant_Level_BG_3x3.Plant_Level_BG_3x3:PersistentLevel.InstancedFoliageActor_0.FoliageInstancedStaticMeshComponent_11
                          [2019.05.16-10.26.27:644][447]LogSlate: FSceneViewport::OnFocusLost() reason 2

                          Comment


                            Ignore all the below - my post process volume wasn't unbounded


                            I'm getting a strange situation where the GI is only showing when the camera is in a certain position - in this case somewhere behind the light. If not in that position it vanishes. I've tried restarting the editor and I have exposure control off. In the pic you can see that in the middle shot it's there and then in the other two positions (which are very close) it's not.

                            Last edited by KimLaughton; 05-17-2019, 10:05 AM.

                            Comment


                              Awesome release! Thank you.

                              Comment


                                For the old and the new gods fix ALL the Blueprints Traces(multi, line, sphere, etc), they are not working if you give the same Start and End.

                                Comment

                                Working...
                                X