Announcement

Collapse
No announcement yet.

Unreal Engine 4.21 Released!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by cbkitt321 View Post
    How do you download this Ureal Fix. Where is the link?
    Thanks.
    You open the Epic Launcher.

    Leave a comment:


  • replied
    How do you download this Ureal Fix. Where is the link?
    Thanks.
    Last edited by Jezcentral; 06-14-2019, 05:50 AM. Reason: Took out email address.

    Leave a comment:


  • replied
    • New: If you create a widget using CreateWidget from inside another widget, we now check if the world context object is a widget. If so, we use it as the outer source for the widget, thus ensuring things like design time flags are properly carried over.
    I am curious about the fix for this. I'm currently working on a project that shipped on 4.19.2 and we are running into issues around something of this nature. As we are not quit ready to switch to 4.21 (it is planned in the near future to switch to this or 4.22) and we have an update we need to ship, I'd like to back port the change if possible. Just need to know which commit it happened in.

    Leave a comment:


  • replied
    Do you access the page through file:// protocol? If yes, try access the page through http:// protocol

    Leave a comment:


  • replied
    Nothing to see here...
    Attached Files
    Last edited by VKleinMP; 03-12-2019, 09:47 AM.

    Leave a comment:


  • replied
    Originally posted by jfharp125 View Post
    Having trouble running a steam dedicated server with 4.20+. Steamworks says (pertaining to development builds) to create a steam_appid.txt in the exe location with your appid. Doing this with 4.19.2 worked fine...Steam API initialized fine for a dedicated server without the need of the steam client running in the background. But for 4.20+ Steam API failes to initialize. I'm currently trying to debug the engine code (Online Subsystem, et al.) to find out what changed caused the halt.

    Anyone else having this trouble?
    Found the problem...the SteamServerInit was failing, I needed to copy the steam dlls into the exe location to fix...perhaps there is a more proper way to fix that I'll research later. Didn't have to do this for 4.19.2.

    Nice to see the authentication stuff working from the log. I'm curious as to how that works. Is it that the client generates the auth ticket from the user who has access to the game on steam, then the server will generate an auth ticket for the user wanting the join and checks it's ticket with the one sent from the client and if they match then the client can join? Is it something like that? I'm curious to test it using a user with the game package running with the steam client in the background who does not have permission for the game (i.e. has not bought it) to see if the ticket will get rejected from the server in that case.
    Last edited by jfharp125; 03-11-2019, 05:31 PM.

    Leave a comment:


  • replied
    Epics Unreal engine 4... best 'game' i've ever played... looking forward to 4.22 with two new 'free' levels, control rigs linked to sequencer (i was just thinking of making something like that) and niagara... i've run out of challenges in life, i can only challenge myself now (life was wayyy too easy)... thanks Epic for all the good times... steve

    happy international womens day to all of you... i can't keep quiet (no no no) (smile)...

    Leave a comment:


  • replied
    Originally posted by NextWorldVR View Post
    Does anybody know how to FORCE this (what I have been told is "automatic") update/Hotfix 4.21.2 to go ahead and UPDATE or HOTFIX?

    Automatic?!! NOT SO MUCH,...
    Assuming you have used the Epic Games Launcher for your initial installation of the Unreal Engine 4.21, updating to Hotfixes follows a similar method.
    • Open the Epic Games Launcher
    • You may immediately notice the yellow button that normally says "Launch" now says "Update". If so, just click it.
    • Otherwise, click on the "Unreal Engine" option on the left sidebar, and then click on the "Library" option on the top bar.
    • You should see your 4.21 engine slot here. If it is not already listed as 4.21.2, then it should give you the option to update.

    Leave a comment:


  • replied
    Does anybody know how to FORCE this (what I have been told is "automatic") update/Hotfix 4.21.2 to go ahead and UPDATE or HOTFIX?

    Automatic?!! NOT SO MUCH,...

    Leave a comment:


  • replied
    Originally posted by KingVario View Post
    Is there any chance Epic will do an improved Roadmap the current one on Trello is abandoned almost?
    It doesnt even have to be full feature plans just major versions aproximate dates and biggest feature.
    Originally posted by Unrealier View Post
    I concur. For some masochistic reason, I keep checking the Trello roadmap about twice a week, even though it hasn't been updated in months now (latest update dates: November 18 and October 22). Either start updating it properly or close the whole thing down. Because right now, the engine versions are being updated more often than that roadmap is.
    Just to make a point about how bad the things are, this post was made exactly a month ago. Since then, UE had an hotfix update and new version preview, and the Trello roadmap still hasn't received a single edit since November 18—full three months ago. Fix it or get rid of it. For anyone who doesn't follow UE's development closely, it looks like abandonware; and for anyone who does, it offers no useful information whatsoever.

    Leave a comment:


  • replied
    Having trouble running a steam dedicated server with 4.20+. Steamworks says (pertaining to development builds) to create a steam_appid.txt in the exe location with your appid. Doing this with 4.19.2 worked fine...Steam API initialized fine for a dedicated server without the need of the steam client running in the background. But for 4.20+ Steam API failes to initialize. I'm currently trying to debug the engine code (Online Subsystem, et al.) to find out what changed caused the halt.

    Anyone else having this trouble?

    Leave a comment:


  • replied
    i can't find "Debug Canvas in Layer" under the rendering tab or in other tab in 4.21.2... it's been removed?
    it's there in the 4.19 release

    Leave a comment:


  • replied
    Originally posted by RVillani View Post

    Is that a custom event you created or something in the engine?
    Engine :-) Quick Link below:

    https://api.unrealengine.com/INT/Blu...get/index.html

    Leave a comment:


  • replied
    Originally posted by Subressor View Post
    Hi,

    I recently upgraded to 4.21.2 and my 'Event OnEndViewTarget' is no longer triggering when I close my PIE session or any in-editor testing.

    Has anybody else had this issue? Is there a setting or workaround? Or should I submit a bug report?

    Thanks,
    Is that a custom event you created or something in the engine?

    Leave a comment:


  • replied
    Hi,

    I recently upgraded to 4.21.2 and my 'Event OnEndViewTarget' is no longer triggering when I close my PIE session or any in-editor testing.



    Has anybody else had this issue? Is there a setting or workaround? Or should I submit a bug report?

    Thanks,

    Leave a comment:

Working...
X