Announcement

Collapse
No announcement yet.

Unreal Engine 4.21 Released!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #76
    Originally posted by lotodore View Post


    I have already reported the UI button issue on 18 November as "Case # 00081057: UMG button events do not work correctly if "use mouse for touch" is enabled". I included a sample project. It was just pointed out to me that this was already entered as . However, UE-66823 is marked for release 4.20.3. Instead, the issue I'm reporting is definitely a regression.

    I think you UI Button issue is linked also to : https://issues.unrealengine.com/issue/UE-50329. There is clearly an issue with the "use mouse for touch" in the Events.
    I bet both are linked to the same root cause.


    As a work around, try to set to false: IsFocusable

    I agree that Pressed & release Events should not be impacted by the "Use mouse for touch".

    UE-50329 have some repro step and the answer hub contains also repro. I hope they will fix it... it is there since months (4 versions).

    Comment


      #77
      I has a some problem with my project in 4.21 (from 4.20). Below you can see cannons that a skeletal meshes with anim bp. I setting up then during runtime by cpp code.
      Below are PIE with DirectX, all seems fine.

      Click image for larger version  Name:	PIE.png Views:	1 Size:	109.0 KB ID:	1557672
      But when I launching mobile preview or enabling android preview (ES2) cannons disappears, they just didn't want to setup for some reason.




      Click image for larger version  Name:	MobilePIE.png Views:	1 Size:	86.2 KB ID:	1557671

      Used Debug in VS for check what went wrong, but code work fine.
      Last edited by GloryOfNight; 11-30-2018, 10:31 AM.

      Comment


        #78
        Regarding the supposed Oculus Avatar support mentioned in the release notes, on Oculus' documentation they mention that Avatars are not supported in Unreal 4.21. See here: https://developer.oculus.com/documen...rs-gsg-unreal/

        Requirements

        Note: Avatars are not yet supported on the newly released Unreal Engine 4.21
        • Unreal Editor 4.20
        I noticed the plugin is only whitelisted for Win64, and it won't build for me for Gear VR/Go.

        Could a dev clarify whether this plugin is properly supported in 4.21 right now? Just it seems like conflicting info at the moment.

        Comment


          #79
          Originally posted by Mosel3y
          Could a dev clarify whether this plugin is properly supported in 4.21 right now? Just it seems like conflicting info at the moment.
          Hey Mosel3y,

          I've pinged one of the guys on our team that works with XR/VR. He's looking into it for any additional details. Sorry for any confusion that has been caused. We'll let you know what we find out.
          Tim Hobson | Learning Resources | Epic Games
          UE4 Documentation

          Comment


            #80
            Paper2D Flipbooks used in UMG widgets were broken for VR with instanced stereo rendering a while ago and flagged as "won't fix" but there was a work around to set the material type to "translucent". Unfortunately now the workaround is also broken in 4.21.

            I'm investigating the Paper2D rendering code to see why that is. If I manage to find any more useful information I will make a post in the Paper2D thread with my findings (if I can fix it even better but I'm fairly new to Unreal's rendering backend so I can't say I'll be able to do it with confidence).

            UMG possible doesn't need to be involved. I need to run some more tests to get a more thorough report.

            Here is an answer hub thread which contains the workaround : https://answers.unrealengine.com/que...ent-in-vr.html

            and here is the bug link : https://issues.unrealengine.com/issue/UE-37611

            Thanks

            Comment


              #81
              When I selected the arkit plug-in, the packaging was wrong. Why can't be packaged the ue421 arkit template?
              Attached Files

              Comment


                #82
                Today, after this update the launcher looks like this

                Click image for larger version  Name:	Snapshot-20181203.png Views:	1 Size:	359.0 KB ID:	1558463

                Click image for larger version  Name:	Snapshot-20181203-2.png Views:	1 Size:	23.5 KB ID:	1558466

                And it asked me to install Unreal Tournament at startup...
                All controls now VERY small. Menu exists, but it's 20 pixels at left corner.
                I can't start editor.
                I've deleted all config folders, but it's still the same.
                Even after reinstallation this problem is not gone.

                What I need to do to fix that?

                PS. Mac OS 10.12.6 (iMac 27")
                Last edited by igrodel; 12-03-2018, 06:42 AM.

                Comment


                  #83
                  Thank you Epic, this is the best Unreal Engine version release in years! I love the following; Replication Graph, Linux Defaults to Vulkan Renderer, Linux Media Player, Linux Crash Report Client GUI, & Experimental Virtual Texturing support. Please continue with this momentum in those categories in future releases!

                  Comment


                    #84
                    hey guys, just wanted to install 4.21, but i can't add it to the launcher (only the 4.21 preview 4 shows up)

                    Comment


                      #85
                      Hi the new launcher is bugged. I had 4.21 engine release installed and now its showing preview 4 like other people said. The engine does work properly its showing 4.21 but the launcher is not.

                      Comment


                        #86
                        Hi all.

                        Yes, the recent Launcher update is causing UE 4.21 to display as a "Preview", but this is a visual issue with the Launcher only (it has no effect on UE 4.21), and should be resolved soon. For any feedback related to the Launcher update please share it in this other forum topic: https://forums.unrealengine.com/unre...-beta-launcher, and any issues with the Launcher should be reported to our Launcher support team.

                        Thank you.
                        Stephen Ellis | Enterprise Program Coordinator

                        Comment


                          #87
                          I found fix for the problem that I described before.
                          This launcher have a bug with localization.
                          If switch to english and restart launcher, GUI problem will gone.

                          PS. It's not a real fix, because, if I switch language back, I'll see this GUI problem again...
                          Last edited by igrodel; 12-03-2018, 04:59 PM.

                          Comment


                            #88
                            igrodel Hey there, sorry to hear about the issue you're having. Do you by chance have your primary or secondary language set to Polish or Russian on MacOS?
                            Last edited by Kalvothe; 12-04-2018, 10:48 AM.

                            Comment


                              #89
                              Originally posted by Kalvothe View Post
                              igrodel Hey there, sorry to hear about the issue you're having. Do you by chance have your primary or secondary language set to POlish or Russian on MacOS?
                              Yes, Russian is primary.
                              Last edited by igrodel; 12-03-2018, 07:52 PM.

                              Comment


                                #90
                                found another issue: i was hitting exactely 16 texture samplers in 4.18. now in 4.21 when using the same material it crashes cause its suddenly using more than 16! i*m using forward rendering, so its crucial to me edit: i solved the issue by using more shared samplers. but can one elaborate on why 4.21 needs one more sample?
                                Last edited by schauk; 12-04-2018, 11:21 AM.

                                Comment

                                Working...
                                X