Announcement

Collapse
No announcement yet.

Unreal Engine 4.21 Preview

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    For some reason I can't find 4.21 in my launcher. Is there a checkbox I have to tick in my account or any setting in order to see the latest version? Any help would be appreciated

    Comment


      4.21 Preview 4 doesn't cook all assets for me. Some items referenced by CDO Constructors are not cooked and cannot be found.

      Even if I force-cook all packages, it still doesn't work.

      Comment


        Originally posted by Healthy Nuts View Post
        For some reason I can't find 4.21 in my launcher. Is there a checkbox I have to tick in my account or any setting in order to see the latest version? Any help would be appreciated
        No, nothing special is needed. I suggest exiting and restarting the Launcher. Make sure it actually exits, and doesn't simply minimize to the system tray.
        Stephen Ellis | Enterprise Program Coordinator

        Comment


          Originally posted by Stephen Ellis View Post

          No, nothing special is needed. I suggest exiting and restarting the Launcher. Make sure it actually exits, and doesn't simply minimize to the system tray.
          I killed Epic Launcher from the Task Manager and when I open it, the problem still occurs. I also tried to shutdown my machine and it didn't work either. Lastly I tried to uninstall and reinstall Epic Game Launcher, and it's still not showing up for some reason.

          Below is my setting and the version of Epic Launcher:
          Attached Files
          Last edited by Ofandir; 10-31-2018, 02:49 PM.

          Comment


            Originally posted by Ofandir View Post

            I killed Epic Launcher from the Task Manager and when I open it, the problem still occurs. I also tried to shutdown my machine and it didn't work either. Lastly I tried to uninstall and reinstall Epic Game Launcher, and it's still not showing up for some reason.
            This case is a mystery to me. It should be as simple as adding a new Engine slot on the Library page, and choosing the 4.21 Preview from the list of versions. I recommend you contact our Launcher support team for a deeper investigation. https://epicgames.helpshift.com/a/epic-launcher/

            Cheers
            Stephen Ellis | Enterprise Program Coordinator

            Comment


              Originally posted by GrumpyNZ View Post
              Hey guys, just checked out the Vehicle Template on 4.21, movement is a bit jittery on the client.
              Cheers

              When I opened my project and put vehicles in the map they went crazy and flew off, but I figure that'll be some settings or something that need changing, since the vehicle template looks pretty good replication wise.

              Big fan of the new checkbox in physics replication too cool.

              Edit: Can confirm after more in depth testing the fixes to the vehicles are excellent , a little jittery but no doubt that'll be to do with some fine tuning etc.

              Thanks so much for this update guys, it's a masterpiece!

              HOO-RAH!
              I have the same problem with my project, the client has problems with the movement

              Comment


                Originally posted by Andrea_92 View Post
                I have the same problem with my project, the client has problems with the movement
                What kind of problems? Desynced movement, jitter, flipping upside down?

                I found that to get my vehicles working properly in existing projects I just had to uncheck the "Replicate Physics to Autonomous Proxies" on any components that weren't the root Skeletal Mesh. Keeping it checked true on the root component seems to work a treat, everything is kept in sync across server and multiple clients.

                Comment


                  Hi! Please, fix this: https://answers.unrealengine.com/que...ote-build.html

                  Comment


                    Originally posted by JohannHirsch View Post
                    Did you submit a bug report using appropriate form?

                    Comment


                      Can UE4.21 interfere with existing UE4.20 installation on regards of Android (Daydream VR) builds?
                      I started to get crashes in 4.20 builds seemingly out of nowhere. I suspect this happened after I tried 4.21 preview.
                      Details here: https://answers.unrealengine.com/que...ter-15sec.html

                      Comment


                        Originally posted by GrumpyNZ View Post

                        What kind of problems? Desynced movement, jitter, flipping upside down?

                        I found that to get my vehicles working properly in existing projects I just had to uncheck the "Replicate Physics to Autonomous Proxies" on any components that weren't the root Skeletal Mesh. Keeping it checked true on the root component seems to work a treat, everything is kept in sync across server and multiple clients.
                        This is my movement problem on client, in preview 3 it worked perfectly https://youtu.be/adYc054zsbs
                        Last edited by Andrea_92; 11-03-2018, 11:50 AM.

                        Comment


                          Have you tried playing with the replication settings in the physics part of your project settings? I saw a little jitter on mine but not to that degree.

                          Comment


                            Originally posted by GrumpyNZ View Post
                            Have you tried playing with the replication settings in the physics part of your project settings? I saw a little jitter on mine but not to that degree.
                            Yes, of course, my settings are these

                            Click image for larger version

Name:	Immagine2.jpg
Views:	112
Size:	366.5 KB
ID:	1547288Click image for larger version

Name:	Immagine.jpg
Views:	119
Size:	372.4 KB
ID:	1547287

                            Comment


                              Originally posted by diamond3 View Post
                              Can UE4.21 interfere with existing UE4.20 installation on regards of Android (Daydream VR) builds?
                              I started to get crashes in 4.20 builds seemingly out of nowhere. I suspect this happened after I tried 4.21 preview.
                              Details here: https://answers.unrealengine.com/que...ter-15sec.html
                              update: build seems to be crashing on Android 9 only. It works on Android 8.

                              Comment


                                Any ETA on 4.21 Launch Stephen Ellis ? Obviously rather not have it rushed, but I'm sure there's gotta be some ETA out there (or at least how many more previews)

                                Thanks.
                                Website/Portfolio: http://www.VictorBurgosGames.com

                                Join me on stream: https://www.twitch.tv/BurgosGames for UE4 Game Dev. If you need help, just stop by and ask!

                                Wishlist Neko Ghost, Jump! a 2D/3D Puzzle-Platformer : https://store.steampowered.com/app/1...ko_Ghost_Jump/

                                Comment

                                Working...
                                X