Announcement

Collapse
No announcement yet.

Unreal Engine 4.20 Released!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by CriDos View Post

    Fix project files generation of VS 2017, VS Code and CLION for Windows.
    https://github.com/CriDos/UnrealEngi...0.2_hotfix_ide
    https://github.com/CriDos/UnrealEngi...0.2_hotfix_ide
    This works perfectly, thanks so much for posting this, I appreciate it!!!!!

    Edit: Now that I have actually been able to use CLion, I gotta say, using it with Unreal is super awesome...the code inspections are great. It already pointed out a couple things I never saw that Visual Studio never said a word about.
    Last edited by CoolOppo; 08-25-2018, 06:58 PM.

    Comment


      I'm having a widget bug in 4.20.2. It seems to be a regression from 4.19, and I cannot reproduce it using a small project, so I'm posting it here: Alignment of custom widget blueprints within custom widget blueprints is often broken on Linux (as well as on Android). All is fine on Windows and in the editor preview, but Linux/Android align some widget menus completely false.

      I've spent several hours trying to find out which specific alignment/whatever is causing this bug, but this is a very tedious task, as it takes forever to deploy on Linux or Android from a Windows dev PC. Invalidating etc. the widgets does not seem to help.

      So basically, complex widget combinations are broken on Linux and Android.

      But I have found a workaround: Add widget to viewport, remove from viewport, add to viewport again:
      Click image for larger version

Name:	linux_workaround.png
Views:	9
Size:	33.8 KB
ID:	1520969

      Afterwards widgets are properly aligned on Linux.

      Comment


        I am experiencing a bug in 4.20.2 (and since the launcher release of 4.20) where paper2D sprites will not render in VR correctly. They will only render in the left Eye. This has been an issue in previous engine versions but has worked correctly if using translucent materials.

        In UE4.20 it doesn't seem possible to render Paper2d flipbooks in VR with instanced stereo enabled. Only the left eye is rendered, even if using the opaque, masked or translucent material domains.

        Is this a known issue? A search has come up empty. I have filed a bug report.
        Michael Wentworth-Bell
        Espire 1: VR Operative: Espire1.com
        Melbourne, Australia

        Comment


          Originally posted by lotodore View Post
          .... and I cannot reproduce it using a small project, so I'm posting it here: .....
          You still have to post it using bug report form.

          Comment


            Dear Epic ( Amanda.Bott Kalvothe ), any ETA on a fix for https://issues.unrealengine.com/issue/UE-62310 (and 4.20.3 release) ?

            Comment


              Originally posted by motorsep View Post
              Dear Epic ( Amanda.Bott Kalvothe ), any ETA on a fix for https://issues.unrealengine.com/issue/UE-62310 (and 4.20.3 release) ?
              We do not have an exact date for 4.20.3 at this time.

              Comment


                So glad there is finally an area light!
                | QuinnVR | Portfolio | Twitter |

                Comment


                  Why is sample rate private?

                  "error C2248: 'USoundWave::SampleRate': cannot access protected member declared in class 'USoundWave'"

                  How/why/wut, I don't know how to set the sample rate now!
                  ______________________________________________
                  https://www.facebook.com/madhousesoftware
                  Where sanity is a virtue

                  Comment


                    Originally posted by MADHOUSE View Post
                    Why is sample rate private?

                    "error C2248: 'USoundWave::SampleRate': cannot access protected member declared in class 'USoundWave'"

                    How/why/wut, I don't know how to set the sample rate now!
                    What about SetSampleRate() method in USoundWave?

                    Comment


                      Originally posted by Cheshire Dev View Post

                      What about SetSampleRate() method in USoundWave?
                      Thanks!! <3
                      ______________________________________________
                      https://www.facebook.com/madhousesoftware
                      Where sanity is a virtue

                      Comment


                        any idea when all the intellisense issues with 4.20 will be fixed? I was told 4.20 introduced many issues with intellisense...For example...

                        "DECLARE_DYNAMIC_MULTICAST_DELEGATE(FOnOpenRequest);

                        UPROPERTY(BlueprintAssignable)
                        FOnOpenRequest OnOpenRequest;
                        "

                        OnOpenRequest wont show up in autocomplete/ intellisense in visual studio.

                        Comment


                          Have a pretty big issue with large worlds and the directional light not casting any shadows past a certain point in 4.20. 4.19 did not have this issue > https://answers.unrealengine.com/que...4207/view.html

                          Comment


                            Originally posted by nyxagamemnon View Post
                            Have a pretty big issue with large worlds and the directional light not casting any shadows past a certain point in 4.20. 4.19 did not have this issue > https://answers.unrealengine.com/que...4207/view.html
                            File official bug report using official bug report form.

                            Comment


                              Has anyone found a way to create a location event at the end of a loop. The old way of using a death event doesnt seem to be present in the niagara setup. It would be pretty beneficial be able to add an emmiter in the same place as the last particle in the previous emmiter. Alas no one has posted documentation on that just yet

                              any help would be greatly appreciated

                              Comment


                                Originally posted by kurylo3d View Post
                                any idea when all the intellisense issues with 4.20 will be fixed? I was told 4.20 introduced many issues with intellisense...For example...

                                "DECLARE_DYNAMIC_MULTICAST_DELEGATE(FOnOpenRequest);

                                UPROPERTY(BlueprintAssignable)
                                FOnOpenRequest OnOpenRequest;
                                "

                                OnOpenRequest wont show up in autocomplete/ intellisense in visual studio.
                                nm i think i just needed to regenerate the visual studio project files

                                Comment

                                Working...
                                X