Announcement

Collapse
No announcement yet.

Unreal Engine 4.20 Released!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by HeliaXDemoN View Post
    Ok, I am crazy or Niagara makes some basic stuff super time consuming? To create a simple particle with 3 emitter you need:

    • Create a Niagara System
    • Create 3 Niagara Emitters
    • Add the 3 Niagara Emitters inside the Niagara System

    And if I need to add 1 more Emitter I need create another emitter outside the Niagara System and Add it to the the System.

    Add a way to create Emitter inside the Niagara System that go inside the Niagara System folder. Them you create a Niagara System and add 3 emitters inside the system.
    It's time consuming now because the infrastructure isn't yet in place. Long term vision, we have a body of emitters that are 75% of the way towards what you want. You can just pull them in and tweak the last 25% that you need to complete your effect. Until then, you can just pull the same default emitter in 25 times and tweak each instance to match what you want. You can add/disable modules in systems, making it possible to do most of what you want inside a system. Because we maintain inheritance, systems track what happens to the original emitter and synchronize with those changes.

    Comment


      Looking great, But there is an issue on my side (using the Source version)
      I can't see the Translate or Scale Widget in the Editor. It only shows if I'm using Wireframe mode. The rotation one seems to work.

      Using UE 4.20 source (release). With Geforce GTX 1080 (Driver: 398.36).

      Tested with preview Shader Model 5 and 4, same results.

      Comment


        Originally posted by motorsep View Post

        "Backlogged" status usually means it's never going to be fixed
        This bug is making it really hard for coders. It has 64 votes too. I really think they should be doing something about it.
        Last edited by Balgy; 07-27-2018, 01:30 PM.

        Comment


          UPDATE!

          The 4.20.1 Hotfix is now live! This Hotfix includes important fixes for importing FBXs and crashes with forward shading.

          Fixed in 4.20.1
          Fixed! UE-59351 Installed Build Code First Person template fails to Launch with System.IO.DirectoryNotFoundException for AudioMixerAudioOut\AudioMixerAudioOut.precompiled during Build step
          Fixed! UE-62017 Cannot debug projects in the Editor if it uses a unique target build environment
          Fixed! UE-61955 SwarmCoordinator.exe is missing from binary build
          Fixed! UE-62001 BuildGraph cannot create installed build for Windows
          Fixed! UE-61937 nDisplay monoscopic broken on GL3/4
          Fixed! UE-62007 Blueprint nodes can have false error labels when loaded
          Fixed! UE-62144 Unable to use Steam Sessions with a source built editor from Github
          Fixed! UE-62079 FInBunch.bClose flag is not copied in FInBunch(FInBunch &InBunch, bool CopyBuffer)
          Fixed! UE-61946 Arrays on multicast events called from the server are not passed to clients
          Fixed! UE-62033 Linux: callstack unwinding is broken on ARM
          Fixed! UE-61530 Need an option to suppress "Register Unreal Engine file types?" in Setup.sh
          Fixed! UE-50281 Arch64 and ARM servers fail to open on the Linux machines
          Fixed! UE-61951 Undersampling bug in Diaphragm DOF on non HLSL compiler
          Fixed! UE-61795 Diaphragm DOF crashes with forward shading and MSAA
          Fixed! UE-62096 Crash when using StepToNextShot / PreviousShot with sequencer
          Fixed! UE-61728 Burnin for ShotFrame and CurrentShotLocalTime is incorrect
          Fixed! UE-61707 Geometry cache track doesn't always update
          Fixed! UE-61706 Animations don't update on the first frame of shots
          Fixed! UE-62067 Can't import FBX animations
          Fixed! UE-62064 Generate Lightmap UVS Doesn't Update the Lightmap Coordinate Index
          Fixed! UE-61841 Access Violation referencing a Material Function containing a CurveAtlasRowParameter
          Fixed! UE-62099 Namespaces are not removed when importing Skeletal Meshes from FBX, and breaks the importing of referenced Animations
          Fixed! UE-61762 Virtual Camera Global Boom influenced by motion scale when moving forward with device at an angle

          REMEMBER: Please report any new bugs you find by following the How To Report a Bug Guide

          Comment


            Originally posted by Amanda.Bott View Post
            Fixed! UE-62067 Can't import FBX animations
            Oh thanks!


            UE4 Development [TARTARUS | Object Inspection System | Pattern Lock]
            Let's Connect [Twitter]

            Comment


              Something strange, I started the installation process and next noticed a new version of the Launcher was available, updated it and now show me only 4.20.1 Preview 5.
              This is the right one?

              Comment


                Originally posted by Amanda.Bott View Post
                Fixed! UE-61946 Arrays on multicast events called from the server are not passed to clients
                Thanks, was wondering if this was a bug or if I needed to rework something in my event.

                Comment


                  UMG has an issue with a double outline on text that has a shadows enabled. I posted this in the questions section but haven't heard back. Please see before and after image.

                  Victor "Vexar" Mercieca
                  Twitch Channel
                  Artstation
                  Youtube Channel

                  Comment


                    In 4.20 I have got a bug with tessellation in viewport.
                    In closeup it look ok, but when I zoom out i get black outlines and another tessellation bugs.
                    Same scene tested in 4.19 and works ok.

                    https://www.youtube.com/watch?v=91Ni...ature=youtu.be

                    Comment


                      I hope UE-62069 gets added in one of these hotfixes since I noticed it got fixed. It's a huge issue for me and having to wait until 4.21 for that specific fix would be a bummer.

                      Comment


                        Am I imagining things or does the editor launch a bit faster with 4.20.x?

                        Comment


                          Originally posted by SirToxe View Post
                          Am I imagining things or does the editor launch a bit faster with 4.20.x?
                          It did for me initially, but then it slowed down to about 4.19.2 loading speed when I opened saved project (which was a TPS template saved as a project).

                          Comment


                            For 4.20 , There is strange bug .

                            When I start VoiceCapture inside android , runtime permission shown up and I can see captured data after the app start , however if I close the app and run it again, VoiceCapture state become OK but No voice data . 0 bytes .

                            I tried to debug that with android studio profiler , and I found this error pop up when the app start for 2nd time : E/AudioRecord(24604): start() status -38 , and then bytes are always 0 . I dont know even a right description for this case to report a bug about it . could anyone help .

                            Here is the full LOG
                            Attached Files

                            Comment


                              UE-61706 - Animations don't update on the first frame of shots......Thank you!!!

                              Comment


                                Originally posted by KmburTG View Post
                                Looking great, But there is an issue on my side (using the Source version)
                                I can't see the Translate or Scale Widget in the Editor. It only shows if I'm using Wireframe mode. The rotation one seems to work.

                                Using UE 4.20 source (release). With Geforce GTX 1080 (Driver: 398.36).

                                Tested with preview Shader Model 5 and 4, same results.

                                Oh, I have the exact same problem with 4.19! I already thought its something wrong only for me, great to hear you have the same problem.

                                Does anyone know more about this?
                                Easy to use UMG Mini Map on the UE4 Marketplace.
                                Forum thread: https://forums.unrealengine.com/show...-Plug-and-Play

                                Comment

                                Working...
                                X