Announcement

Collapse
No announcement yet.

Unreal Engine 4.20 Preview

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Does UE 4.20 currently support Metadata from Maya? I've noticed support for Metadata from 3DS Max via Datasmith. Is there any way to get Metadata out from Maya assets? With the help of Python, I'm able to set_metadata and read it afterwards from any asset. But I can't seem to read it raw from a freshly imported Maya asset.

    Comment


      Originally posted by Kalle_H View Post

      Can someone confirm this. I reported a bug but the response I did get was. "I am able to set the Screen Size for any of the LODs when I have Auto Compute LOD Distances = False. Moving the camera in the viewport confirms that the manually set screen size is working." Which is basically opposite what I want to do. Problem is with auto compute distances being always the same.

      Originally posted by Stalks View Post

      Automatic screen size is broken for me as well in 4.20.
      ...
      Broken for me also.

      Comment


        4.20 p2:Area light is too bright after build lighting.It seems that the area light source has too much indirect light intensity

        Comment


          Originally posted by IOchair View Post
          4.20 p2:Area light is too bright after build lighting.It seems that the area light source has too much indirect light intensity
          https://issues.unrealengine.com/issue/UE-60104

          Comment


            Originally posted by ConverseFox View Post
            I would like to point out that an early version of the Geo 2.0/Mesh Editor is in this version! You can enable it by entering this command "MeshEditor.Enable"
            Thank you for this!

            Such a shame the actual tool is buggy and needs a UI pass to make it anything remotely usable...but we live in hope for future developments.

            Comment


              ARKit2.0 available on 4.20 p2 ?

              Comment


                Originally posted by Mitch Mitchell View Post

                Thank you for this!

                Such a shame the actual tool is buggy and needs a UI pass to make it anything remotely usable...but we live in hope for future developments.
                When you are turning on a feature via a console variable or some otherwise hidden method you should have the expectation that the feature may be extremely unstable, missing functionality, and have no ui polish at all.

                Comment


                  Originally posted by kgamble View Post
                  The Steamworks 32-bit dll seems to be missing from the install, is this a mistake or is building projects with Steam support for 32-bit Windows no longer supported?
                  This is still an issue in preview 2 and I haven't gotten a response about it yet. In case you need more detail, if I package for Windows (32-bit) with a project that uses Steamworks I get the error
                  Code:
                  LINK : fatal error LNK1181: cannot open input file 'steam_api.lib'
                  Searching around the install directory for 4.19, steam_api.lib is found at "Engine\Source\ThirdParty\Steamworks\Steamv139\sdk\redistributable_bin" but it's missing in my 4.20 install. I verified my installation just in case something went wrong with it but it's still missing.

                  Comment


                    Setting bCastHiddenShadows=true doesn't seem to work in 4.20. Hidden or invisible meshes both won't cast shadows even with hidden shadows on.

                    I've only tested this with cascading shading maps, in VR, on runtime generated meshes.

                    I submitted a bug report.

                    <3

                    Comment


                      Another bug!

                      Packaging to android has an issue:
                      UATHelper: Packaging (Android (ETC2)): clang++.exe: error: unable to execute command: Couldn't execute program 'C:/NVPACK/android-ndk-r12b/toolchains/arm-linux-androideabi-4.9/prebuilt/windows-x86_64/lib/gcc/arm-linux-androideabi/4.9.x/../../../../arm-linux-androideabi/bin\ld.exe': The filename or extension is too long.

                      My android ndk is installed in the standard folder, so I think this should be fixed by UE4.

                      You can reduce that filename by just negating the folders and "../"s in the middle.

                      Edit: I heard back from Epic on this one. They've fixed this bug in CL 4123130 and it should be ready for preview 3.
                      Last edited by NathanSculptrVR; 06-15-2018, 02:03 PM. Reason: update with info I got from Epic

                      Comment


                        Originally posted by Matt View Post

                        When you are turning on a feature via a console variable or some otherwise hidden method you should have the expectation that the feature may be extremely unstable, missing functionality, and have no ui polish at all.
                        Hi Matt, thanks for the reply - but I must ask; what was it about my comment "...but we live in hope for future developments..." that implied I was not aware of that which you mentioned?

                        Comment


                          Originally posted by Mitch Mitchell View Post

                          Hi Matt, thanks for the reply - but I must ask; what was it about my comment "...but we live in hope for future developments..." that implied I was not aware of that which you mentioned?
                          As someone who is just lurking in this thread, it felt a bit to me like you were enabling a very experimental feature through round-about means but then complaining that it wasn't polished (UI, buggy, etc). So I can see why other Matt was a bit defensive.
                          Able Ability System - A high performance, robust ability system for UE4. Now Available!

                          Comment


                            How can I download the ARPG sample game to play around with the 4.20 preview?

                            Comment


                              Hi how can i report a bug for UI 3D Widget component in 4.20 preview 2, the component is visible in blueprint editor, and i can only see the widget in editor only if i enable Show FPS + Realtime but the BUG is that when i press play it dissapears in playmode, ive tried many projects from scratch using proper scaling it just doesnt work, same blueprint works in 4.19/18/17 etc.
                              I did not use any experimental features, i was just testing out 4.20 by making a few BP's from scratch and i cant create a 3D Widget Label because it dissapears in play mode. Please fix this bug its a very important UI component to not be fixed in 4.20 release.
                              I even reinstalled my drivers but its not that either.

                              Comment


                                Originally posted by M3NTH0S View Post
                                Hi how can i report a bug for UI 3D Widget component in 4.20 preview 2, the component is visible in blueprint editor, and i can only see the widget in editor only if i enable Show FPS + Realtime but the BUG is that when i press play it dissapears in playmode, ive tried many projects from scratch using proper scaling it just doesnt work, same blueprint works in 4.19/18/17 etc.
                                I did not use any experimental features, i was just testing out 4.20 by making a few BP's from scratch and i cant create a 3D Widget Label because it dissapears in play mode. Please fix this bug its a very important UI component to not be fixed in 4.20 release.
                                I even reinstalled my drivers but its not that either.
                                https://forums.unrealengine.com/unre...ubmission-form

                                Comment

                                Working...
                                X