Announcement

Collapse
No announcement yet.

Unreal Engine 4.18 Released!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ARKit still not updated.

    Comment


      @Shadow.Storm

      Updating to 4.18.2 has broken my project it says the map was saved with a newer version of the engine coming from 4.18.1.

      EDIT
      I fixed this by using a autosave of my level.
      Last edited by OverRated_AU; 12-12-2017, 09:54 AM.

      Comment


        Updating to 4.18.2 has caused my level to recompile 128,000 shaders on opening the map every single time. I didn't have this problem on 4.18.1
        Marketplace Packs
        ByteBombs Pickup System

        Comment


          Hi,
          just updated to 4.18.2 from 4.18.1. Everything works fine and after all the materials updated, i save the work. Then when i close the editor and open the project again, all the materials have to be updated again. It will take again 15min for 30.000 and after all is done it looks like it should. But then again, when open the level again the materials where not saved before. If i want to render out a sequencer animation, i have the problem too. The materials are not updated and skylight is wrong and the whole scene is too dark.. not in the editor after updating the materials, but it is not saved...oh noooo..please help or update. Thank you.
          KreatiVR:Interactive architecture visualization in 360° VR

          Follow me on:

          youtube:
          https://www.youtube.com/channel/UCi4...0nondmottOLAuw
          linkedIn: https://www.linkedin.com/in/martin-kogoy-99401a140/

          Comment


            Originally posted by Mugoo View Post
            Updating to 4.18.2 has caused my level to recompile 128,000 shaders on opening the map every single time. I didn't have this problem on 4.18.1
            Hi,
            me too. ;-) There must be a bug or something has changed drastically. We have to wait.
            KreatiVR:Interactive architecture visualization in 360° VR

            Follow me on:

            youtube:
            https://www.youtube.com/channel/UCi4...0nondmottOLAuw
            linkedIn: https://www.linkedin.com/in/martin-kogoy-99401a140/

            Comment


              Hi,

              I'm trying update to 4.18.2 from 4.18.1 and I can't do it. Error code IS-MF01-183? Any help with this?, I made the project in 4.18.1 and I can't to access in any way.

              How can install previous version 4.18.1 with not updates?, I can't find the way (always appear update)

              Thanks

              Comment


                Mugoo and mk010769, I tried opening some of our sample projects in 4.18.2 (Realistic Rendering, Sun Temple, Elemental Demo, etc.) and after the shaders compile the first time, opening the projects again does not result in the shaders needing to be compiled again.

                Are you able to provide some instructions for us to reproduce the issue on our end?

                Comment


                  Originally posted by Jon X View Post
                  Mugoo and mk010769, I tried opening some of our sample projects in 4.18.2 (Realistic Rendering, Sun Temple, Elemental Demo, etc.) and after the shaders compile the first time, opening the projects again does not result in the shaders needing to be compiled again.

                  Are you able to provide some instructions for us to reproduce the issue on our end?
                  Hi,
                  hm nothing special done.. I opened the project direct from the epic games launcher. In the settings i have enabled "load default map", so the editor starts with a level map i created in 4.18.1.
                  After the loading is finished, i wait till all materials are updated and then save the level. I close the editor and reopen my level from the games launcher again. It loads my level but then has to recompile all materials again.. same procedure everytime i start with the level..
                  KreatiVR:Interactive architecture visualization in 360° VR

                  Follow me on:

                  youtube:
                  https://www.youtube.com/channel/UCi4...0nondmottOLAuw
                  linkedIn: https://www.linkedin.com/in/martin-kogoy-99401a140/

                  Comment


                    Originally posted by Jon X View Post
                    Mugoo and mk010769, I tried opening some of our sample projects in 4.18.2 (Realistic Rendering, Sun Temple, Elemental Demo, etc.) and after the shaders compile the first time, opening the projects again does not result in the shaders needing to be compiled again.

                    Are you able to provide some instructions for us to reproduce the issue on our end?
                    I'm having the same (or possibly just a similar) issue on my project. For me, whenever I load a level with a landscape all the landscape shaders need to be recompiled. I don't even need to close the editor, just go to a different level and back again. I was hoping the Boy and His Kite sample would have the same issue but no luck. Working on stripping out most of the content from my project so I can post it with a bug report on the AnswerHub.

                    Comment


                      Hi,

                      I really appreciate the hotfix since it seems to have gotten rid of issue "UE-53126 Unknown by landscape material warning logspam when launching onto Android/HTML5/iOS/tvOS" which has been quite a headache ever since we upgraded the project to 4.18.

                      However, right after upgrading the project to 4.18.2 from 4.18.1, whenever we build or cook it, we get a "DerivedDataCache is too slow when accessing..." when cooking uassets and and the process just hangs in there for ever (or for at least 2 hours, which is the most I have wait for since the issue started) - I posted a related, more detailed question in the answerhub as well.

                      https://answers.unrealengine.com/que...accessing.html

                      Any sort of input, help or advice would be greatly appreciated.

                      Thank you.

                      Comment


                        Originally posted by Mugoo View Post
                        Updating to 4.18.2 has caused my level to recompile 128,000 shaders on opening the map every single time. I didn't have this problem on 4.18.1
                        It seems 4.18.2 doesn't load the cached data from 4.18.1 instead it thinks you wiped out your save and goes ahead and recompiles the lot lol.

                        Comment


                          I clocked loading times on my maps. 4.16 loads the map in 5 seconds while 4.17 and 4.18 take 14 seconds. That is quite the difference.

                          Any ideas why this is? Is it because of the changes in 4.17's Asset Registry?

                          Metahusk: A 501(c)(3) Creative Development Cooperative
                          Projects | Forums | Repositories | Nonprofit | Donate

                          Comment


                            Not sure what's causing the slowdown, but... this was submitted to main branch few days ago.

                            Change 3780855 by Gil.Gribb

                            UE4 - Fixed a linear search in EDL that caused performance problems for very large maps. Saves half the load time in FN-BR.
                            Last edited by Moth Doctor; 12-13-2017, 11:32 AM.

                            Comment


                              Originally posted by mk010769 View Post

                              Hi,
                              hm nothing special done.. I opened the project direct from the epic games launcher. In the settings i have enabled "load default map", so the editor starts with a level map i created in 4.18.1.
                              After the loading is finished, i wait till all materials are updated and then save the level. I close the editor and reopen my level from the games launcher again. It loads my level but then has to recompile all materials again.. same procedure everytime i start with the level..
                              For those having this issue with the shaders compiling, try deleting the folder AppData\Local\UnrealEngine\Common\DerivedDataCache .

                              Comment


                                I'm having a performance bug in the editor when I open menus or editor windows (mesh editor, mat editor, mat instance editor, etc). I created a report here. Anyone know of a solution or have something similar?

                                Comment

                                Working...
                                X