Announcement

Collapse
No announcement yet.

Unreal Engine 4.18 Released!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Thread 6 Crashed:
    0 libsystem_kernel.dylib 0x0000000185e1d348 __pthread_kill + 8
    1 libsystem_pthread.dylib 0x0000000185f31344 pthread_kill$VARIANT$mp + 396
    2 libsystem_c.dylib 0x0000000185d8cfb8 abort + 140
    3 MJ3D 0x0000000100b8be1c FGenericPlatformMallocCrash::InitializeSmallPools+ 5619228 () + 0
    4 MJ3D 0x0000000100d3d1b0 FOutputDevice::Logf+ 7393712 (wchar_t const*, ...) + 232
    5 MJ3D 0x0000000100cee828 FDebug::AssertFailed+ 7071784 (char const*, char const*, int, wchar_t const*, ...) + 308
    6 MJ3D 0x0000000100f36fcc LoadPackageAsync+ 9465804 (FString const&, FGuid const*, wchar_t const*, TBaseDelegate<void, FName const&, UPackage*, EAsyncLoadingResult::Type>, EPackageFlags, int, int) + 572
    7 MJ3D 0x00000001010fe814 LoadPackageInternal+ 11331604 (UPackage*, wchar_t const*, unsigned int, FLinkerLoad*) + 1360
    8 MJ3D 0x00000001010fc248 LoadPackage+ 11321928 (UPackage*, wchar_t const*, unsigned int) + 556
    9 MJ3D 0x00000001010f9090 ResolveName+ 11309200 (UObject*&, FString&, bool, bool, unsigned int) + 992
    10 MJ3D 0x00000001010fc878 StaticLoadObjectInternal+ 11323512 (UClass*, UObject*, wchar_t const*, wchar_t const*, unsigned int, UPackageMap*, bool) + 1216
    11 MJ3D 0x00000001010fd270 StaticLoadObject+ 11326064 (UClass*, UObject*, wchar_t const*, wchar_t const*, unsigned int, UPackageMap*, bool) + 256
    12 MJ3D 0x0000000103bb2d24 UMaterialInterface* ConstructorHelpersInternal::FindOrLoadObject<UMaterialInterface>+ 56110372 (FString&) + 1420
    13 MJ3D 0x0000000103bb2764 ConstructorHelpers::FObjectFinder<UMaterialInterface>::FObjectFinder+ 56108900 (wchar_t const*) + 128
    14 MJ3D 0x0000000103f9f904 void InternalConstructor<UARKitCameraOverlayMaterialLoader>+ 60225796 (FObjectInitializer const&) + 92
    15 MJ3D 0x0000000100f8427c UClass::CreateDefaultObject+ 9781884 () + 1200
    16 MJ3D 0x00000001010ef790 ProcessNewlyLoadedUObjects+ 11270032 () + 3004
    17 MJ3D 0x0000000100b36fe8 FEngineLoop::PreInit+ 5271528 (wchar_t const*) + 12512
    18 MJ3D 0x0000000100b33de8 FAppEntry::Init+ 5258728 () + 40
    19 MJ3D 0x000000010119f374 -[IOSAppDelegate MainAppThread:] + 232
    20 Foundation 0x0000000186cf6860 __NSThread__start__ + 996
    21 libsystem_pthread.dylib 0x0000000185f3031c _pthread_body + 308
    22 libsystem_pthread.dylib 0x0000000185f301e8 _pthread_body + 0
    23 libsystem_pthread.dylib 0x0000000185f2ec28 thread_start + 4
    ,>

    Comment


      Originally posted by meshcarver View Post
      I recently updated from .13 and had lighting artifact issues (lots of black stepped lines etc) becuase Im using dynamic/movable lights for the Skylight and main Directional Light as I need time of day.

      Now, in .18 the artifacts are NEARLY gone..!
      Is this an intentional fix? If so, could someone point me to the information in the fix/feature list please so I can check it out?
      It was a dealbreaker for me as it was so bad, but now it's much much better- still there but much more subtle.

      I can't find any referance to this being fixed anywhere- unless I've jumped the gun too early as I've yet to do extensive testing.
      The 'fix' may not be in 4.18, it could be in from 4.14 all the way to 4.18. You have to upgrade the project for each project to know which version actually fix it.
      And then to make it trickier, the fix may not be intentional - it is meant to fix other bugs.

      Comment


        Syed, you've given me oh so much confidence...
        Even if it's not intentional, is it even safe to say it will now stay like this for each upgrade release or could it break/regress again do you know?

        Plus, if I was a AAA Developer and went ahead with this only to find it broke again a year down the line, what would be the way to fix it again? What would be the process as I can imagine it causing all sorts of headaches to go ahead with an option only to find it "taken away" at a later point?
        Last edited by meshcarver; 11-23-2017, 10:56 PM.
        Website
        Artstation
        Twitter

        Comment


          Yes so much confidence.. sorry about that..

          If you are afraid it may break again in future, then one way is not to upgrade unless absolutely necessary. If there is a bug that need to be fixed and it is in the newer version, then you can cherry pick and apply it to your custom build (yes, custom build.. lol). But I have read that UE4 does a lot of supper-commit, which merges a lot of unique commits into one so cherry-picking is even trickier (yes, I used that word again haha)

          Comment


            Hey man, thanks for the advice lol..!!!
            In a way all this stuff is i the future for what I'm trying to do, but it's good to know so thanks again..!!
            Website
            Artstation
            Twitter

            Comment


              I've got a problem with the DPI scaling. Everything looks way bigger (and blurred) than it did up until version 4.17.

              I tried disabling the option "Disable DPI based Editor viewport scaling" but it doesn't do anything different at all. Does someone have the same problem?
              TweenMaker | OutlineMaker

              Comment


                I installed Substance Painter 2017.4.0 and Unreal Engine 4.18.1
                Plugin (from market http://joxi.ru/n2Yn9qRfoWQNYA)
                http://joxi.ru/MAjGOx7F4NgMQr
                when i choose asset and press right mouse button, i see "Send to substanse painter"
                I click on this line
                http://joxi.ru/n2Yn9qRfoWQV6A
                Asset opens in the Substance Painter
                https://clickscreen.ru/ac0264afe5.png
                A new spp-file appears in this directory
                http://joxi.ru/krD8B51sEVoLjr
                When I try to draw in Substance - Unreal Engine crashing(((
                http://joxi.ru/vAW49NRs15oKJr
                http://joxi.ru/EA49B3nFwl6VLr

                I tried to do this:

                Changing the version to be explicit with the engine version:
                1. Open the Substance.uplugin in your favorite text editor.
                2. On the third line, there is a variable titled "VersionName". Change the first three numbers to be the explicit version of the engine you are using. It should currently read "4.17.0.25" which should be changed to "4.17.2.25".
                3. Repeat the steps to reload the plugin within the plugins window within the editor.

                And this:

                In the case this does not solve the issue, this may be a result of the plugin already being built against an engine that is not compatible with the engine you are using.
                To build the plugin using the custom engine:
                1. Open the plugins folder and delete the following folders:
                - Binaries
                - Intermediate
                2. Run Generate Project Files (Batch file if added to the engine or through the right-click context menu of a .uproject if added to a project)
                3. Build the engine/project in the Development Editor configuration

                But it didn't work(((
                Can you help me?
                P.S. sorry for my English

                Comment


                  Edit: I was told to shout regression.

                  This broke from 4.17 to 4.18, report and repro steps here:

                  https://answers.unrealengine.com/que...n-instead.html
                  Last edited by Fantasifall; 11-28-2017, 08:33 PM.

                  Comment


                    4.18 broke VR development

                    https://answers.unrealengine.com/que...n-vr-mode.html

                    this should be a 4.18.2 hotfix

                    Comment


                      Originally posted by Curs0 View Post
                      4.18 broke VR development

                      https://answers.unrealengine.com/que...n-vr-mode.html

                      this should be a 4.18.2 hotfix
                      Are you sure there will be 4.18.2 ?

                      Comment


                        Originally posted by motorsep View Post

                        Are you sure there will be 4.18.2 ?
                        The 4.18 branch was updated to 4.18.2 13 days ago, so yes, there will be a 4.18.2.
                        Easy to use UMG Mini Map on the UE4 Marketplace.
                        Forum thread: https://forums.unrealengine.com/show...-Plug-and-Play

                        Comment


                          Originally posted by motorsep View Post

                          Are you sure there will be 4.18.2 ?
                          I just know we are totally blocked by an editor slate crash and many VR developers reported it....

                          Comment


                            I see you have marked UE-52280 fixed in 4.18.1, but the similar bug UE-51886 is not fixed. Our project is affected by UE-51886. PIE crashes every time after PIE window gets focused and gains mouse input.

                            PRECONDITION: Many streaming levels and streaming volumes in one project. Start PIE session with right clicking -> Play From Here

                            HOWEVER there is no crash in PIE IF:
                            1.) PIE window is in full screen mode (F11)
                            OR
                            2.) Details panel is closed before starting PIE session (Details Panel could be the root cause for this bug?)

                            I can provide more information if needed, but those things stop Editor crashing so I suspect strongly that this bug is caused by new behavior of Details Panel. In my setup I have Details Panel, Levels Panel and World Settings Panels all as tabs under the same tab window. Whenever I unload (hide) streaming level in our project the Levels Tab is unfocused and Details Tab is focused. This itself is a minor inconvenience, but it could also be the reason for this bug I believe. Just guessing here, but could the Details Panel try to show details of some object that is no longer available in PIE session after streaming level is unloaded?

                            Comment


                              wo0o0ow.... long article!

                              Comment


                                Hi Everybody,

                                Can anybody from the Epic Staff tell me whether or not there will be another hotfix for 4.18

                                My institution is thinking about updating but we don't want to if there is going to be a 4.18.2

                                Thanks in advance.



                                Comment

                                Working...
                                X