Announcement

Collapse
No announcement yet.

Unreal Engine 4.18 Released!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Kalle_H View Post
    Any one else have problems with ios? I noticed that performance is very bad. Frame time is doubled versus 4.17. There is also some sort of glitch that shake up dynamic shadows and materials that use worldposition based texture coordinates at pixel shader. Basically unusable.
    Updating our iPad5G to ios11.1 fixed all issues with performance and glitches. Sorry for blaming 4.18.

    Comment


      I installed UE4.18 after official release but after a while it became UE4 Preview 4, WTF?
      Reinstalled, 2 days it was UE 4.18 and now it back to "Preview4".

      Click image for larger version

Name:	QIP Shot - Screen 075.png
Views:	100
Size:	167.9 KB
ID:	1380263

      Comment


        Originally posted by SeriouSerg View Post
        I installed UE4.18 after official release but after a while it became UE4 Preview 4, WTF?
        Reinstalled, 2 days it was UE 4.18 and now it back to "Preview4".

        Click image for larger version

Name:	QIP Shot - Screen 075.png
Views:	100
Size:	167.9 KB
ID:	1380263

        I was getting that too. I think it's just a launcher bug. Restarting the launcher all the way fixed it for me.

        Comment


          Originally posted by Amanda.Bott View Post
          Blueprints: Added an option to disable the comment bubble on comment boxes that appears when zoomed out
          Thanks to Michael Noland or whoever @ Epic fixed BP-Comment-Bubble-Hell (this).
          Its been a long time coming, and its a small thing, but it sure makes a big difference.

          ~~~~~~~~~~~~~~~~~~~~~~~~~~
          Resolved - 4.18 'Project Conversion' Bug: - Special thanks to kjustynski
          ~~~~~~~~~~~~~~~~~~~~~~~~~~

          Solution:
          Fixed! - Very easy solution - Just load the Apex (Destructible) Plugin, as its not loaded by default.

          Observation:
          Seems strange that 4.18 loads Alembic-importer & Actor-Sequence both experimental, but not this?
          Anyway what do I know! However It may mean many project upgrades will generate the same error.
          As the plugin can't be loaded before the project-upgrade as its a per-Project-setting and not Editor.
          So a restart is needed after the Plugin is selected (after the upgrade) for everything to right itself etc.
          (In UDK, there was always a basic 'built-in' destructible-mesh-system as part of the core engine etc)

          ~~~~~~~~~~~~~~~~~~~~~~~~~~
          4.18 'Project Conversion' Bug:

          HTML Code:
          CreateExport: Failed to load Outer for resource 'AssetImportData': DestructibleMesh
          CreateExport: Failed to load Outer for resource 'SceneThumbnailInfo_0': DestructibleMesh
          After 4.18 upgrade all Destructible Meshes are nuked.
          Seeing this on 4.18, after upgrading from a 4.16.1 project.

          Which in-turn was upgraded from 4.10 .... 4.14 .... 4.15 etc.
          But this is the first time this type of error has ever occurred.
          4-18 Release-Notes don't show big work on Destructibles.
          Not that I could see, unless I missed something crucial etc.

          AH posts: advise deleting binaries, that won't help here.
          Others mentioned 'delete cache' assume that's DDC???
          Others mention migrating everything to new project also.
          But this is quite a generic error affecting different cases.
          So I don't want to break other things by trying this just yet..

          https://answers.unrealengine.com/que...-for-reso.html
          https://answers.unrealengine.com/que...rce-error.html
          https://answers.unrealengine.com/que...e-error-1.html
          https://answers.unrealengine.com/que...rce-error.html

          Is anyone else seeing this, or is it an isolated issue?
          Last edited by EntrpriseCustomr; 11-05-2017, 03:42 AM.

          Comment


            I got this fixed by disconnect the pin of the related nodes and reconnect back again.

            Comment


              [Resolved - See above...]

              Originally posted by Syed View Post
              I got this fixed by disconnect the pin of the related nodes and reconnect back again.
              Did you have this error with Destructible Meshes Syed?
              The import is failing, so sadly that won't work here.

              (*.uassets for destructible meshes are left out of the project)
              Last edited by EntrpriseCustomr; 11-05-2017, 03:43 AM.

              Comment


                [Resolved - See above...]

                Repro'd the problem using this 3rd party project here, but same issue.
                So it doesn't look like its related to DDC or cache / project corruption...
                Last edited by EntrpriseCustomr; 11-05-2017, 03:42 AM.

                Comment


                  To be sure, did you turn on APEX Destruction plugin?
                  Destruction module has been moved to plugin and turned off by default. Everyone get this error at 4.18 upgrade if there's any destructible mesh in content.
                  This was mentioned in Release Notes

                  Comment


                    Hi,

                    I have encountered an issue trying to build a dedicated server for a 4.18 project. The engine was built from source, then a binary version was created from that.

                    My problem is the content of the "MyGame.Server.Target.cs" file located in the MyGame/Source folder.

                    I am following this guide: https://wiki.unrealengine.com/Dedica...ows_%26_Linux)

                    The guide suggests using the following lines:

                    Code:
                    using UnrealBuildTool;
                    using System.Collections.Generic;
                    
                    public class MyGameServerTarget : TargetRules
                    {
                    public MyGameServerTarget(TargetInfo Target)
                    {
                    Type = TargetType.Server;
                    bUsesSteam = true;
                    }
                    
                    // TargetRules interface.
                    
                    public override bool GetSupportedPlatforms(ref List<UnrealTargetPlatform> OutPlatforms)
                    {
                    // It is valid for only server platforms
                    return UnrealBuildTool.UnrealBuildTool.GetAllServerPlatforms(ref OutPlatforms, false);
                    }
                    
                    public override void SetupBinaries
                    (
                    TargetInfo Target, ref List<UEBuildBinaryConfiguration> OutBuildBinaryConfigurations,
                    ref List<string> OutExtraModuleNames
                    )
                    {
                    OutExtraModuleNames.Add("MyGame");
                    }
                    }
                    Now as far as I know that is outdated, so I changed it to this:
                    Code:
                    using UnrealBuildTool;
                    using System.Collections.Generic;
                    public class MyGameServerTarget : TargetRules
                    {
                    public MyGameServerTarget(TargetInfo Target) : base(Target)
                    {
                    Type = TargetType.Server;
                    bUsesSteam = true;
                    ExtraModuleNames.AddRange( new string[] { "MyGame" } );
                    }
                    
                    // TargetRules interface.
                    
                    public override bool GetSupportedPlatforms(ref List<UnrealTargetPlatform> OutPlatforms)
                    {
                    // It is valid for only server platforms
                    return UnrealBuildTool.UnrealBuildTool.GetAllServerPlatforms(ref OutPlatforms, false);
                    }
                    }
                    However, upon generating the project files, I get the following error:
                    Code:
                    ERROR: c:\MyProjectPath\MyGame\Source\MyGameServer.Target.cs(22,36) : error CS0122: 'UnrealBuildTool.UnrealBuildTool' is inaccessible due to its protection level
                    ERROR: c:\MyProjectPath\MyGame\Source\MyGameServer.Target.cs(22,52) : error CS0117: 'UnrealBuildTool.UnrealBuildTool' does not contain a definition for 'GetAllServerPlatforms'
                    ERROR: UnrealBuildTool Exception: Unable to compile source files.
                    Does anyone know how to do this correctly?

                    Thanks!

                    Comment


                      [Resolved - See above...]

                      Originally posted by kjustynski View Post
                      To be sure, did you turn on APEX Destruction plugin? Destruction module has been moved to plugin and turned off by default. Everyone get this error at 4.18 upgrade if there's any destructible mesh in content.This was mentioned in Release Notes
                      Cheers for the tip. I assumed the default fracture system didn't even use Apex (as per UDK).
                      So thanks I'll look into this just as soon I fix the other things stopping the project from working...
                      Last edited by EntrpriseCustomr; 11-05-2017, 03:43 AM.

                      Comment


                        Where is tango things? Not ArCore, tango. Tango plugin is missing there. I have Asus Zenfone AR and there is no documentation and plugin is dropped. In 4.17 tango plugin is present

                        4.18:
                         
                        Spoiler

                        4.17
                        all tango classes is present, such as mesh reconstruction, area learning
                         
                        Spoiler
                        tangoMapConfigurationActor is missing on 4.18
                         
                        Spoiler
                        Last edited by adigyran; 11-05-2017, 05:22 AM.

                        Comment


                          I'm looking forward to texture2d array in 4.19

                          Comment


                            Originally posted by JerryLi View Post
                            I'm looking forward to texture2d array in 4.19
                            Yes! Epic is "planning to have this for 4.19, and someone is scheduled":

                            https://github.com/EpicGames/UnrealEngine/pull/2340
                            Easy to use UMG Mini Map on the UE4 Marketplace.
                            Forum thread: https://forums.unrealengine.com/show...-Plug-and-Play

                            Comment


                              Bug editing the Light Color of a SkyLight
                              Every time you double-click to open the colorpicker, the hsv value is loaded incorrectly - an offset is added.
                              (if value is 0, then this does not happen).

                              Steps to reproduce:
                              Drag SkyLight into scene.
                              Double-click Light color to open Color Picker. Change to non-zero value and save (V in HSV)
                              Double-click Light color to open Color Picker again Incorrect value shown..

                              https://www.casualdistractiongames.com

                              Comment


                                Originally posted by OptimisticMonkey View Post
                                Bug editing the Light Color of a SkyLight
                                Every time you double-click to open the colorpicker, the hsv value is loaded incorrectly - an offset is added.
                                (if value is 0, then this does not happen).

                                Steps to reproduce:
                                Drag SkyLight into scene.
                                Double-click Light color to open Color Picker. Change to non-zero value and save (V in HSV)
                                Double-click Light color to open Color Picker again Incorrect value shown..
                                You know that there has to be AH report in order for Epic even to start looking into your bug?!

                                Comment

                                Working...
                                X