No announcement yet.

Unreal Engine 4.17 Preview

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

    I've updated
    All issues in 4.16 are resolved but in 4.17 project is crashing on startup - new logs etc.


      Originally posted by Malachi93 View Post
      Any idea when we will see the Clear Coat Shader function being added to the Forward Renderer? I have project that heavily relies on this.
      Any word on this?? I'm aware you can implement clear coat in the GetImageBasedReflectionLighting function in ForwardLightingCommon.usf. However I'm not sure exactly how to do it. Is there any sign of this being put into the forward renderer as default??



        We have just released Preview 3 for 4.17! Thank you for your continued help in testing the 4.17 build before its official release. As a reminder, the Preview builds are for testing only, and should not be used for the active development of your project.

        For a list of known issues affecting this latest preview, please follow the links provided on the first post in this thread.

        Experimental ARKit support has been added in this preview.


        Fixed in Preview 3

        Fixed! UE-46839 Destructibles jitter for a short period after breaking
        Fixed! UE-46765 Crash when using Vertex painter with material including cubemap texture sampler
        Fixed! UE-47431 Sound cues with delays do not play in the animation editor when set as anim notifies
        Fixed! UE-47227 [CrashReport] UE4Editor_Persona!TSharedPtr<IEditableSkeleton,0>::ToSharedRef() [sharedpointer.h:794]
        Fixed! UE-47248 [CrashReport] CastChecked<UAnimBlueprint,UBlueprint>()
        Fixed! UE-47476 [CrashReport] UE4Editor_Engine!USkeleton::GetMeshLinkupIndex() [skeleton.cpp:420]
        Fixed! UE-47528 [CrashReport] UE4Editor_Persona!FReferenceSkeleton::FindBoneIndex() [referenceskeleton.h:252]
        Fixed! UE-47397 Audio thread priority causes issues for some games
        Fixed! UE-47383 Audio streaming chunks failing to load
        Fixed! UE-47490 Severe hitch during test for AEOverview - SW Procedural in QAGame
        Fixed! UE-47626 QAGame Crashes when Shooting in -game
        Fixed! UE-47562 Crash FAudioDevice::AddNewActiveSound() when loading music in Game client
        Fixed! UE-47296 [CrashReport] UE4Editor_ClothingSystemRuntime!FClothingSimulationNv::GetBounds() [clothingsimulationnv.cpp:730]
        Fixed! UE-47360 Non Uniform baking of HLOD materials causes texture stretching
        Fixed! UE-47570 Unable to launch Shooter Game to Xbox One using Visual Studio.
        Fixed! UE-47344 Log output on Mac is not displayed in terminal window and Xcode launch log
        Fixed! UE-46826 Quick Launch Cook on the Fly Crash using UFE/Project Launcher
        Fixed! UE-47588 Unable to build script plugin against 4.17 release
        Fixed! UE-47483 Crash running GC and Level Load Stress Test in TM-Core on Mac in packaged QAGame.
        Fixed! UE-46657 Puzzle Code project has spelling error in BlockGrid.cpp
        Fixed! UE-47459 Content Examples fails to cook due to long path names
        Fixed! UE-39586 Many FText warnings in Output Log while cooking
        Fixed! UE-47618 Linux - Steaming Levels not being triggered
        Fixed! UE-47491 Resizing the compiler results log when it contains errors from a math expression node will crash
        Fixed! UE-47455 Crash when Clicking on a Linear Color Default Value in an interface
        Fixed! UE-47451 Access none after making changes to a blueprint that is referenced in the level blueprint
        Fixed! UE-47494 Undo/Redo of changing a blueprint function parameter to bool can crash
        Fixed! UE-47326 Crash when using Find Substring node if the starting position is higher than the number of characters in the string being searched
        Fixed! UE-47313 Crash when loading old data after changing type of Map Value to related type
        Fixed! UE-47340 Crash upon using EComparisonMethod as a variable in a struct
        Fixed! UE-47605 [CrashReport] Crash trying to destroy an uber graph frame because the RawPointer is still set
        Fixed! UE-47512 Math expression nodes do not show errors in their tooltip anymore, and the error bar goes away after subsequent compiles even though the node is still in error
        Fixed! UE-47481 Potential crash during undo/redo of a split pin
        Fixed! UE-47321 Save on successful compile only not working in blueprints
        Fixed! UE-47331 Blueprint Active Node highlight not working properly
        Fixed! UE-47322 Breakpoints on Flow Control nodes are not triggered.
        Fixed! UE-47467 [CrashReport] UE4Editor_Kismet!FBlueprintGlobalOptionsDetails::CanDeprecateBlueprint() [blueprintdetailscustomization.cpp:5127]
        Fixed! UE-47493 [CrashReport] UE4Editor_Kismet!FBlueprintGraphArgumentLayout::OnArgNameChange()
        Fixed! UE-47478 [CrashReport] UE4Editor_Landscape!ALandscapeProxy::PostEditChangeProperty() [landscapeedit.cpp:3692]
        Fixed! UE-47527 Android ES31 crashes on Galaxy S7 Adreno
        Fixed! UE-47469 Depth/Stencil discard missing for non-hdr mobile path causing performance regression on Qualcomm.
        Fixed! UE-47287 HTML5 Client fails to connect to Windows dedicated server
        Fixed! UE-45398 Re-showing a landscape component after hiding it does not work on Android
        Fixed! UE-45015 Landscapes do not Render when used with Lighting Scenarios on Mobile
        Fixed! UE-47254 Chrome does not take control of the mouse pointer when playing Zen
        Fixed! UE-47557 SunTemple does not look correct on iOS device (cooked from Mac)
        Fixed! UE-47396 ZenGarden's game sequence doesn't play on device
        Fixed! UE-47403 SunTemple scene does not update properly on iPhone 6S
        Fixed! UE-47540 [CrashReport] Crash on Mac - UE4Editor-IOSTargetPlatform.dylib!FIOSDeviceHelper:oDeviceConnect()
        Fixed! UE-47318 Objects set to Stationary and movable do not create shadows in the right eye for daydream
        Fixed! UE-47665 UPL addElement and addElements can infinitely recurse if tag is included in inserted data
        Fixed! UE-44467 Crash when trying to load an invalid map after disconnecting
        Fixed! UE-45809 OnlineSubsystemMcp crashes if OnlineSubsystemUtils is loaded before it
        Fixed! UE-46078 [CrashReport] Access violation in UE4Editor_Engine!TOctree<TVolumeLightingSample<3>
        Fixed! UE-46464 TextRenderActors do not appear in screenshots (SkelMeshMergeMap auto test)
        Fixed! UE-47404 Fix Vulkan textures not streaming
        Fixed! UE-47373 Deleting a light in game or deleting a mesh in PIE causes a large hitch
        Fixed! UE-46910 Crash: Direct3DDevice->CreateBuffer failed at D3D11VertexBuffer.cpp with error E_INVALIDARG
        Fixed! UE-42841 [CrashReport] UE4Editor_Engine!FMaterial::CacheShaders() [materialshared.cpp:1663]
        Fixed! UE-47551 Shadow culling inefficiencies
        Fixed! UE-47305 Particle simulation crash dereferencing deleted emitter resources
        Fixed! UE-45559 [CrashReport] Access violation in UE4Editor_Engine!FDistanceFieldAsyncQueue::ProcessAsyncTasks()
        Fixed! UE-46621 [CrashReport] Assertion on in UMaterialInterface::InitDefaultMaterials()
        Fixed! UE-47607 Crash on play if a BP uses a ClearInstances node followed by an AddInstance node
        Fixed! UE-45431 Crash when adding Actor Array Element to a Sequencer Event Struct
        Fixed! UE-47343 Invalid Memory Access Crash compiling a Widget Blueprint with an unsaved Transform animation track
        Fixed! UE-47142 ImagePlate should operate on Texture instead of Texture2DDynamic
        Fixed! UE-47178 Editor Crashes when working in QAGame TM-Sequencer_EventTrack - TCString<TCharType>::Strlen(InName)
        Fixed! UE-47623 Double click into a shot sometimes updates the time incorrectly
        Fixed! UE-47246 [CrashReport] UE4Editor_CoreUObject!FPackageName::LongPackageNameToFilename() [packagename.cpp:381]
        Fixed! UE-47464 [CrashReport] Fatal error: Cast of nullptr to Actor failed - UE4Editor_CoreUObject!CastLogError()
        Fixed! UE-46056 Editor crash on level load with multiple actors with the name "(none)"
        Fixed! UE-47543 Mac Automation Test Failed (LoadAsset)
        Fixed! UE-47529 Flickering on right side of "Package Project" menu.
        Fixed! UE-47603 Crash while scrolling through language options in Packaging settings
        Fixed! UE-46572 [CrashReport] UE4Editor_Engine!USplineMeshComponent::CalculateScaleZAndMinZ()
        Fixed! UE-47251 [CrashReport] UE4Editor_Cascade!FCascadeEdPreviewViewportClient::GetCascade() [cascadepreviewviewportclient.h:72]
        Fixed! UE-46433 Linux: CEF uses system libpng instead of a bundled one, refusing to run
        Fixed! UE-46069 [CrashReport] Assertion on Mac in FCocoaRunLoopSource
        Fixed! UE-47333 Mac fullscreen toggle button loses functionality after switching from fullscreen to windowed
        Fixed! UE-47295 [CrashReport] Crash on Mac - UE4Editor-Slate.dylib!FTextLayout::GetAsTextAndOffsets()
        Fixed! UE-46634 ShaderCompileWorker on Linux output makes the log too verbose
        Fixed! UE-47499 Mac Automation Test Ensure (NewFlags & PKG_PlayInEditor) ==0 || (this != EditorPackage)
        Fixed! UE-47498 Mac Automation Test Failed (StackCubesLarge)
        Fixed! UE-47500 Mac Automation Test Failed (BP_ComposurePostMoveProjectionMatrixTest)
        Fixed! UE-47504 Mac Automation Test Failed (Proc Mesh Collision)
        Fixed! UE-47546 [CrashReport] UE4Editor-Kismet.dylib!FTabInfo::OnMouseDownHisory(FGeometry const&, FPointerEvent const&, TWeakPtr<SMenuAnchor,()
        Fixed! UE-47329 Default Key Binding for Save Level removed
        Fixed! UE-47267 Crash when CTRL+Tab'ing with Property Matrix open
        Fixed! UE-46505 Jittering in Engine Menu Dropdown Options
        Fixed! UE-47430 Clipping issues in the profiler
        Fixed! UE-46553 Widget blueprints do not appear in HTML5
        Fixed! UE-47266 Canvas screen preview in blueprint widget editor not displaying
        Fixed! UE-47270 Making UMG buttons keyboard focusable does not behave correctly in PIE
        Fixed! UE-47612 [CrashReport] UE4Editor_Engine!UTextureRenderTarget::GameThread_GetRenderTargetResource() [texturerendertarget.cpp:44]
        Fixed! UE-47277 Sequencer actor path does not always update in VR Mode
        Fixed! UE-47151 GearVR trackpad quadrant buttons not detected in TM-MotionControllers
        Fixed! UE-47337 GetHMDWorn not visible to blueprint, delegates not hooked up
        Fixed! UE-47218 GearVR screen percentage is broken when not 100
        Fixed! UE-47157 Command console is really small on Oculus Rift

        REMEMBER: Please report any new bugs you find to the UE4 Answerhub in the 'Bugs Reports' section.
        (How to Report a Bug)
        Stephen Ellis | Senior Engine Coordinator


          wohoo , Lots of fun stuff to play with.
          Twitter - @TheKRushin

          Feel free to ask questions and come learn to be an #UnrealDev

          How to report a Bug


            Who have tried to export something complicated into HTML5? Such as Zen Garden here from 4.16 announce.


              P3 unfortunately still does not fix the new 3D widget performance problems in 4.17 on mobile VR:
              Headgear - VR/AR solutions


                Screen Percentage bug in VR - please fix it, in Post Processing there is Misc setting for screen percentage and it break VR experience 100%, it only affecting as Zoom and break every application. This bug is critical and still exist in 4.17 P3 version.


                  Assertion failed crashes when loading a dev build client of a project..

                  Same problem in 4.17 preview 2 and 3. This problem does not exist on any other Unreal Engine version prior to 4.17.
                  Last edited by MADHOUSE; 07-26-2017, 06:43 PM.
                  Where sanity is a virtue


                    Originally posted by mordentral View Post
                    I am not entirely sure how I feel about this new console command as it stands currently. While batching is always nice and performance improvements are great, even turning this value to 0 (defaults to 1 then due to a Max call) the behavior of updating physics bodies is different than in 4.16 and previous engine versions.

                    I feel like this is a regression in intended behavior as you would think with the feature essentially turned off that it would behave as it did before (IE not batch or wait to send transform updates).

                    For instance, if you re-scale an object its physics body won't actually be changed until the batched commands go through, so you essentially have to wait a frame after setting scale3D to handle any logic that depends on the physics thread scale of the body.

                    This indirectly breaks any form of fast transform updates to a simulating object.

                    In 4.16 and before I was able to dynamically re-scale a simulating object while it was held with a PhysxConstraint, however in 4.17 it hitches badly with the same operation. I can directly alter transform on it with its BodyInstance and it has no such problem, however to get the game thread version to also update setting scale3D on it causes the batched physics change to also be called. There is no separate path to manually scaling the physics representation and the object itself due to the UpdateTransform function always being called from SetScale3D and always posting to the physics thread eventually overwriting manual changes to the PxRigidDynamic.

                    *Edit* It kind of feels like there is a body lock that doesn't go away until the actual update happens.
                    Hello mordentral,

                    I've tried a few things to reproduce the hitches you're mentioning but I haven't seen anything on my end. Could you please make an Answerhub post about this in the Bug Reports section and include a project that reproduces the hitch that you're mentioning?


                      Can someone say if there're any updates on modding?

                      Originally posted by Stephen Ellis View Post

                      Gameplay/Scripting Updates:
                      The Asset Manager now has Blueprint access and is ready for production. The Asset Manager is a global object that can be used to discover, load, and audit Maps and game-specific asset types in the editor or at runtime. It provides a framework to make it easier to create things like Quests, Weapons, or Heroes and load them on demand, and can also be used to set up cook and chunk rules when packaging and releasing your game. The Asset Manager tab in Project Settings can be used to set up the rules for your game. Primary Asset Types that are scanned by the Asset Manager can be queried at runtime before they are loaded, and can then be asynchronously loaded on demand. To use the asset manager, call functions on the native UAssetManager class (which can be subclassed for your game), or call Blueprint functions in the Asset Manager category such as Async Load Primary Asset.
                      Does this mean that we could make a game easily moddable like Robo Recall or this doesn't have anything to do with that?
                      ProBoon, Old-School FPS, Open Source & Tutorials
                      Support Project Boon on Patreon

                      On Steam Soon, Click Below


                        Originally posted by Matthew J View Post
                        Hello mordentral,

                        I've tried a few things to reproduce the hitches you're mentioning but I haven't seen anything on my end. Could you please make an Answerhub post about this in the Bug Reports section and include a project that reproduces the hitch that you're mentioning?
                        Sorry, I hadn't been able to test on the latest preview 3, was waiting to do that before submitting a bug report.

                        Good news is that it appears to be functional again in preview 3, apologies for not getting around to it before you had to look into it.

                        I'll edit the original post to mention that its been fixed too.

                        Consider supporting me on patreon

                        My Open source tools and plugins
                        Advanced Sessions Plugin
                        VR Expansion Plugin


                          Did reimport behavior change in 4.17? I used to do Import to replace skeletal meshes instead of reimporting them when I needed special settings (instead of changing them in Persona and reimporting there), but now it seems like using Import just reimports with the same settings. It's a bit weird because if you only reimport the mesh the animations don't update, I guess the skeleton doesn't update when reimporting only the mesh.


                            Originally posted by masterneme View Post
                            Can someone say if there're any updates on modding?

                            Does this mean that we could make a game easily moddable like Robo Recall or this doesn't have anything to do with that?
                            Doesn't really have anything to do with modding.

                            Michael Noland


                              Just want to let everyone know I've been working on android/daydream apps and the new audio mixer system is really cool. In terms of immersion just having spatial attenuation greatly increases the immersiveness of a game. Also, it is my recommendation to try and bring in the very latest version of google vr plugins for the eventual 4.17 release. I am fairly certain this recent commit, uploaded yesterday, solved an incredibly irritating problem I was experiencing in both 4.16 and 4.17 involving visual artifacts/erratic behavior of the virtual motion controller: . I don't feel confident enough in myself to say there was a definite cause and effect relationship -- quite honestly I don't understand the code that was changed -- but after I downloaded and then rebuilt everything in visual studio using this particular version of the set of google vr motion controller plugins, used in conjunction with a 4.16.2 version of the engine, my problem went away completely. I am just barely starting to learn visual studio and c++ so it's just as likely I accidentally hit some checkbox somewhere in some blueprint to either cause or solve the problem I've been experiencing so take what I write with a grain of salt.
                              Last edited by jasonh2013; 07-28-2017, 12:56 AM.


                                In 4.17 there was some modifications for InstancedStaticMeshComponent. This did break our custom dynamic foliage spawner. It seems to impossible to now initialize batch of data to gpu.
                                In 4.16 I could just simply do it like this. Which worked like charm. But in 4.17 this causes crash.
                                So I figured new way to do this but the function that need to be called is in InstancedStaticMesh.h which is in private folder and I can't include it.
                                instanced->PerInstanceRenderData->UpdateInstanceData(instanced, 0, num, false);
                                Compile error and simplified example is here: